WiFi & tethering not working brand new V4K

Got my Vero 4K today, set it up and updated, and restored some settings/library from the SD back up copy of my old Vero 1. All works brilliantly and super fast compared to Vero 1, with a couple of exception.

Ethernet to WiFi Tethering doesn’t appear to work at all (it did on the v1). I have a stable LAN connection via Ethernet.

I have switched on the WiFi adapter in myosmc, which works after a few minutes. I can see WiFi networks, but I can’t connect to my local WiFi network unless I make it open. It rejects the password each time. I have tried using osmc skin, in case it was the input keyboard but it’s the same. I also strangely now have this issue on my Vero 1 but perhaps it’s always been the same as I never connected it to my network via WiFi…

When I switch tethering on (Ethernet to WiFi) it seems to disable the WiFi altogether. I have checked Connmanctl status and it says WiFi tethering is active.

I used Tethering on my Vero 1 (updated to latest version of osmc) with no issues, so surprised it doesn’t work on 4K.

Log uploaded /ruyehayije


When you say it doesn’t work:

Can you enable it?
Do you see a WiFi Hotspot?
This is a bit vague.

Is SSID hidden?
2.4 or 5G? Are 2.4/5G using same network name (avoid this if possible)
Are you using WiFi encryption?

Thanks for your reply Sam. Sorry to be more specific, this is two issues - Wifi connection and Tethering:

V4K Ethernet connects to network just fine with passphrase.
V4K Wifi adapter can be enabled. It sees wireless network (WPA2-PSK, AES, 2.5Ghz SSID visible) and can connect to it but not consistently. It is on the same network as the ethernet connection so will try a different one.
[Vero 1 has same issue now I notice, as I have moved it to a room without ethernet access]

I disconnect V4K from wifi network (if it’s connected) but leave adapter enabled. When I go to ethernet to wifi tethering, it says it’s enabled as osmc_wifi but I can’t connect to it on my Viera TV or Ipad or macbook. I have tried manually entering the connection in case SSID is hidden, but same result no connection. I looked at Connmanctl via ssh, it says wifi tethering is already enabled.


Okay, so WiFi connection to an AP works, it’s just tethering that doesn’t?

The tethering can be hit and miss, but connecting to an AP should work reliably


Wifi connection to AP sometimes works, Tethering never does. It used to work fine with all same settings on vero 1 running latest OSMC (Oct) so assume this could be a hardware thing?

…just to add I have added a wifi dongle to the Vero 1 and it seems to connect fine to Wifi now, albeit slower. Would it be worth trying it on the V4K to see if that triggers tethering?

Let’s fix one problem at a time first: connecting to APs.

The GUI isn’t always descriptive when there’s a problem connecting to a WiFi network. If you’re familiar with the command line, you could try connecting via that. See Could not connect to Wi-Fi - #16 by DBMandrake.

Any errors will be a lot clearer. OSMC won’t connect to WiFi on reboot if an Ethernet cable is attached. This is intentional.

Tethering is a bit hit and miss with ConnMan. It may be an idea for us to use hostapd or something else in the future.