Wired connection stopped working after upgrade

Was watching a movie over NFS, it asked if I want to upgrade I said yes, it rebooted and now my wired connection won’t work. WiFi is working fine, but I would rather be physically connected.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

That’s just a Kodi log. I suggest you either run grab-logs -A from SSH or use My OSMC log uploader and choose “all configs and logs”.


Can you take a photo of My OSMC -> Network -> Wired?


Try rebooting your router, then reboot the Vero. You are getting an odd IP address

which IP address is odd?

The 169.254.x.x address. It suggests that the device can’t find a DHCP server.

Oct 22 16:02:34 osmc avahi-daemon[362]: Joining mDNS multicast group on interface eth0.IPv4 with address
Oct 22 16:02:34 osmc avahi-daemon[362]: New relevant interface eth0.IPv4 for mDNS.
Oct 22 16:02:34 osmc avahi-daemon[362]: Registering new address record for on eth0.IPv4.

I have rebooted router and and vero and retried still not working, is there a way to force the vero to renew DHCP lease?

Have you turned off the wireless network? Having both wired and wireless on at the same time could be a problem.

Try setting the IP address manually in MyOSMC and see if that works.

I only turned on the wifi after it had failed the wired way.

It doesn’t even bring up the option to configure network manually in MyOSMC.

Stupid question, have you tried a different cable/port?

Are you in a position to reinstall OSMC?


yes, I just want to make sure it’s not screwed up in my dhcp server or something.

Also, what is the best way to go about that on the Vero4k?

Did you check cable and port? Is the router port coming up?

the cable and port are fine, it is hitting 169.254/16 which means there is no DHCP server. but there is one and I have the lease active, it just won’t take it.

You could try reinstaling OSMC from Download - OSMC
Or we can debug it with ConnMan.

Does static IP work?