Wrong aspect ratio on Live TV - OSMC RC2, RPi2, TVheadend, HDHR EXTEND, US Cable (Cox) ClearQAM

So i’ve got a setup going and can view live tv but i see the wrong aspect ratio. my 16:9 channels look more like 4:3 and my 4:3 channels look like 9:16 (that is, taller than they are wide, like your cell phone turned up right).

My OSMC screens/menus look fine, filling up the entire HD TV screen. It’s only the TV channels that have the wrong aspect ratio.

Anyone else having similar issues?

Is this problem only for live TV, or does it affect recorded films and other such videos?
There is an adjustment under Settings|System|Video Output - the line marked ‘Video calibration’ does what I want.
Cautionary note - some repeated old stuff is broadcast as 4:3 rather than 16:9 (since that is how it is in the archives).

In settings under video, and playback there are 2 settings…

“Allow Error in aspect ratio…”


Display 4:3…

if not, are you using TVheadend as tvserver software?(kodi PVR addon) or DLNA from your tuner?

The problem doesn’t exist when i’m navigating around OSMC menus, only on Live TV. However, i haven’t tried playing any local media… i’m installing the media browser addon right now and will let you know if playing movies also shows the problem. Also, i have another HTPC running WMC and the same TV stations play in 16:9 format with great resolution (in US, using cable feed playing ClearQAM content). The resolution on my RPi2+OSMC+TVheadend really sucks as well, but i’m attributing that to the same thing that is screwing up my resolution.

Just another tid-bit of info… I have a roku with a Plex channel to play local media content. However, i have been unable to get an acceptable solution to live TV on the roku (though this is in the works). So, i bought a RPi 2 (along with all the cables, power supply, remote, etc…) to get OSMC up and going as my Live TV solution. To that end, i really only care about Live TV (though OSMC could do a lot more… maybe even replace the roku if i had a netflix app/addon for OSMC :wink: )

I just tried to double check and verify that i am using the kodi PVR addon. Not sure how to check (it’s not listed under addons like the media browser i just installed is listed), so going by memory, yes, i’m using the addon with TVheadend as the backend server (setting TVheadend up in a browser from a remote machine). I adjusted the “display 4:3…” setting to 16:9 and IT WORKED! However, my resolution is still HORRIBLE. So, i played around with the video sync setting to allow it to sync to video content (start/stop setting, haven’t tried the always setting yet). So, if you could offer some suggestions on tracking that down, that would be great.

@Gmoney i think this is a tuner issue, are you running the latest firmware for four hdhomerun tuner?..

have you try’d the hdhomerun kodi addon

So this is where the men are separated from the boys, so to speak. I’m not sure i understand exactly how to install this on my RPi2 under OSMC. I’ll give it a shot, but i may need a little hand holding.

And yes, i do believe it is a tuner issue. I think that the HDHR devices are highly configurable and there is some configuration that is getting messed up when TVheadend attempts to tune a specific channel. My guess is that the tuner is trying to transcode to a codec that is not needed and OSMC is just dealing with it the best it can. Or, perhaps the tuner is not transcoding at all and it should be. I attempted to use hdhomerun_config (while TVheadend had tuner0 in use) to determine what mode of transcoding the HDHR was in (mobile (up to 720p30), heavy (up to 1080i60 / 720p60), native (no transcode)), but i couldn’t figure out how to query that using hdhomerun_config.

Ahh… found several commands for hdhomerun_config

$ hdhomerun_config 10507BF9 get /sys/features
channelmap: us-bcast us-cable us-hrc us-irc kr-bcast kr-cable
modulation: 8vsb qam256 qam64
auto-modulation: auto auto6t auto6c qam
transcode: heavy mobile internet540 internet480 internet360 internet240

So, the transcoding options are not what i previously stated. So, now i query the tuner that is used by TVheadend:

$hdhomerun_config 10507BF9 get /tuner0/program 119
703 transcode=internet240

I’m no expert here, but i’m betting the lower that number (internetXXX), the lower the quality of transcoding or at least the lower the resolution. I’ve done a very small amount of googling and cannot find how to force the tuner into a particular transcoding mode. There is some documentation (that seems out of date) that allows you to block any particular transcoding mode, so theoretically, i could block all but the one i want to try. But i haven’t figured out how to do that yet.

Also, although the dsiplay setting (mentioned above) helped fix the aspect ratio issue, i’m betting that’s more of a band-aid solution. If i fix the resolution issue, i’m betting the aspect ratio issue gets resolved automatically.

Ok, another update. I contacted SiliconDust and it turns out, in addition to the hdhomerun_config and hdhomerun_config_gui utilities/scripts/programs, the device has it’s own webpage. Just put in the HDHR device IP address in a browser and go (I bought my tuner used on eBay and have no documentation for it :frowning: ). From there, you can set your transcode mode (i tried none, heavy and mobile). However, once i started playing with this, the TVheadend server and/or the PVR addon in OSMC started acting funny (paused/skipped/dropped the stream and the PVR addon kept disconnecting from the TVheadend server). Just plain unstable. But… i reverted back to default settings for video display, the ones mentioned in @HarryL 's post above (post 3). Once i reset those settings to default, the video displayed in the correct aspect ratio (though was still not great resolution and the intermittent pausing stream remained). However, i did not rescan the muxes, yet :wink:

Still desperate, i installed the HDHomeRun Live TV addon for kodi (URL that @HarryL listed above, post 6). It was super easy, with a caveat: I’m pretty sure you need the libhdhomerun-dev package installed. I already have this installed from my TVheadend endeavor. For info on installing that package, see @HarryL 's instructions on this, found in topic 1608 post 14 ( OSMC RC Unable to install TVHEADEND - #14 by HarryL ). If you follow those instructions, you will need to replace the following line (in the rc.local edit instructions)
/usr/src/tvheadend/build.linux/tvheadend -u osmc -g video -C &
/usr/src/tvheadend/build.linux/tvheadend -f -u osmc -g video -C &

With the HDHomeRun Live TV addon, you can force the transcode mode from OSMC. I used ‘none’ and have a great looking image with the correct aspect ratio and no stream disruption. The interface is not as intuitive (the channel up/down buttons don’t work… you have to use the right button to expose the channels, then the up/down buttons to scroll). However, you do get the channel name, like WHDLA or WSERE, etc., without the pain of setting up the EPG data. And, if you are using an antenna (in the US at least), the guide will be auto populated for you (my guide is not in the public domain, so the addon cannot fetch it… same issue on my Win7 WMC setup)

With all this said, shy of my problem being resolved once i rescan the muxes in TVheadend, it seems that there are some issues with TVheadend and the PVR addon. I know a bunch of other people are using this setup successfully, and @kphammond9 even has the HDHR (EXTEND??) device (same as mine) in the US up and running with this setup, although using an antenna (ATSC) not a cable (ClearQAM) input like i am. Using an antenna affords the ability to use predefined muxes, which doesn’t work for me. Again, a lot of people are defining muxes themselves, like i am, but not in the US with US-cable-irc type muxes, that i know of. If that’s you, please respond and let me know what you did… cause i’m pulling my hair out over this.

im unsure of what works and what doesn’t work for you… but if it’s a tvheadend issue try looking in there forum http://tvheadend.org


the app store version is now working, try that should work better.

Indeed it does work better, though not as good as the HDHomeRun Live TV video addon.

I started with a completely fresh install of the latest OSMC (2015.06-1). I added the HDHomeRun Live TV video addon as a base line. That works seamlessly with great resolution, no stuttering and no issues with sound for all channels. I then loaded the App Store version of TVheadend server followed by enabling the HTSP TVheadend Client (PVR Addon). I noticed that now i have to use a username/password (osmc/osmc of course). I remotely connected to http://osmc:9981/extjs.html?# , created my network, enabled my adapters and selected my network, manually added my muxes and then mapped all services. I configured the PVR Addon (entered UN & PW) and began surfing the channels. The video came in with no stuttering and the resolution seems to match that of the HDHomeRun Live TV Addon. However, a couple of channels didn’t have sound at first. If i waited long enough, the sound would come in but the video would instantly start tiling (when this happened, none of the cpus were over 10% utillization). Also, on some channels, the video can sometimes take a bit to display (get a black screen until it does), but eventually comes in. I occasionally saw some stuttering as well. And then it happened… HTSP TVheadend Client disconnected from the server. When it reconnected (automatically), there was a message that said “No Free Adapter”. When i go back into the remotely connected browser window, i notice that there is not adapter listed any longer. I then fired up the HDHomeRun Live TV Addon once again and it immediately connected to the HDHR tuner and began playing the video stream from the selected channel.

I rebooted the system and enabled debugging (logging). I started changing the channels, but i would wait longer (stay on that channel) when i noticed issues with tiling or audio. At one point, a channel that had no audio at first, then with audio but a tiling video stream, eventually came in “sync” and had good audio and video. But the next time i changed the channel, i got nothing (black screen no sound). I kept changing the channel but couldn’t get anything to come in. I never did get the client to disconnect from the server nor did i see the “no free adapter” message again.

For what it’s worth, here’s the log file.

Also, just tried to uninstall the app and disable the addon, but i still get a message on boot up that says no pvr has been enabled (or something like that). Is there a system file that i can edit to keep that message from displaying?

the pi does struggle with 1920x1080 @ 60.00 especially pi1, but it does work it just needs time…i think it’s a network/bandwidth issue. i have seen that it’s best to press stop and then change channel… probably a pvr addon issue.

you can test it on your laptop with kodi installed or VLC and use playlist like so http://OSMC_ip:9981/playlist.


@HarryL, I hear ya. However, the HDHomeRun Live TV addon that you pointed me to works flawlessly, with no PVR capability of course. When Silicondust (maker of the HDHR devices) comes out with the PVR functionality, the question will be, where to put it?.. in the pi2 or in my Synology NAS. If it goes in the pi2, it will be interesting to see if i have the same issues as i do with the TVheadend setup.

I guess there is one more option and that is to purchase another pi2 and run the backend on it. This might be the cheapest and most straight forward option anyhow. Do you think that would help alleviate some of my issues?