Xbox series X controller bluetooth connection

Has anyone had success pairing a series X controller to the Vero via bluetooth? Usb works fine but I would prefer using bluetooth.

The only other threads I have found on this were in relation to the older xbox 360 and xbox one controllers. I have already tried disabling ertm with no luck. The controller seems to pair via MyOSMC, but I don’t get any vibration feedback, the logo keeps blinking and the inputs don’t respond.

In bluetoothctl I can see the controller pairing and the prompt changes to Xbox Wireless Controller but same response. I also tried manually pairing the controller but again, same response.

It seems many people across the web suggest xpadneo | Advanced Linux Driver for Xbox One Wireless Controller (shipped with Xbox One S) . I am running matrix; is DKMS still not recommended?

DKMS isn’t recommended in general for kernel updates.

I have an Xbox X Series X and the supplied controller.

How do I put the controller in Bluetooth mode so I can pair it with the Vero or attempt to do so? For now it’s just paired to the console.

On the front on the controller between the two shoulder buttons there is a small black button offset to the left. If you tun on the controller using the central logo on the top and then hold down the small black button on the front until it flashes rapidly, that is the controller entering pairing mode.

I am on holiday now - so can’t look at it at this time.

Hey Sam, let me know when the dust has settled and you have time to look into this. I’m willing to be a guinea pig since I have two series X controllers and a little linux knowledge. I’m having a lot of issues with these controllers - even when plugged in via USB;

Detection

  • Controllers vibrate on vero boot but both are turned off (Logo LED is off) on OSMC boot.
  • Turning controllers on using the Logo button, the logo LED flashes and fails to find controller, LED turns off after some seconds
  • Turning on the controller again using the logo button the controller is sometimes found, sometimes not

If a connection is managed, sometimes straight after, or after a period of time the controller will start to intermittently disconnect and reconnect.

  • Disconnect / Reconnect cycle can happen multiple times in a row, sometimes never reconnecting
  • Unplugging and replugging the USB cable sometimes helps finding the controller (the LED stays solid) but soon after starts the disconnect cycle
  • D-pad responsive input delayed (left thumb stick is ok). Sometimes it seems the D-pad inputs are duplicated / repeated / ‘stick’ so quickly alt or double tapping the D-pad will mean navigation gets stuck going left, right etc
  • In retropie, after some time the controller will disconnect and the LED will turn off. When turned on, the disconnect cycle will start

Asides from the basic input issues, there are some QoL issues with the Series X Controller too

  • Logo LED light is blindingly bright at all times when connected
  • During ‘Controller Configuration’ in OSMC it nearly always triggers the ‘Press all analog buttons now to detect them’ pop up at least once on the initial setup. This popup doesn’t seem to solve anything and knocks you out of the controller setup flow.

And something specific to the retropie / retrosmc add-on, the logo and share buttons aren’t recognized in controller setup (I will post in that thread)

I never had these issues with the xbox 360 or xbox one controller (I don’t have either any more to test) but basically I would turn on the vero and the xbox one controller was usable straight from boot with the LED on (and not blinding) and no connection issues.

https://paste.osmc.tv/ceyivomoce
https://paste.osmc.tv/iyeweviwir

I have a controller – so I can try pairing.

What should I be testing the controller on however (just navigating Kodi?)

Hi Sam, yes you can try navigating OSMC / Kodi. Reproducing the issue is seemingly random, although I find even more often than not, on OSMC boot with a USB cable plugged in, the controller starts off disconnected and struggles to connect when the logo LED is pressed.

If you do manage to connect, you can eventually see the issues after a period of time on the RetroPie addon from hissingshark, i usually just use the default PSX emulator.

I will let you test first, but I can try another fresh wipe since I might have installed bluetoothctrl after, but it isn’t on and bluetooth in MyOSMC is disabled, so I assume that shouldn’t interfere

I should also remark that this happens regardless of being plugged into a USB hub with other peripherals or being plugged directly into the Vero with nothing else attached

I updated through the gui to 2021-21.1 but still having issues with the series X controllers even when connected by USB cable.

I haven’t ssh’d into the box to update using apt - is that still advised against?

Is there something I can do to help the team investigate? Do you need newer logs?

Try the staging repository first.

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb http://apt.osmc.tv buster-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

I’d also recommend you deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

So I finally had some time to test this. On the staging repository (installed about a week ago) I can confirm that using a wired connection with a controller works, so long as you disconnect and reconnect the controller on boot. It works completely fine for hours, and OSMC seems to recognize the logo button (retropie does not) - although the led light is still pretty blinding.

A second controller on a wired connection however has the same issues as on the release; it turns off after some time, button presses are either not registered or register as repeating long presses.

Bluetooth still doesn’t work. That said, the gui connection process at least recognized and connected the controller pretty consistently this time, although even when listed as connected the controller would keep searching for connection. I didn’t check command line output for bluetooth.

I am really happy you guys have managed to integrate wired support for at least one controller, so thank you for that. I hope you guys manage to implement support for a second controller (and dimmer logo led lights) soon.

I am happy to keep testing.