3 keys on OSMC Remote Control do not work anymore

The following keys on my original Vero 4K+ remote don’t work anymore:

  • back key
  • play/pause
  • stop key

Tried with a new battery without success. All other keys are working fine.

Have you tried re-pairing the remote?

Hold Home and OK

OSMC remote pairing wiki: Pairing the Original Black OSMC RF Remote Control with a Pi/Vero2/4k/4k+

Re-pairing following the wiki didn’t help at all.

Have you check that they physically work (no dirt blocking them)?


So you see a blue light when they are pressed?
Do you know how to use SSH? These buttons go through a slightly different input pathway, so something may be broken on the software side of things.

Can you also upload a set of logs via My OSMC -> Logs and send us the URL.


Yes, the blue light is on when I press the buttons.
SSH is no problem for me.

Here’s the log:

I had/still have this exact problem sometimes, usually just reboot it until it starts working again

Rebooting did not solve the problem here.

It’s not a debug log so hard to see if the presses are being registered, but you could stop Kodi (sudo systemctl stop mediacenter) and eventlircd and use evtest to verify the button presses are being detected.


I have installed evtest now, how do i stop eventlircd?

Cosmc@vero:~$ sudo evtest
No device specified, trying to scan all of /dev/input/event*
Available devices:
/dev/input/event0:      gpio_keypad
/dev/input/event1:      cec_input
/dev/input/event2:      DaKai 2.4G RX
/dev/input/event3:      DaKai 2.4G RX
/dev/input/event4:      OSMC Remote Controller  USB Keyboard Mouse
/dev/input/event5:      OSMC Remote Controller  USB Keyboard Mouse
/dev/input/event6:      meson-ir
/dev/input/event7:      lircd
/dev/input/event8:      eventlircd
Select the device event number [0-8]:

Which device is the OSMC remote? And what to do next?

What’s this? Did you try disconnecting this first?

Disconnected now, didn’t solve the problem…

There are two event pathways for keys (you will need to check each).
sudo systemctl stop eventlircd should do the trick

Okay, it’s
/dev/input/event2: OSMC Remote Controller USB Keyboard Mouse

I get the following when I press the mentioned keys:

Testing ... (interrupt to exit)
Event: time 1556134689.907232, -------------- SYN_REPORT ------------
expected 16 bytes, got -1

evtest: error reading: No such device


Did you try with the other input?

If that happens again, can you run grab-logs -A and send me the output?
Have you tested on another device?


Yes, the the other input doesn’t react on any key press


I have no idea how to test that. Tried to learn/control my Apple TV 4k with the remote without success.

I also have the same problem after the update.
I have proven everything that is discussed in this post and it does not work for me.
Any ideas?

Thank you.