3D Frame Packed output

On Previous Beta I had 3D working (installing/activating a beta verion via CLI)
With the current release my Vera 4K+ is not playing 3D frame packed material in 3D? Any idea why this is happening? Should I execute some CLI command to get it working again?


I’ve fixed it (at least I do hope :slight_smile: ). The fix will be part of the next testbuild.


@sam_nazarko Any timeframe for when we might see that next test build?

1 Like

Nice work @tanio99, looking forward to the next build.

1 Like

I don’t have an ETA at this time.
But we keep moving forward with things


Thanks it is working again. Did not realise that 3D was still not in the main image.

I follow all steps to instal 4.9 because i lost 3D, but my Vero 4K+ don´t receive update after reboot. Some solution? I try to install sudo apt-get install --reinstall vero3-mediacenter-osmc=18.6.0-13… but neither works.

Please post logs so we can check if you have set up the repository correctly.

What is the output of this command?

Now works, thanks!

I should be receiving my Vero 4K today and I’m extremely excited!

I’ve ordered it for the MVC 3D support which I know is still a bit unsupported.

Do I need to install v18.6.0-13 using the above command?

Also, I really hope that this feature gets re-implemented back into the main branch for the latest versions!


It will.

I experienced the same issue mentioned earlier in this thread by @pab11 where he was unable to get right-eye first 3D files to play correctly, nor would the swap eyes feature do anything. I finally figured it out and just wanted to share with the forum. I am running the OSMC June '20 edition on a RPi2. My solution was to disable the OMXPlayer hardware acceleration. I previously had this option (along with the MMAL acceleration) enabled. Turning off the MXPlayer option leaves the player playing all 3D MVC files perfectly. Hope this helps someone else.

This thread is about the Vero 3D frame packed output, not playback on Pi.

I don’t know if this would help, but I use both MakeMKV as well as CloneBD for ripping my 3D-MVC files. If you want me to rip something using CloneBD for testing anything I would be happy to do so.

1 Like

Thanks for your offer. I think I’ve fixed that issue, so currently there’s no need. But it’s good to know that you would help if needed!


I can’t get the Frame Packed 3D working and I don’t really know why.

As per the Install instruction in the first post I went to the 4.9 topic and:
updated my Vero through “My OSMC”
logged in via ssh/console and edited sources
ran the update/upgrade/reboot commands

It does play 3D MVC files and it does offer me “Hardware based” when playing one of the files but the output is still 2D.

Did you also ran the downgrade sudo apt-get install --reinstall vero3-mediacenter-osmc=18.6.0-13

I have not done this. Is that the final step? (does the note in the first post implicate that I should have done that?)

No but it was mentioned in the last release.
So that step currently is needed till a new 3D version is released.

1 Like