3D Frame Packed output

That’s right, provided you enable Adjust Refresh Rate.

If you play something with HDR properties we will send an HDR EOTF. Usually your TV will also show something like an HDR logo too.

It is a bit more complicated than that. That setting is for the GUI but also sets the output resolution and frame rate of playing video IF you don’t have adjust refresh rate enabled. If you have adjust refresh rate switching enabled then video will be output at the GUI resolution and higher at an optimized frame rate. A whitelist with refresh rate allows for output both above and below the GUI resolution depending on what is set.

If you use the recommended settings your should get HDR output during playback and when the video starts you should see on your LG and black screen followed by a HDR logo in the top right corner display for a couple seconds. If not already enabled on your LG you will have to enable “HDMI ULTRA HD Deep Color” in its menus.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Thank you @sam_nazarko @darwindesign! I have set it to the above settings and it is 99% awesome!

As far as it switching into 3D TAB/SBS automatically, it seems to actually do that with TAB files, but not SBS files. I tried several and that’s what happened, but I will do some more testing.

As far as HDR goes, I think I am getting it. I am just getting the notification so quickly it’s barely noticeable. On my TV it comes in on the bottom right which is below the progress bar etc. That combined with the fact it takes a few seconds for the picture to appear, I think due to refresh rate syncing with the source file. By the time the pic comes on, I just barely catch what I think is the HDR notification.

I have to say, I love it!

How are your files named?

Does your TV remote have an Info button? That should tell you what type of input signal you’re getting. Failing that, if you hit the Settings button on your remote (probably a cog wheel label) and go into the the View Mode menu (probably a white-mountains-on-blue-background icon) you’ll probably find the names of the available modes are different, depending on whether you’re in HDR mode or not. For example, non-HDR modes might include Expert (Bright Room) and Expert (Dark Room), while HDR modes might include HDR (Standard) and HDR (Bright).

EDIT: I don’t have your model of TV, but mine is an LG model of similar age, so I hope yours works similarly.

What issues specifically are “gone”? Thanks.

Since I use Plex and that has no specific functionality for 3D I use their recommendation for the main movie naming and add something like " - 3D-TAB" to the end of the file name. For example it would be something like:

“The Avengers (2012) - 3D-TAB”

I’ve never had any circumstance where I could play 3D through Plex before outside LibreELEC and I never really questioned it. I just put it in 3D manually if need be.

I do the same thing with the MVC files (“Movie (YEAR) - 3D-MVC”) and those have 100% worked fine in switching it to 3D mode, but I realize there is something different about the stream itself and that may be why those work.

Do the SBS files have SBS in the name instead of TAB?

Yes sir. They would be named “Movie (YEAR) - 3D-SBS”.

My library is consistently named, but that doesn’t mean it’s named in the optimal way for 3D recognition. This is new ground for me! Like I said earlier, I’ve only ever used LibrELEC on a Pi3 and that worked great for 3D-MVC. However, I didn’t even try to use it for anything else. It was a one trick pony.

I haven’t had time to try this yet. I normally use a Harmony Hub for all my consumption so I need to look at the original “Magic Remote” that came with the TV.

Grab a copy of mkvmerge (if you don’t already have it), and open up the files and check the “stereoscopy” metadata field on the video, and see if the video stream was properly flagged as SBS (or TAB, etc). If you were downloading from the internet, they probably were not. If not, set the correct value, and remux. It should play properly then regardless of what you named the file.

btw, “mk3d” is actually the proper extension for 3d mkvs, so that’s what mkvmerge will want to save it as once you flip switch the metadata to 3d, kodi doesn’t care which extension is used though, both are recognized

Note there are both left-eye-first, and right-eye-first options, left first is the usual, but some sources are right-eye first, so if it looks funky in 3d, you might need to switch it)

1 Like

I can open a file in MKVToolNix GUI (which contains mkvmerge) and use the header editor. There is no metatag called “stereoscopy” but there is one called “Video stereo mode”:

I’m trying to figure out what the value “3” means still…

When I make 3D remuxes in this same program (which I use a lot) it does try to make a file with a that .MK3D extension. The problem is that Plex won’t see these files normally (I think you can tweak something for it to work) so I name them all .MKV. I don’t know what the implications are in name for Kodi because I don’t use Kodi’s or OSMC’s metadata capabilities. it’s all about Plex. I even use my Vero4K+ with the “Plex for Kodi” add on. No SMB drive mapping permissions Windows share garbage. Just log in as my Plex user and OSMC sees all my content…:wink:

I’m aware of this left/right eye thing, but I’ve never changed a rip to “right eye first” and I don’t recall having any issues. Perhaps I just haven’t run across a ti9tle that had that setup?

So long as they’re correctly labelled in the metadata, the Vero should handle right-eye-first mkv files automatically. If it ever doesn’t you can switch eyes manually during playback. I wouldn’t worry too much about that.

1 Like

Are you aware of a way to determine the metadata discussed above? How about file naming? Is there a correct way to do that for 3D files?

if you go to the “multiplexer” tab, and click on the video stream, on the right there will be a “stereoscopy” dropdown under the video metadata section, which you can just pick “side-by-side-left-first” (or whichever applies), and then remux. you probably can look up the ID number for the mode you want and adjust it in the header editor, but I usually find it easier to use the remuxer. (I often strip out audio streams and subtitles for languages I don’t understand for a lot of videos as well, or change the order)

this has the list of numerical codes you can use in the header editor

[edit, link to the mkv specs instead of the blog]

1 Like

Awesome! Thanks! I see on mine that it is:

“3 - top - bottom (left eye is first)”

That would be accurate! Are you saying that OSMC should be reading this tag and operating appropriately based on what is reads in the Matroska container, regardless of what the file is named as?

I too will often remux when I need to make changes. Most often it’s because I want to add an audio file, remove tags etc. For example I’ve had 4K/3D box sets where the 4K version had better quality audio and wanted to add those tracks to the 3D rip. When you get to the large files though I am finding it much faster to use the header editor for certain changes.

I noticed that MVC is called “both eyes laced in one Block” in that Matroska spec. I guess that’s the technical definition? lol

It does for me. As long as I make sure the stereo flag is set correctly, it always plays correctly, and I don’t have to worry about the naming. It’s the first thing kodi checks to decide if the video is 3d or not.


That being said, I’m not sure what flag is used for MVC, I don’t see FP listed in the mkv spec.

1 Like

I think that’s right, yes. It pays attention to the file name if the correct container information isn’t available. (Is that right, @tanio99 ?)

Just because I never miss a chance to be super-pedantic about something: MVC and FP aren’t exactly the same thing. MVC refers to the way the 3D frame data is encoded into the video file; FP refers to the format of the HDMI signal that the box eventually outputs.

1 Like

ok, that makes sense. So, for MVC, how is it flagged as 3d? or is the 3d data part of the codec itself and not need a metadata flag?

1 Like