3D Frame Packed output

For 3D, we primarily rely on regular expressions against the filename to give us hints as to how the file is encoded.

I’m sorry Sam, but that’s not correct. The naming is used as fallback. The stereoscopic info is taken from the hints returned by ffmpeg. If no stereoscopic info is present, the filename is used to detect the 3D info.

So @angry.sardine is right:


So if the filename is the fallback, is there a correct naming guide that I can follow?

Like I mentioned before, Plex doesn’t care nor can it do anything with 3D so I’ve never pursued “proper” naming. The Plex metadata agents generally ignore anything after the “(YEAR)” in the file name so it doesn’t really matter what I put there. I just made up my own.

That being said I am going to go back and make sure all my 3D stuff has the correct metadata tag. It would just be good going forward to name them the correct way if it exists.

Thanks for all the help!


1 Like

Thanks! Like I said I don’t use Kodi natively for anything.

This link took me down the rabbit hole though and I landed here:


On the macroblocking issue, curious what other titles have this besides ‘Avatar’?

I know that Gravity has it, too.


And A Christmas Carol

1 Like

Thanks, will keep a running list w/my review on Kodi forum. Helps me as I’ll use my Zidoo Z9S to play these movies.

Recall ‘Ready Player One’ is another one.

Of the titles listed I own “Avatar” and “Gravity”. I’ll try this myself when I get a chance. I already have them ripped to MVC.

Something else I have found: sometimes I notice, particularly when I’m in the menu of OSMC that the overscan is off and I am missing some of the picture around the edges. I will go into the settings and re-adjust it so it’s perfect. At some point it goes back to whatever it was though.

Since the new 3D build was released I have noticed several small updates waiting for me when I use the player though (which is always on in the background) and it may be that I’m seeing this after updates. I haven’t confirmed this is the pattern though. It might be related to something else.

I will keep an eye on it and if it has nothing to do with the new 3D-MVC build I apologize. Feel free to move the comment if appropriate. I just wanted to give feedback here first because I never noticed it before.

Other than this it has been AWESOME! I absolutely LOVE having a player that can play it all! (except commercial streaming channels which I may progress to trying some of the plugins for…if I feel confident)

Don’t do that. Set your TV correctly to 1:1, Just Scan, or however it is named on your TV

I don’t know what this means. The TV itself hasn’t changed nor has the output of any of my other devices on the same AVR/TV setup. The Roku Ultra isn’t having this issue, nor is the Shield.

Am I misunderstanding your suggestion?

Which TV Make/Model do you have then we can tell a bit more exact.

Generally you should not see overscan and if that is the case then a configuration on your TV can correct it.

This is the model:

OK, I’d love to learn about this! My limited knowledge is telling me that any settings I change on the TV itself would affect anything that is plugged into it. but perhaps I don’t fully understand.

I also have a BenQ 2050 3-D projector that I have tried it on. It seems to be fine there, but that is only 1080 anyway. Most of my trials have been on the LG TV above and that’s what it is connected to currently.

OK, I tried both Gravity and Avatar this morning. Perhaps I don’t know what “macroblocking” actually is, but Gravity played flawlessly for the first 10 minutes without a burp. I stopped it at that point and moved to Avatar.

Avatar also played fine, but I got an occasional what I would call an “artifact” on the screen. It happened a few time in the first 10 minutes, but I chalked it up to maybe a glitch in the rip or something. Is that macroblocking? If so, what is that about? Is it some sort of copy-protection thing or something?

It is in the manual on the page you just linked to under settings->picture->aspect ratio. You want it set to “just scan” which disables overscan.


I will try this, thanks!

I presume that this won’t change how the other devices appear, but will this require me to “reset” the changes I made on the Vero?

What you’re describing in Avatar is the issue we’re talking about. I watched Gravity a few days ago and can confirm that it also pops up there (not sure if it’s in the first ten minutes, but it did pop up at least four or five times in the movie).
Honestly I have no idea what’s causing it. Apparently it’s something to do with the firmware written by the chip manufacturer, and unless they fix it it’s beyond Sam’s control.

1 Like

Is it JUST on MVC files or does it do it with other types of 3D like TAB/SBS files? It sounds like it’s related to MVC.

Frankly, if the worst that happens is an occassional artifact on a handful of movies I’ll live with it compared to not having MVC capabilities.

Do you know if it happens on the Pi3 builds as well or is it specifically related to the Vero hardware? I don’t know what’s in that box and there is a label that says “do not open case or we will hunt you down!” so I haven’t looked…:wink: