3rd party PS3 Controller (SHANWAN) with Kodi Leia

Hi there,

First of all I want to thank Sam and the whole OSMC Team for the extraordinary job on Kodi Leia for OSMC !

2 Years ago I bought a raspberry 3 model B with two PS3 third party (SHANWAN) controllers. On the raspberry Retropie was installed and the two controllers worked via bluetooth.
I formatted the SD-card and installed OSMC, but i couldn’t get those controllers working…

Some months ago I bought another Raspberry 3 but model B+. I thought that the problems concerning the pairing via bluetooth with one of the controllers would be solved with Kodi Leia. But with spending many hours in reading the old topics on this forum and others and trying to get it working I’m still unable to control Kodi with the SHANWAN controller via bluetooth.

Is there anybody else struggling?

Here are some short informations about my problem:

  • I want to control only Kodi Leia with a 3rd party (SHANWAN) PS3 controller via bluetooth.

  • I can’t see the controller in MyOSMC at the bluetooth section. I know the MAC-address by using the controller with the laptop.

  • The controller works via usb, but it is “vibrating”.

  • The controller works via usb (without vibrating) and via bluetooth with my laptop (windows).

  • It would work with RetroPie (I believe there was a package to install, which is called like the 3rd party controller), but I don’t need Retropie and only want to use Kodi on OSMC.

Thx for your support and inputs!

Kind regards SchmidiGonzales


Have you tried pairing from the commandline:

Thanks Tom.

Yes I’ve tried pairing via ssh, but the controller wasn’t listed…


Have you tried the controllers with bluetooth in either retropi or raspbian, to confirm?

Thanks Tom.

When I bought my first raspberry on ebay, Retropie was installed and both controllers were paired with bluetooth.


Looks like this issue may sneaked in to RetroPI recently aswell:

I suggest trying the following:

sudo hciconfig hci0 reset
sudo systemctl restart bluetooth
power on
( unplugg and re-plugg controller)
scan on
agent on
( unplugg and re-plugg controller)
connect XX:XX:XX:XX:XX:XX


Oh, ok.
I will test this tomorrow.
Thx a lot for your support!

1 Like

Hi Tom,
I tried to connect it as you wrote.
But the MAC-Address which I know by the connection with my laptop doesn‘t appear on the list (devices).
There is another new MAC-address which i tried to pair with.
But i got the error:
Failed to pair: org.bluez.Error.ConnectionAttemptFailed

Do you know any other solutions?


I’m suspecting this a stupid question, and I think I already know the answer. But whats the result of:


and using the MAC address shown windows, rather than one that is listed?

Also I’m not familiar with these controllers, do they have pairing mode?


I‘m thankful for your support, so there are really no stupid questions :wink:

Pairing with the known MAC-Address shown by Windows:
Device 05:AA:9F:82:63:25 not available

Pairing with a listed MAC-Address:
CHG Device 90:DD:5D:AF:ED:C8 Connected: yes
Failed to pair: org.bluez.Error.AuthentifictionFailed
CHG Device 90:DD:5D:AF:ED:C8 Connected: no

I don‘t know about other „pairing modes“ but you can press the ps button and then the lamps start flashing. So the controller is trying to connect with another device, and when paired, only one is shining.


“I plugged the PS3 controller in USB mode, waited 10s (the controller don’t stop vibrating), removed the usb and pressed the bluetooth button on the controller. It worked.”

This is from the github link I posted earlier. I suggest trying to plugin in via usb, see if it finishes vibrating and then try pairing again.


Hi Tom,
I‘ve tried to pair the controller again, but failed again…
I can confirm that the controller stops vibrating after unplugging and replugging within 10 seconds. But as I wrote already, the controller doesn‘t appear in the devices list in bluetoothctl and can‘t pair with bluetooth…


I’ve been looking in to this, and there seems to be issues with these controllers and latest versions of bluez (http://www.bluez.org/). I think you are going to struggle to get it work with any current linux distro. I suggest trying with the latest version of retropie, and report back. If it works there, Its more likely its something than can be fixed on osmc.

Regards Tom.

Hi Tom,

I’ve just installed RetroPie and the addon launcher. But because of a known issue I had to add a line to the RetrOSMC installation script as seen below:

After this I could install the ps3controllers in RetropieSetup, Manage packages, manage driver packages. Then in configuration / options I could install the PS3 Driver (Shanwan) and after that I paired it with "Pair PS3 controller (clone support shanwan).

Now it works in Kodi too :slight_smile:

Hopefully the OSMC Team can have a look into this issue.
And maybe someday it won’t be needed anymore to install Retropie just to pair a Shanwan clone with OSMC.

Thx a lot for your troubleshooting!
Kind Regards