After April update OSMC remote control problems + suspend not working

#1

I updated my Vero 4k + to the April update last Friday and suddenly have problems with the OSMC supplied remote control. It seems there is a lag or button presses are not always recognised. I have to press several times before something happens.

Is this a known issue and will there be a fix?

#2

Hi,

We’ve had some reports of some issues with IR based remotes; but not the OSMC remote. We will make an update available to address this in the next few days.

Can you try re-pairing the remote by holding Home and OK?

The suspend issue is being invesitgated

Sam

#3

Thanks for the quick reply Sam. I tried re-pairing the remote when it’s unresponsive and that doesn’t work. When I connect a mouse or keyboard I have no problems.

I checked the battery as well and it’s still fully charged (3V). What else can I do?

Alex

#4

Hi, just to be sure, you followed these steps: Pairing the Original Black OSMC RF Remote Control with a Pi/Vero2/4k/4k+ ?

#5

Hi Jimknopf, after following your steps it’s working fine again!

Thanks for the help.

1 Like
#6

Hi, my remote stopped working again. Pairing the remote does not work anymore.

Could the remote be faulty?

#7

Have you tried changing the battery? The cell is likely low.

#15

The suspend option will be fixed in the next update on Sunday.

#16

Hi Sam, I changed the battery and I’m still unable to pair the remote. After pressing the home and ok button for 5 seconds the blue light on the remote stays on but does not blink when I insert the usb receiver. When I reboot the vero with the usb receiver inserted the remote works but only temporarily. After a few minutes it stops responding.

I noticed that when the remote works correctly the blue light has a quick flash when pressing buttons and when it stops working the blue light stays on for approximately a second.

I also check in the OSMC settings and the correct remote is selected. Could I have a faulty remote or receiver?

#17

Can you please upload a log via My OSMC when the remote does not behave as expected?

Sam

#18

Hi Sam, I hope the upload was done correctly, I’m a bit of a newby with all this.

The URL:https://paste.osmc.tv/fajoravodi

I tried pairing on several occasions and rebooted a few times and this was unable to use the remote at all and was forced to use a mouse, hopefully it’s all in the logs.

#19

The dongle is being detected:

May 03 09:12:24 osmc kernel: usb 1-1: New USB device found, idVendor=2017, idProduct=1688
May 03 09:12:24 osmc kernel: usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
May 03 09:12:24 osmc kernel: usb 1-1: Product: USB Keyboard Mouse
May 03 09:12:24 osmc kernel: usb 1-1: Manufacturer: OSMC Remote Controller
May 03 09:12:24 osmc kernel: input: OSMC Remote Controller USB Keyboard Mouse as /devices/c9000000.dwc3/xhci-hcd.0.auto/usb1/1-1/1-1:1.0/0003:2017:1688.0001/input/input2

If you send an email to support@osmc.tv with your order number we can send you a new receiver. You’ll need to pair it with the remote again when you get it.

Sam

#20

Hi Sam, just sent you the email.

Alex

#21

Thanks

Sam

#22

Hi Sam,

Did you receive the email my wife sent you?

#23

What’s the ticket number?

#24

Is there a fix or workaround for the IR remote issue please? I use Logitech remotes to integrate the Vero 4k and it’s a real pain vs 17.X not having this work smoothly any more.

#25

The IR remote (assuming you’re getting repeats) problem was fixed a while ago. For now you can update to the staging repository.

Sam

#26

OK. Haven’t done that yet, though noticed that in the OSMC settings app under remotes RC6 appears to have “disables” highlighted against all the typical IR related libraries. I’ve reenabled one of those and things appear to be “normal” again.

#27

Hi Sam,

I just received the new receiver and I’m still unable to pair the remote. When I press home and ok for pairing the blue led stays on and does not turn off after the 5 seconds. Connecting the receiver to the vero doesn’t do anything.
I tried in windows 10 and the receiver is recognised but pressing the remote does nothing, every button press the blue led stays on for a long second.