After August 2021.1 update no hdmi output whatsoever

Hi,
after updating my pi3+ to 2021.1 on boot i get no hdmi output whatsoever. I even tried using osmc_installer with a blank sd with same results, no hdmi output.
2020.10 works like a charm though.
As I dont have scren output I cannot log into the pi to debug or grab logs (no ssh working either).

Regards,

Hi,

See the top one, please try updating again from the commandline.

Thanks Tom.

And how can i get a cli if no console is available…

Do you have another TV you can try to connect to?

sadly no, i dont

Hi,

Try SSH:

Thanks Tom.

What are the lights on the RPi doing during boot? Have you tried a different PSU?

Don’t mean to be rude, but on my first post I said that ssh is not working either.

Not trying to make circles with this, plain October’s image works fine, 2021.1 does not.
I cannot debug anything if I cannot get a shell or something (no ssh, and no video output).
Again, October image works fine. My tv and my PSU are the same.

I mention it as I had an issue with an update in the past that drew a bit more power than previous and it actually took my PSU past what it could supply maintaining sufficient voltage. That is also why I asked about the lights as if it is giving you a blink code that may give a hint of what is going on.

I think the Pi just halts, as there is no lights turning on except the red (power?) one.
My psu is fine, I tried even with a 3A one with same result.

So the October update works fine but when you try to install the new update after it reboots then you don’t even get the blinking green lights showing it reading the boot files?

Yup. Even if I try to burn a fresh image with osmc_installer the result is the same.

Hi,

:man_facepalming: Sorry completed missed that (Trying to do to many jobs here).

Are these official pi PSUs or equivalents (Such as the one available in the osmc store)?

Thanks Tom.

Thanks Tom.

I think so, I’m using this one Aukru Micro USB 5V 3A Cargador Fuente alimentación para Raspberry Pi 3, Pi 2 Modelo b y Modelo B+ (B plus) ,Banana pi : Amazon.es: Electrónica .
As I said before I tried with other ones I have around with same results. Today I’m going to try to test it with another tv.

1 Like

Well, it seems that the pi3b+ does not like the provided config.txt.
I fiddled with it a little bit and managed to get it to boot to a tty (no Kodi running still).

Well, the mediacenter is still not starting, but at least i have a tty to fiddle.
This is the config.txt autogenerated by osmc (osmc-installer.exe)


[pi4]
dtoverlay=rpivid-v4l2
arm_64bit=1
kernel=kernel.img

[all]
dtoverlay=vc4-kms-v3d,cma-512
disable_overscan=1
start_x=1
disable_splash=1
disable_fw_kms_setup=1
include config-user.txt

If i remove “dtoverlay=vc4-kms-v3d,cma-512” and set “dtoverlay=lirc-rpi” my pi boots with HDMI output (still no mediacenter starting, dont know why).

My pi does not like the vc4-kms-v3d overlay; with vc4-fkms-v3d it boots fine but the interface is slow as dirt…

Suggest to try a clean install on a new SD Card

Please, read previous posts before suggesting.

Where does it say you used a new (tested) SD Card?
Suggest to test card with h2testw.

1 Like