After June update Sad face playing all videos

Hi I have vero 4k and until never had issues upon updates.

After doing the last update 06_01 2019 I have problems playing video files.

The file (any file) starts playing but when I try to skip forward one or 2 times I get the sad face and reboot. this happens also when I try playing files located on Vero so it is not network related.

I have upload log file to

Best regards

Just to clarify: do you only get issues with crashes on seeking?


Hi Sam

yes playing seems normal. The crash is random upon I seek…sometimes at once …sometimes after 4 or more seeks or forwards.

After I managed to upload the first log files…another issue has occurred…I cannot upload new log files. The following invalid url is returned:<html>
I have tried to reboot and restart but cannot upload new log files. I have turned off VPN and no Firewall. The same issue with the comand line grab-logs -A.

Bets Regards

Your logs are full of messages from various add-ons and will be too big for the uploader. Try disabling all add-ons as that may also be affecting play-back, and see if the problem is still there. If it’s not, enable the add-ons one-by-one and see what happens.

Thanks for the quick reply.

I disabled 3 addons and turned on only “Enable Debugging” under logging.

I tried to reproduce the error but now the sad face come as soon as I press play. The movie file is on Vero4K.

log files

any suggestion is appreciated



i have the same kind of error when I try to see a video stream from an addon

log files

I guess I had faulty update. What should I do to re-update?

i did not do a back up of settings before the update.


Just check for updates in MyOSMC. More likely than a faulty update of OSMC is one or more of your addons is incompatible with Kodi 18.3 that you updated to 2 weeks ago.

Ok clear. But it seems to me whatever I do I get this issue. Just to play a local video on my Vero should not be related to addons or… ? Should I really disable all addons in order to debug?

Best regards

You need to remove all of the pirate addons.

It looks like it’s one of those pirate addons that’s failing and we do not support them. If you refuse to remove it, then you need to contact the author of that addon for help.

OK clear . Not sure maybe a dummy question… Is there an easy distinction between pirate addons and not unofficial kodi addons?


To get a better idea of our piracy policy, please see this link here FAQ - OSMC Forums

I am still looking in to the crash when seeking.
This will be fixed shortly – it is a known issue.


I have now removed all addons.
What I do not understand is why it happens with such a high frequency if it as known issue. Before the june update I did never had this issue.

Now it happens also upon pressing play
Below the log

I start thinking about fresh install

That’s not what your log indicates. There are dozens of 3rd party repos and many pirate addons still installed.

Use this simple method below to backup your current Kodi config and start from scratch -

sudo systemctl stop mediacenter
sudo mv .kodi kodi.back
sudo systemctl start mediacenter

thanks for your quick reply and advice.

I did the 3 sudo commands as suggested and the system was reset.

I changed the skin to Estuary and I tried to play the local file. The problem is still present. As soon as I pres play I get the sad face.

Log files:


Disable your hyperion installation and try again. Additionally, mediainfo on the file you are trying to play could be interesting to see. Are you sure that ALL videos crash Kodi? Or just these test vids?

Not sure how to disable Hyperion installation? sudo systemctl stop hyperion ?

How can I log additional media info? Verbose for video component under specific?

Yes the issue is with all files. I will do some test from the home folder.

Best regards

I have no idea on the hyperion.

It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC.

You can also create the mediainfo-output of the affected media file on the OSMC device:

  1. login via SSH, user osmc, password osmc
  2. if not already installed: sudo apt-get update && sudo apt-get install mediainfo
  3. cdto the directory containing the video/audio material in question
  4. since mediainfoonly needs to read the header information of the file data, copy the first 4 Mbytes of the media file to a new file:
    dd if="<media file>" of=purgeme.bin bs=1024 count=4096
  5. upload the decoded media information using
    mediainfo purgeme.bin|paste-log
  6. publish the returned URL here in this topic
  7. remove the created media file snippet
    rm purgeme.bin

Thx for your help.

media info

Sorry, that instruction is a bit outdated and not exactly correct, I’ll edit it. Can you provide mediainfo <filename.ext>| paste-log?