After latest update I'm getting very brief pauses in sound when playing 44.1khz sound files

The title says it all really. I updated on Saturday and all went smoothly with no errors reported. I have a vero 4K so not the latest model. I made no changes to any settings and have passthrough enabled for sound to an amp.

I have hundreds of cds ripped to flac at their native 16bit 44.1khz. These are stored on my NAS and mounted via nfs.

Prior to the update they played fine. After the update they all play with random very short (<1sec) pauses throughout playback.

I have some videos with 44.1 AAC audio and this does the same.

All other sample rates (48, 88.2, 96, 192) are fine for both video and audio only files

Searching the forums it seems people have had issues like this before with a gui set to 4k. Mine is 1920@23.98fps although I’ve tried changing to lower res

I wonder does anyone else have this issue please?



I should say, I got my friend with a Vero 4k+ to try files of these types and he had no issues. His settings are the same as mine.

Could it be a vero 4k only issue?

I did test this on a Vero 4K and all is fine. I’m using our latest staging repo build though. Maybe you could try this as well…

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

Hey Chillbo,

thanks for the suggestions. I ran them (just as the osmc user) but unfortunately no luck. Things are still the same.

Anything else I can try? It’s very odd



Plugging headphones into the jack on the side of the kodi and things play fine so it’s definitely something to do with the hdmi output and 44.1khz

and a bit more investigation - My vero 4k+ is normally plugged into my amp (NAD T778) and the picture output from that to my TV (LG B6). As I said, prior to the kodi update all was fine but now not. However if I plug vero directly into the tv then 44.1 khz sound plays fine.

Seems like some change made in this kodi release doesn’t play well for 44.1khz audio on the NAD T778 amplifier.

Please can you help?



To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for all components

  • enable event logging and notification event logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshots:

It might be good for you to once upload logs with your Vero connected to your NAD amp and another set of logs when it’s connected to your TV :+1:t2:

forgot to set the component specific logging for SMB library so here we go again:

vero connected to NAD amp:

and connected directly to the tv:

(playing AC-DC - '74 Jailbreak. Track 1)

I know it’s the weekend so don’t want to be pushy, but is this something that you think can be fixed?

If not can anyone tell me how to roll back please even if it means a complete reinstallation of an earlier build



I’m sure it can be fixed, but we haven’t identified the problem yet.

You can downgrade by reinstalling from Download - OSMC.

1 Like

You could maybe work around it by choosing a fixed 48ks/s output in Settings->System->Audio. We would at least be interested to know if that works without blips so we can narrow down the issue.

I’ve already tried that and can confirm it works. Fine for stereo music but not so good for TV since it outputs 5.1 channels (my setup) with FR and FL used. It means though that I can’t select surround mode on the amp to get that surroundb sound experience.



Doesn’t it resample all the channels? We’re talking about AAC audio which would be decoded to PCM, right?

Yes it resamples all channels to pcm. My setup is configured as 5.1 in the Vero config. So what gets sent to the amp is pcm 5.1. if the input file is aac 2.0 then only the front left and right have any sounds on. The other channels are still encoded but empty.

It just means I can’t use the surround mode on the amp since the amp already sees it as 5.1 channels.

I hope that makes sense. No big deal really.

Yes aac at 44.1khz can be resampled to 48khz successfully.


Hmmm. We spent a lot of effort getting rid of that 3/4 years ago. I’m going to file that as a regression. Just checked. I can’t reproduce that on my AVR.

I should explain that the files I have issues with are stereo TV programs (aac 2.0) was well as cd flac rips

Errr, stereo TV would be 48ks/s anyway?

Hey Sam,

if I downgrade is it was simple as doing a backup, downgrading by burning the image to the SD card and then restoring the backup?

Or do I need to reinstall and reconfigure everything?


These are downloaded from t’internet so some are 44.1 annoyingly

Most are 48 as you say.

Hmmmm. Let me check that again then.

Fairly sure I’m right but I’ll confirm when I have a chance.

Hopefully tonight but maybe tomorrow