All videos hang after Jan update

Please can you offer some help?

Osmc (on rpi2) updated earlier today to 2016.01-1 and since then HD video files hang after 1-2mins play :frowning:
I read other posts re power supply… Our pi is powered by output 5v 2000 ma… Is this sufficient? It is the power supply which shipped with the pi and I have had no issues previous to this update. My external drives are powered independently
I have uploaded logs… URL is

You need to enable debug logging, demonstrate the issue, then provide logs.

Thanks… I think I have done that now?

I have the exact same problem with the same conditions(power supply, external hard drive…) and i can’t play any video.
Here is the url for my log if it can help

Double check audio settings.

I checked my audio settings. Nothing wrong with them. I also change my power supply with a 2.4 Amp but that didn’t change anything

Hi thanks for this reply…

I too checked audio settings and chose to return them to defalts. This has made no difference, the pi freezes when playing any video… It lasts approx 1min with a 1080p file and about 10 mins with an sd file. CPU usage is maxed at 100%

What should we check the audio settings for please? I have enabled stereo upmix on some movies before but never made any other changes… And the pi has always worked perfectly prior to this update.

Latest logs

I tried to use Kodi 16 Jarvis nightly builds but this is not changing anything, still have the same problem here

Is this streamed media or media files? I am testing both at the moment.

Edit: The result: Ran 15 minutes of Deutschland 83 streamed from tvheadend and 15 minutes of Weissensee from an NFS share. No issues seen. None were HD though.

I’m playing media files on rpi2 from external USB drives… They are powered independently.

It appears to effect all videos both HD and sd… However the sd plays for longer before it freezes. At the point it freezes the CPU is stuck at 100% and I then have to pull the power out to restart.

My setup has been unchanged for a year and osmc has worked perfectly until this update happened yesterday. Real shame as I have used osmc / raspbmc for years and think its great!

Do you think a fresh install of this build might help?

Try downgrading the kernel:

Your previous kernel will be visible under dpkg -l | grep rbp | grep image

Then you can sudo dpkg apt-get install --reinstall it.

I have the same problem.

Videos hang after 30 minutes.

Hi thanks again for replying.

I have tried the first command which returned 2 results:


So then I tried

sudo dpkg apt-get install rbp2-image-4.3.3-3-osmc

But then get dpkg error… Need an action option…

My apologies if I have misunderstood the instruction, I have little Linux or command line knowledge. Please could you advise on the error?

Thanks again


Close. Try:

sudo apt-get install --reinstall rbp2-image-4.3.3-3-osmc

After installation, run sudo reboot.

Thanks for your feedback.

1 Like

I have tried this solution and I have play entire video without problems.

This night I will see another video and tomorrow I will tell you if all is fine.

Thanks for your help-

Great thank you, that has solved it. Video now plays with no freezes.

Will I be OK to proceed with future osmc updates?

Interesting. Thanks for the report.

It is odd this regression has occurred. I will do some investigation this week myself.

Updates won’t be affected.


If you are a Raspberry Pi Zero, B or B+ user:

sudo apt-get install --reinstall rbp1-image-4.3.3-3-osmc

If you are a Raspberry Pi 2 user:

sudo apt-get install --reinstall rbp2-image-4.3.3-3-osmc


The problem seems to be more general with USB (devices). My RPi2 with multiple USB mass storage devices (flash, externally powered disk). With kernel 4.4.0-1-osmc these devices are discovered, but no partitions are (an no filesystems useable, of course). With some tests “lsusb” hung. 4.3.3 works fine.


2 posts were split to a new topic: Remote (USB) not working after January 2016 Update