Amber skin defaults after reboot - krypton

#1

when changes are made to the skin it resets back to default after reboot

have tried making changes, then switching skin and back again and then rebooting but still resets.

log:

http://paste.oscm.io/okequkevey

0 Likes

#2

Seems same as this

0 Likes

#3
0 Likes

#4

tried shutdown command

first try it seemed to store changes, subsequent tries does not get stored

seems to hang during shutdown with either black screen or the last screen from video played

tried quit which seems to store it for now, but I think I already tried this with different results

when quitting kodi it produces sadface, but seems to store for now even after reboot

0 Likes

#5

This happens for me too on my Vero 1, since the Krypton update. Amber settings very often reset after reboots.

0 Likes

#6

after a few further reboots it has now defaulted itself again - quite an annoying “feature”

0 Likes

Confluence Skin settings not persistent
#7

its not only skins that reset. and its not only amber happens to all skins just most people do not change skin settings. Even total uptime reverts back to the past sometimes.

0 Likes

#8

Choose Exit instead of reboot for now and let us know if it works

0 Likes

#9

unfortunatelly it does not. Exit does not solve this. It does not always happens. It usually is but not always. Also sometimes the skin will loose all the changes. Sometimes it will loose some, or only the latest changes. I had a couple of kodi settings back to defaults also.

Today in a new installation i had the same problem along with some new weird ones.

Once more the total uptime reverted to 1 hour even tho i was working on it for at least 2 hours. This time as every time the total uptime reverts to an earlier date or to zero i lost all the changes in kodi settings i had done and all the skin settings.
But that is not the weird.

I was using lircd for infared remote control. I had no extra addons installed at all. I just had a hard time to map everything to the remote because it had a lot of keys and we wanted to use them all.
After the setup i went to osmc addon to change the wireless ip address to static. But i am not able to stay on the wireless menu since it is like i am pressing again the up or down key when i stop on the wireless menu so i always loose it.
Then i gave a try with another remote that i was using for 4 months. Infared again. Loaded the old conf file i had and again everytime i try to stop on the wireless the cursor moves 2 or 3 or 4 or sometimes a loooooot of times to the direction i was using to go to the wireless.
If i use any other type of remote (usb, mouse, yatse, web interface) it is not doing that.
It does that only there. I said hey what the hell let set up a new remote and test. I set up only directional keys and ok. again the same.
And they weird part comes. I thought to disable lirc from oscm menu. But while i was trying to navigate there i got a message that osmc cannot access advancesettings.xml because it does not have the rights to access it.
But i have no advancesettings file since i havent setup one and new installations of kodi are missing this file by default. So i went and checked if the file is there and it is not (/home/osmc/.kodi/userdata).
I created one via bash just to be sure and checked rights.

I am going to reinstall and make a dance/pray/gift to gods and ghosts.
Now i am checking on another installation the same lirc conf file and it is working fine.

I must be doing something very wrong i think. Maybe this is a user rights thing? I had to do something?

Anyway thanks for your help man, really.
Keep up.
I will try to get logs tommorow if i reinstall because i literally nailed the sd card with a nail while i was still mad.

Oh the one time i had a total uptime reverted to an earlier date and lost all the settings (kodi and skin) my skin changed to the osmc skin.

0 Likes

#10

just rebooted the vero and instead of resetting skin settings it reset all kodi settings - again

together with the choppy video issue this is getting a bit frustrating…

0 Likes

#11

This should be fixed now (skin settings and choppiness)

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

0 Likes

split this topic #12

2 posts were split to a new topic: Amber skin defaults after reboot - krypton - pi Moved as user believed solved on rasberry pi.

0 Likes