Artifacts in videos since version 2021.11.2

Hi Guys,

Hopefully somebody can help me.

I’m having artifacts (unwatchable amount) in some videos since I’ve upgraded to version 2021.11.2 on my Vero 4K+. The same videos did not have issues on version 2021.11.1.

It happens on h264, h265, HDR, Non-HDR…

Videos with these issues play perfectly fine in VLC on Windows and LG Smart TV.

Any idea what could be the cause for this? Is there a log I could check? If yes, which one?

Thanks for your help!

Please post some logs. I can’t think of anything that changed between these two versions that would cause this.

Hi Sam,

here you go:


The video I’ve tested here is “Venom - Let There Be Carnage (2021).mkv”

And it looks like this since 2021.11.2:

Let me know if you need anything else for troubleshooting.


EDIT: I’ve done some further digging using MediaInfo: It seems that this issue only happens with HEVC files. Videos in AVC Format run fine. (based on very short testing in the past few minutes.)

I can see in the logs why this is happening to an extent, but the reason behind that is unclear.

Can you try checking for updates again to ensure you are up to date?
Do you have a sample file you could send to reproduce the problem?


Hi Sam,

I just checked for updates again.: Fully up to date (November 2021.11-2 is the current installed version)

Sample File? Yes, I can reproduce the issue with this: jellyfish-3-mbps-hd-hevc.mkv

Its a HEVC issue because I can’t reproduce the issue with this jellyfish-3-mbps-hd-h264.mkv

Thanks for your help!


I link my topic since, as you noticed, it is probably the same issue: HEVC issues with Vero4K+
Up to date as of 10 minutes ago as well.

Can’t see an obvious cause for error in your log.
Can you see if a fresh installation helps?


Hi Sam,

I was afraid you would suggest this… Ok. Will try a fresh install tomorrow.

(First need to do some checking how to Backup (MySQL) settings and so one…)

Will keep you posted.

@sam_nazarko: issue is resolved with cold boot!

(Shutdown osmc => unplug power & replug

During boot it gave me a unhappy smiley face with some commands in te top left corner.

After this boot HEVC files ar working fine again!

Thanks for your help!

Can you show me a photo of the text that appears? It sounds like there is still an issue.

Unfortunately I did not take a picture during the cold boot when those commands where showing.

Every cold boot I’m doing now is going without issues…

If something comes up again I will let you know!

Glad to hear this.

Yesterday I updated to the latest version and I encounter the same artifacts but “only” with 4k HDR video, fullHD videos work fine.
I tried to restart but the problem still remain the same.
Sometimes, but not now, it worked putting in configuratiin —> display mode —> windows so the screen remained blue and at the next restart, after disconnecting the power, the playback was done correctly but now, after several attempts, even this trick doesn’t work anymore.
Sorry for my very poor english.

As this problem was reportingly solved I suggest you open a new thread and attach debug enabled logs.

I had issues with some movies, reboot didn’t work but disconnecting and reconnecting power did. Been having similar issues randomly since the original Nov update, my kid says it’s glitching :grin: