HEVC issues with Vero4K+

Hello,
Since an update which occured between friday night and saturday night last week, all HEVC files are choppy. One frame every 10 or so seconds. Whatever the resolution (FullHD/4K), HDR or not, the audio codec…
In comparison, all other video codecs files are fine whatever the resolution.
The files are played from a NAS with a 1000Mbits/s link.

The UI is ok during playback. CPU usage is not through the roof and network is 1000Mbits/s.

Here are my logs : http://paste.osmc.tv/ruqeyetozi

if you long-press the Info button do you see video decoding as HW or SW?

If it’s software, probably some kernel modules were not configured correctly during the update like in my case:

1 Like

Looks like you are having the same issue as me:

It says HW. But while checking following your instructions, I noticed that the pixel format was not detected correctly.
I tried the command with dpkg and nothing happened.
I suppose that everything is fine on this front.

Indeed !
It is the same issue from what I am seeing in your screenshot.
Extremely blocky and chopping.
It happens less with animes

Damn sorry to hear that (although I’m glad I’m not the only one with this issue, sorry! :innocent:)

Let’s hope @sam_nazarko can help us troubleshoot this b*tch!

That’s fine, I am quite happy to not be the only one too :stuck_out_tongue:

I’m investigating.

Out of curiosity – have you tried cold booting your device? There seems to be another user only experiencing a problem with a warm boot (i.e. reboot).

Yes. Warm or cold boot have similar results

Well, just to be sure I tested the cold/warm boot hypothesis.
But I could not conclude to anything since everything is fine again now…
Either cold or warm boot, h.265 playback (even 4K/HDR/DTS-HD) is ok.
I really don’t get it.

Issue here is resolved with cold boot!

(Shutdown osmc => unplug power & replug

During boot it gave me a unhappy smiley face with some commands in te top left corner.

After this boot HEVC files ar working fine again!

Thanks for your help guys!!

I find it strange though. My box is never let powered on so I do not get where the issue was coming from since it is almost always in a cold boot.

Let’s keep an eye on things. It could even be a memory leak after some time. But my theory is that it only happens during warm reboots and when you installed the update you didn’t power cycle the box.

That’s not your fault - we don’t expect you to have to do so.

I have tried cold and warm boots and until yesterday night, it was not working.
It is quite strange :slight_smile:

Back to square one tonight : laggy and choppy for HEVC but x264 is OK.
Cold boot or warm. There was an update but it did not change anything.

Please post logs – because we didn’t release any updates.

Here you are : https://paste.osmc.tv/rijeguzoju
EDIT : and once more this morning

osmc@osmc:~$ sudo apt update && sudo apt full-upgrade -y
Hit:1 http://security.debian.org buster/updates InRelease
Hit:2 Index of /debian buster InRelease
Hit:3 Index of /debian buster-updates InRelease
Hit:5 InfluxDB Repository buster InRelease
Hit:4 Index of /osmc/osmc/apt buster InRelease
Hit:6 Index of /osmc/osmc/apt buster-devel InRelease
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following NEW packages will be installed:
vero364-image-4.9.113-56-osmc:arm64
The following packages will be upgraded:
vero364-kernel-osmc:arm64
1 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 24.2 MB of archives.
After this operation, 91.8 MB of additional disk space will be used.
Get:1 Index of /osmc/osmc/apt buster-devel/main arm64 vero364-image-4.9.113-56-osmc arm64 4.9.113-56-osmc [24.2 MB]
Get:2 Index of /osmc/osmc/apt buster-devel/main arm64 vero364-kernel-osmc arm64 3.9.223 [1084 B]
Fetched 24.2 MB in 38s (632 kB/s)
Selecting previously unselected package vero364-image-4.9.113-56-osmc:arm64.
(Reading database … 35826 files and directories currently installed.)
Preparing to unpack …/vero364-image-4.9.113-56-osmc_4.9.113-56-osmc_arm64.deb …
Unpacking vero364-image-4.9.113-56-osmc:arm64 (4.9.113-56-osmc) …
Preparing to unpack …/vero364-kernel-osmc_3.9.223_arm64.deb …
Unpacking vero364-kernel-osmc:arm64 (3.9.223) over (3.9.222) …
Setting up vero364-image-4.9.113-56-osmc:arm64 (4.9.113-56-osmc) …
11+1 records in
11+1 records out
11743232 bytes (12 MB, 11 MiB) copied, 0.378951 s, 31.0 MB/s
0+1 records in
0+1 records out
112640 bytes (113 kB, 110 KiB) copied, 0.00995013 s, 11.3 MB/s
Setting up vero364-kernel-osmc:arm64 (3.9.223) …
osmc@osmc:~$ uname -a
Linux osmc 4.9.113-55-osmc #1 SMP PREEMPT Fri Nov 19 14:03:43 UTC 2021 aarch64 GNU/Linux

Kernel version seems to have been incremented.
After a cold reboot (warm reboot did not work, red led stayed on, unplugged everything, let everything still for 10 sec and tried again), nothing changed. Here are the logs: https://paste.osmc.tv/kubijavece

Yet another update tonight

You are getting updates because you are still on the development repository.