Audio blank when resuming a paused video

I have this issue since I have been using the Vero 4k+.
When I resume playing a video that was paused, video starts right away, but for half a second, there is no audio. After that time, everything is fine but I missed whatever was said for that half second.

I have tried every audio settings, reset my device by removing /home/osmc/.kodi, no luck.

The Vero is simply connected via HDMI. The video file is on the Vero (not a LAN problem).

I have tried on different screens, no luck.

And above all, I have osmc installed on a raspberry pi 1b, and I don’t have the issue with it.

Sam already tried to help me but we couldn’t find any solution as of now.

Does anybody has that kind of issue?

Any help will be greatly appreciated.



As you are already using PCM, there’s unlikely to be a solution for this. There is a Keep Audio Alive setting that may help; but I seem to recall that you had issues with this.


I think this is an issue we have all had before. Not sure how to fix it. It can be partially fixed with setting delay after changing resolution but since OP is talking about issues after pause that probably wouldn’t help.

But It sure would be nice if this somehow could be fixed with a update in the future or a new device in a few years time.

What’s causing this anyway ? My amateur guess would be that it happens because the video stream gets hardware accelerated while the audio is handled by the CPU ?

I started a thread with the same problem: Sound delay after pause

Although for me it is 2-3 seconds but only when audio is set to passthrough. If set to PCM there is a very small delay but nothing to complain about.

Unfortunately now I have a new TV and am using ARC, which doesn’t pass multichannel PCM so I have gone back to passthrough.

It takes a little bit of time for the receiver to lock on to the audio signal and adjust to the appropriate mode (PCM).

By using keep alive this is sometimes resolved; as the AVR is kept in a warm state.

The keep audio alive setting doesn’t change anything for me.
But again, why is my old raspberry pi with the same osmc can do it fine and the brand new Vero 4k+ can’t… ?

Possibly of value as a workaround?

Unpause Jumpback


Thanks but my workaround would be the raspberry pi.

Can you upload a log so we can check your audio settings?

If you are using passthrough you can expect a small delay while the signal locks on. This will happen on any platform.

Of course, which log file would you like?

1 Like

Great, I’ll do that as soon as possible.

hi, i bought a vero 4k+ a couple of weeks ago, and i have the same issue. connected via hdmi to denon 3313 avr and there is a audio gap for about 1 second when resume after pause.
settings are passthrough, the display of my denon says for example dts, and when i pause it switches to pl2 cinema, when i unpause it switches back to dts with the audio gap.

any reasons or solutions? i dont care about the money, which device would be better? :smiley:
and sorry for my english, i’m no native speaker… thx

It would be best for you to post debug logs that display the behavior so we are not playing a guessing game. It likely will be just a matter of something like not using refresh rate switching or some other setting that is much easier spotting from a log than guessing what it may be.

thx for the reply. so this is not a normal behavior? will check the logs.

lot of ERROR: CAMLCodec::AddData: packet to big: 172526, probably corrupted
the vero is connected to a Synology 920 NAS via NFS and LAN cable via Zyxel 8-Port Gigabit Switch

Maybe i should check this: Configuring fstab based NFS share mounts


Under certain conditions it can be but when I’m playing regular DTS content passthrough into my Denon AVR it does not switch to PCM when paused. I would recommend the following changes to your settings.

Display resolution set to 1080p at 60hz
Audio channels set to 7.1
In player settings set adjust refresh rate to on start/stop

In the audio settings you might also play with the keep device active setting.

thx again. and you don’t have an audio delay?

changed all the settings but its still the same behavior.
and, its also with dolby digital and true hd etc…

ok, tried a nvidia shield and kodi, and the issue is the same. so, its not the vero which causes the issue i suppose, maybe kodi…

Some AVRs (most in fact) will have a small delay before audio is heard as they identify the audio stream being sent and then start to process it.

ok, thx for the answer.
tried smb, same behavior.

my ps4, my dune mediaplayer and my panasonic blu-ray player don’t behave like this.
avr stays at dts when paused and audio is resuming immediately after unpausing.

sorry, i’m pedantic about this things, the delay annoys me, so i guess i gonna buy the next player… :smiley:

The network protocol won’t make a difference.

The keep Audio Alive setting might solve this. But what is happening is when you pause the video, we stop sending an audio signal, which causes the AVR to revert back to PCM.

It’s possible for us to keep sending a passthrough signal; but things like UI sounds may not work as expected.