Audio/video hesitating - eth0 Status (No internet)

This setup has been working great for a long time. I have updates turned off - because generally updates break things - “if it ain’t broke, don’t fix it.”

Anyway, all of a sudden, a few days ago, the audio (on MP3s) and the audio/video (on video files) started hesitating and pausing. The Pi acts like it is doing other things in the background because when it is hesitating, it takes longer for it to respond to the remote control and it always takes longer for the web interface to connect.

The only things that I have done differently are installed a new computer on my network (which I have now taken back out for the time being) and installed CU LRC Lyrics (which I have since uninstalled - although this didn’t start immediately after installing the lyrics add-on). After changing all of this back the problem still persists.

I seem to have narrowed the issue down to the Pi - my laptop streams the same MP3s and video files over the same network connection with no issue and another TV streams the video files (through Plex) with no problem. So it can’t be the server or the network.

Another odd thing is this - my router now shows the IP address of the Pi as “offline” and the Status under the OSMC settings shows “eth0 (No internet)” - even though I can connect to the Pi through the web interface and I can still do show updates and install add-ons through the Pi… so I KNOW it IS connected to the internet!

I don’t won’t to reinstall this system. I will if I have to, but I would rather know what the problem is. To me, reinstalling to fix a problem (if that even works) is like buying a new car because the “check engine” light comes on. “WHY” is the most important question one can ask, so… WHY?

If you read this far - THANK YOU!

Hi there!
To get a better understanding of the problem you are experiencing we need more information from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.
Thanks! :+1::laughing::point_up:

I think this is what you need?

Try again :wink: that link is broken somehow

uuggg… Ok, let’s try this one :slight_smile:

You need to update your system bro… This system hasn’t been updated since March… Sorry, but we can’t provide support for this as it sits… And as much I hate to tell you, you may require a complete re-install to get on a functional upgrade path.

Software doesn’t just “stop working” because it’s “out of date.” Since this is the first trouble I’ve had, there was no reason to “update” and since"updating" may not fix the issue I have now, I would only do that as a last resort… Thank you for looking anyway.

Good luck then…
Thanks! :+1::laughing::point_up:


Don’t say we didn’t tell you so… lol

Your PSU is not providing enough power

Jan 10 18:51:47 osmc udisks-glue[244]: Device file /dev/mmcblk0 inserted

Either this, or you removed and reinserted your SD card during operation.

If you replace the PSU, the issue should resolve itself. It is still recommended you update to the latest version of OSMC.

Software doesn’t stop working because it’s out of date, but try calling Microsoft to get support on XP, guess what answer that you will get. The OSMC development team is a small team, and they can’t support old versions.

Since your problem suddenly occurred, I’d suspect that you may have SD card corruption problems. Any power failures lately, or did you just pull the plug on the Pi?

Unless you done lots of customizing, a fresh install isn’t that bad to do.

You can certainly backup your ~/.kodi directory and import it to a new install.

I think I did accidentally pull the card out, but it was after I had “powered down” the system. I wouldn’t think that would show up in the logs, though…

Do y’all see a lot of PS issues? Because that has been the answer to every issue I’ve ever had and that was never the problem… Not saying it can’t be this time, just that that seems to be the go to answer.

I do have a backup of the .kodi directory as well as a img of the sd card.

I didn’t mean that I expected old software to be supported forever, only that software didn’t just “stop working” for no reason. I just thought someone might have some idea.

As for power failures… not to my knowledge, but that is always possible…

It wouldn’t…


I’ll try to find a stronger PS. Thanks guys!

OK… so, even though I have never had an issue with the power supply, I went ahead and replaced it with a larger current device. I also “upgraded” the OS to the latest version available to the installer (which did away with the AWX web interface :frowning: ) and just to eliminate the SD card as a possible suspect, I installed the new OS to a brand new 4gb high-speed SD card.

Even with all of that, the audio and video is still pausing and hesitating. I am uploading a new set of logs if anyone wants to take a look:

Thanks again…

I haven’t looked at your logs (since I’m on HughesNet I don’t download unless I have to) so I don’t know if you are on a wired or wireless connection with your Pi. But that’s what I’d look at next. This really sounds like a network problem to me. And just because it was working before, that doesn’t mean that a cable hasn’t gone bad, or your wireless dongle isn’t failing.

A few years ago, I suddenly had problems with my internet connection. Hadn’t changed a thing. But it wasn’t consistant, some things worked, some didn’t. I tracked down the problem to an Ethernet cable that had been chewed on by a mouse! (And there were 6 cats in the house at the time; they were all fired from the mouse patrol)

Thank you. The Pi is wired to a LinkSys router configured with OpenWRT to act as an access point. I have tried disconnecting the cable from the Pi and connecting it to my laptop and the laptop plays video and audio fine… just like every other wired and wireless device on the network… I know things go bad without warning or explanation, but I really cannot think of anything that I haven’t tried to eliminate!

Sure it wasn’t one of the cats that chewed the wire and s/he was just blaming the mice? I’ve caught mine trying that in the past! lol

To understand if the network or the RPi is your problem I suggest that you first copy the file to the SD card and play it from there to see the result of that.

Might be worth rebooting everything. Server, router and Pi.