Banding Issue still present, latest build on Vero 4K

Edit: this is now fixed in the latest software.

Hi guys!

I got my Vero 4K finally setup yesterday and tried some 4K HDR movies like ‘The Revenant’ and ‘Star Trek: Into Darkness’, everything seemed to be ok as far as I jumped through different scenes.
Then I took a look at BBCs ‘Blue Planet II’. Just at the beginning, when David Attenborough stands on the boat, banding in the Sky is terrible. It´s a 2160p HDR series, and when I play this file directly on my TV (LG 55C7D) everything seems to be fine, no banding visible for me.

I turned on ‘Auto switch HDR’, System Resolution set to 2160p60hz.

I don´t know why this happens, this seems a little bit odd, since the movies i tested were fine.

If someone has this exact series ‘Blue Planet II’, can you test it?

Not looked into log yet…


Don’t set the resolution to 2160p.
You should have it at 1080p and enable Adjust Refresh Rate.

As it’s been discussed, the auto-switch option is not 100% accurate yet. This will be resolved soon.

If you enable 10-bits manually banding will be completely gone.



Wow, what a quick reply. :slight_smile:

Adjust Refresh Rate is enabled, but why do have I set to 1080p, maybe you can give me some more detailed information here. Therefore I have to ask, somewhere in a review I read that the Vero 4K does Resolution Switch automatically, but as i tried yesterday, when i play 1080p blurays and resolution is set to 2160p, i doesnt switch.
I will set it to 1080p for now, since I want the TV to upscale 1080 content.

I know that it´s not a 100 percent accurate, i did read that in the ‘official’ banding issue thread. Looking forward to get a more stable version soon :slight_smile:

How do I enable and disable 10bit manually? It´s not in the menus, right?


If you set the resolution to 2160p, it won’t switch properly.

You should have it set at 1080p (for the best GUI performance and image), as Kodi’s scaler isn’t very good. You then enable Adjust Refresh Rate and switching will work fine.

No – it needs to be done by SSH. But see if the switching works well enough for you after changing resolution.

Ok trying that soon, thx a lot for now!

1 Like

No problem. Let us know how you get on.

Resolution Switch to 1080p has done it for me :slight_smile: Nomore Banding visible in certain test scenarios. Thanks for your quick help.

1 Like

I have another issue with my Xbox One remote connected via IR. Since I wanted some buttons to act as I want, I remapped some of these. Volume Up and Down now controls my Cinema-Light in my room (on/off), basically it runs a python script. Everything is working fine as I intended it to be.

But, the strange thing is that only every second press I take on the remote gets recognized by the system. No matter how long i wait between a button press, only every second press is executed. Totally strange. I did install the lircd.conf via the OSMC menu.

Any idea?

Are you using the IR extender?

Yes, cause i want to place the box behind my board in the future, so i have to use it. When I look at the backside of the Vero, its the port far right, am I right?

Any idea? Cant figure it out.

Try without the extender first
If this does not help, we can use Irrecord to see if the presses are getting through

Tried without extender, same problem.
How to read out Irrecord?

As my original post had a mistake better follow this

1 Like

Thx fzinken, tryin this! :slight_smile:

Finally, Michael_Gombkoto´s solution in the Xbox Remote Thread did work just fine. I created a new lircmap, and everything seems to be fine, button presses are quite instant and nomore double-presses needed.
Strange, as the new licd is exactly the same as the old one, at least what I read out of the file.

Thx, fzinken!

still issues with xbox remote, see this thread: