CEC suddenly stops working

Hi Guys,

i’m experiencing above problem, as a workaround i change the input port and change it back, then it’s working again. Do I have to activate all debug-options?
Thx in advance! :wink:


Does it happen while you are actively using Kodi, or when you turn your TV on? I have this when turning the TV on sometimes. I’ve seen it once or twice while using Kodi, but that’s extremely rare.

Hi @bmillham,

it appears during watching TV or using Kodi. My AV-Receiver is a Pioneer SC-LX56, and never had issues with it.


Is this a new issue, or has it always been problematic?

If it keeps happening, I’d first try another HDMI cable. If that doesn’t do it, logs. Probably just the CEC component log would be fine.

I assume, it’s since sam changed the CEC-behaviour. It’s new and it’s not the cable. :wink:


I didn’t change any behaviour, just made some more settings to Kodi.

Try disabling set language from Tv in Settings -> Input -> Peripherals.

Also try powering down the TV and Vero 4K at the mains for ten minutes


Ok Sam, thanks for the hints, will do that.
Sorry, was a wrong expression! :wink:

Interesting options! :slight_smile:

I’ll keep u informed, but looks good right now with disabling set language.


Thanks for letting me know. Keep me posted.

Hi @sam_nazarko,

til now everything is fine, that really did the trick and indeed it’s a Philips TV too! On the other hand i want to let u know, how stable even the nightlies are. Really glad that i’ve bought a vero and not a raspi. :wink:
Keep up the good work and support! Thx for helping me.


Hi @sam_nazarko,

What was the fix here? Something to adjust on the TV set or on the Vero device? I want to try out and feedback. Did you have time to look at my logs?
Thanks for clarification.


No such setting on Philips 52pfl9704h/12

The setting is in Kodi Settings -> Input -> Peripherals.

I did the adjustment. Does not fix. It worked for 5 minutes, started watching something, then I lost control again. After another reboot also noticed (use confluence skin) after booting up Vero I am able to click one to the right or the left then losing control. Did pulling the mains, etc. Really out of ideas. Same time RPi3 works without problem. Checked Libreelec CEC setting, it does not have ticked use tv’s language either… Copied Libreelec CEC settings to Vero CEC, still same problem. What can be the next step?

We need the logs
Try swapping hdmi cable with Pi 3

Did upload logs.


When you uploaded the logs, you should have been given a url; please post the url?

Thanks Tom.

Hi Tom,

Been sending the screenshots of URL to Sam via email.
Not sure how secure sharing URL to public.


The logs will only show you you private ip range, not your your public IP; if that is your concern. If you have other concern you can sanitize your logs, details can be found here:

The choice is yours, but the community may provide insight on the issue.

Thanks Tom.