Configuring component output


#1

Component video can be configured by editing /etc/X11/xorg.conf.

For 720p output:


Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "RegistryDwords" "RMDisableRenderToSysmem=1"
    Option "DynamicTwinView" "false"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "UseDisplayDevice" "TV"
    Option         "TVOutFormat" "COMPONENT"
    Option         "TVStandard" "HD720p"
    Option         "TVOverScan" "0.80"
    DefaultDepth    24
    Option         "NoLogo" "True"
    SubSection     "Display"
    Modes "1920x1080" "1280x720" "1024x768" "720x480" "800x600" "640x480"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection

For 1080p output:


Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "RegistryDwords" "RMDisableRenderToSysmem=1"
    Option "DynamicTwinView" "false"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "UseDisplayDevice" "TV"
    Option         "TVOutFormat" "COMPONENT"
    Option         "TVStandard" "HD1080p"
    Option         "TVOverScan" "0.80"
    DefaultDepth    24
    Option         "NoLogo" "True"
    SubSection     "Display"
    Modes "1920x1080" "1280x720" "1024x768" "720x480" "800x600" "640x480"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection

Older TVs such as Samsung may not support 1080p, so the following line needs to be changed for 1080i:

Option "TVStandard" "HD1080i"

After editing, restart your system by issuing sudo reboot


Apple TV Component Output and Broadcom CrystalHD BCM70015 Card
Journey to the Blue Screen
#2

4 posts were merged into an existing topic: Configuring composite output


#6

u 4got to change 720p to 1080p


#7

Look again. it was changed on Dec 2nd


#8

Sorry for the daft question,

i am trying to configure this, i copied the file to my PC with WinSCP, edited and tried to copy back but get access denied. also the same if i try to edit the file directly on the ATV with WinSCP.

is there something else i need to do to get permission to replace or edit the file?

i am logged in using osmc/osmc, do i need to log in as root?

what would the password be?

Thanks!!


#9

Root password is not set by default.
Suggest you copy the file to /home/osmc then ssh into the atv and copy with sudo cp /etc/X11/.


#10

Where did I go wrong?

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 340.46  (buildd@binet)  Tue Oct  7 08:03:22 UTC 2014

Section "ServerLayout"
    Identifier     "serverlayout0"
    Screen      0  "screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "monitor0"
    VendorName     "SNY"
    ModelName      "Sony TV"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "RegistryDwords" "RMDisableRenderToSysmem=1"
    Option "DynamicTwinView" "false"
EndSection
Section "Screen"
    Identifier     "screen0"
    Device         "device0"
    Monitor        "monitor0"
    DefaultDepth    24
    Option         "NoLogo" "true"
    Option         "RegistryDwords" "RMDisableRenderToSysmem=1"
    Option         "DynamicTwinView" "false"
    Option         "ModeValidation" "NoVertRefreshCheck, NoVesaModes, NoXServerModes"
    SubSection     "Display"
        Depth       24
Option         "TVOutFormat" "COMPONENT"
    Option         "TVStandard" "HD720p"
    Option         "TVOverScan" "0.80"
    DefaultDepth    24
    Option         "NoLogo" "True"
    SubSection     "Display"
    Modes "1920x1080" "1280x720" "1024x768" "720x480" "800x600" "640x480"
        Depth       24
    EndSubSection
Section "Extensions"
    Option         "Composite" "Disable"
EndSection

#11

Start a forum post if you’re having problems, explaining what these problems are.


#12

I started a new thread, but I haven’t gotten any responses in the past 11 days since I started the thread: Apple TV Component Config - Where’d I go wrong?


#13

Thanks first for your posting and I got my component video working. However, the analog audio output got low sound and bad quality. I installed this new OSMC KODI with a Usb and I know my atv1 hardware is good. I still kept my old Apple OS with XBMC Eden version and audio worked great. Can anyone help me on how to fix this?


#14

Older TVs such as Samsung may not support 1080p, so the following line needs to be changed for 1080i :

Option "TVStandard" "HD1080i"


#15

Thank you for this suggestion. Amended the post.


#16

The documentation on how to configure TV out can be found at
https://en.wikibooks.org/wiki/NVidia/TV-OUT
https://help.ubuntu.com/community/NvidiaTVOut