Connecting to Digital TV idiots guide please

After giving this thing a break for a week I’ve set aside this evening to try and get my vero to pick up tv signals. After all the reason I bought the device was so that I could watch and record TV programs and if I want to keep them I could easily copy them across onto a USB stick very easily.

I’ve now got internet connected to a long ethernet cable so that the wifi doesn’t suddenly drop.

I’ve also got a DVB-T card that I’ve managed to get working on a windows machine using blade, I also managed to get the same device working on a Ubuntu machine - so it should be linux friendly. It’s hooked up to an external aerial as the little one that comes with it seems to be utterly useless.

I’ve tried enabling the different PVR software on the vero menus but I can’t work out how to make the vero scan for channels.

I’ve installed the TVHeadend Server from the app store
I’ve also gone to the settings=>live tv menu and clicked to enable
I was told to install a PVR program so I chose Myth TV and enabled it

When I go back and try to scan channels nothing happens. If I click on the channel manager nothing happens. I’ve tried a couple of different PVR programs - am I using the wrong ones? Or is there something else I’ve got to do

I think my problem is that I don’t have a PVR backend installed. But I’m not sure how to install this. Is there a settings menu that I’m missing.

I am not sure which post to reply to.

You don’t need TVHeadend Server or another backend if your card is on another system. That means the system that houses the card is the backend. The Vero is just a frontend.

I am not completely sure what ‘Blade’ is. But I recommend using Windows Media Center or MediaPortal. Both have simple PVR clients which will let you watch TV from Vero.

Sam

I’ll stick to this post - I tried to see if I could delete the other post but I didn’t see that option.

I’ve plugged the DVB-T card into the vero. I have enabled both MediaPortal PVR and PVR WMC. Both of these appear to be having problems because as soon as I enable them there is a dialogue box at the top of the screen that gives the name of the PVR client and says Connection lost.

When I go to the live TV settings menu and select scan for channels there is an Information dialogue box that pops up and says “None of the connected PVR backends supports scanning for channels.”

http://kodi.wiki/view/Live_TV
http://kodi.wiki/view/PVR

You should probably make sure you understand everything here, it will probably move you along quicker than waiting for someone here to spoon feed you. The kodi wiki is a very well written and (typically) very current that any user should be familiar with.

From what I understand in order to watch TV directly I need a PVR backend which will talk to the DVB-T card. This will then forward the information to the PVR Client which can then send the information to the screen and I get tele.

There seem to be a number of PVR Clients pre-installed on the Vero, but we need to enable them to get them to work. I’ve enabled Myth TV, MediaPortal and WMC

“PVR backends can either run on the same host running Kodi, or on a stand-alone host/device completely by itself with Kodi only running when needed, as long as they have a network connection between them.”

I take this to mean that the Vero can behave as the PVR backend (by plugging a DVB-T) card directly into one of the USB slots. I can also enable one of the PVR Clients and I should then be able to watch TV.

But at the moment I don’t think the Vero has the backend working correctly

I’ve tried to go into MediaPortal to see why it keeps saying connection lost. When I click on the hostname it comes up with this screen

I’m pretty certain that there’s supposed to be a virtual keyboard on screen here but for some reason it’s gone missing

I don’t use Live TV but I’ll offer you these bits that I am aware of. You shouldn’t be running more than one client on your Vero. If you are running MythTV backend then use THAT client. The client and the backend MUST be compatible. If TVHeadend isn’t working from the app store, then I’m quite certain there are several threads on this board that give some insight on how to get it working. If you have some other system that runs most of the time, it might be preferable to put the backend on it and then connect the Vero (via the compatible client) across the network.

Not being a user of LiveTV, this is all I can offer. Your posts are likely being ignored by other users because the OTHER threads on the board pertaining to livetv probablyalready hold the info for making it work. No one likes spend time re-iterating info that is already available.

I appreciate all the help you’re offering. Whilst I am not an expert I am an enthusiast and a supporter of open source (and libre software).

I’m not using any other devices – just the Vero. I’m trying to use it as a plug and play device.

I haven’t installed Myth TV backend because that isn’t in the App store (and I haven’t found it anywhere else).

I have no other system to link to the vero. I did plug the DVB-T card into a laptop to check that the card was compatible with a linux system and it was.

I don’t feel I’m being ignored. Both yourself and Sam have replied to my posts pretty quickly. Hopefully I’ll get it working before too long.

Thanks again

My current situation is that I have TV Headend Server installed from the appstore.
I’ve also tried to install TVHeadend HTSP Client but it keeps saying access denied, followed by connection lost.

I have found this thread and I’m going to try and work through this and see where I get

As far as I know, the app store version of tvheadend is still broken. Refer to this thread and follow HarryL’s instructions with a fresh install of osmc.

The important thing (for me, anyway) was not to install the app store version at all. It didn’t work if I tried removing and reinstalling. Start from scratch. There is no guarantee that this will work, since you are using a different tuner, but it might help. If you have any questions about your particular tuner drivers, that linked thread would probably be a good place to ask.

Ok so I’m going to try and start from scratch as installing the tvheadend from the appstore doesn’t seem to be working.

I’m not sure if there’s a factory reset option somewhere - I’ve not found it.

What I’m trying to do is use the osmc-installer

I’ve followed these instructions from the https://osmc.tv/download/linux/ page

echo ‘deb Index of /repositories/home:/osmc/Debian_8.0 /’ >> /etc/apt/sources.list.d/osmc-installer.list
apt-get update
apt-get install osmc-installer

But I keep getting told that it can’t find osmc-installer

root@osmc:/usr/src/tvheadend# sudo apt-get install osmc-installer
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package osmc-installer

I did make sure that I had the Release key installed before trying to install osmc-installer but it hasn’t worked yet

The osmc-installer is not available on ARM platform as it is not suppose to be run from within OSMC as that would mean you are sawing of the branch you are sitting on. OSMC-installer would be run on your Desktop PC (WIndows/MAC/Linux) from which you re-install OSMC onto a SD card.
But only because you have issues with tvheadend a reinstall of osmc should be the last step.

I decided to try and do a fresh install as I’m going to try and get the DVB-T player working.
I used the OSMC-installer downloaded from apt-get on my ubuntu 15.04 machine. I took out the SD card from the VERO and plugged it into an SD card reader and then attached it to my linux machine.

I then put the SD-card back in the VERO and it goes through a fresh install.

I then try to enable the PVR-client TVheadend HTSP but it still doesn’t try and search for channels when I click this option.

I am encouraged however as I followed Harry’s instructions for installing TVheadend in the terminal and I got this back

2015-05-18 22:04:08.613 [WARNING] dvr: Output directory for video recording is not yet configured for DVR configuration “”. Defaulting to to “/home/osmc”. This can be changed from the web user interface.
2015-05-18 22:04:08.626 [WARNING] access: Created default wide open access controle entry
2015-05-18 22:04:08.629 [ INFO] CSA: Using 32bit parallel descrambling
2015-05-18 22:04:08.630 [ INFO] epggrab: module eit created
2015-05-18 22:04:08.630 [ INFO] epggrab: module uk_freesat created
2015-05-18 22:04:08.630 [ INFO] epggrab: module uk_freeview created
2015-05-18 22:04:08.630 [ INFO] epggrab: module viasat_baltic created
2015-05-18 22:04:08.653 [ INFO] epggrab: module opentv-skyit created
2015-05-18 22:04:08.660 [ INFO] epggrab: module opentv-skynz created
2015-05-18 22:04:08.661 [ INFO] epggrab: module opentv-skyuk created
2015-05-18 22:04:08.664 [ INFO] epggrab: module opentv-ausat created
2015-05-18 22:04:08.666 [ INFO] epggrab: module pyepg created
2015-05-18 22:04:08.666 [ INFO] epggrab: module xmltv created
2015-05-18 22:04:08.673 [ NOTICE] START: HTS Tvheadend version 4.1.7~g61eeb38 started, running as PID:2933 UID:1000 GID:44, CWD:/usr/src/tvheadend CNF:/home/osmc/.hts/tvheadend
2015-05-18 22:04:09.557 [ INFO] AVAHI: Service ‘Tvheadend’ successfully established.

This last sentence seems to suggest that I’ve got something working

Hi Sam

I’ve still not managed to get the dvb-t dongle working with the vero. However I’m now considering using another backend - but how would I connect a device to the vero?

That looks as if you installed the TVheadend “server”, but didn’t configure it.

To go with the server, you also need the “client” which you had previously managed to install, had you installed it again ?

Have you read through http://docs.tvheadend.org/ ?

Personally I run mediaportal on a dedicated windows box and use the mediaportal PVR plugin.

Cheers