Eternal buffering


#1

After an hour or two of video playback, the next video I try to play will buffer forever. No further videos will play until the vero is rebooted. Music plays fine. The video files are an external harddrive, which is the same one i was using with OSMC on my raspberry Pi, which did not have this issue. I enabled logging and had it running when trying to play a video only to find that the log uploader addon is also broken. Any help greatly appreciated, thanks!


It was ExFAT
#2

Please explain “broken”.


#3

Thanks for responding!

From the Kodi wiki: “This add-on has been marked as broken in the repository: Upload website is no longer functional”

I get a failure message saying the max size is 400kb regardless of how long the logging has been on.

Should I be using a different one?


#4

The OSMC buildin log uploader is under MyOSMC.
All details are explained here

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/


#5

Ah crap I feel like a jackass thanks for the heads up! I’ll post legit logs when this happens again


#6

Ok so I had the logging running for a while when it finally happened again (so frustrating it happens at random time intervals) but when I went to use MyOSMC to upload the logs, it gave an invalid URL (“paste.osmc.tv/<html>”). So Then I used SSH and “grab-logs -a” to get this URL:
https://paste.osmc.tv/xazijegeco
I really hope this helps find the issue. Thanks again guys!!


#7

My OSMC will reject logs > 10M

Same for grab-logs, but you may have ran this after a reboot.

Sam


#8

It’s -A not -a.

You seem to have only uploaded APT logs, which explains why it went through ( < 10M)

Sam


#9

I tried again and this time the vero wasn’t on for nearly as long, and i didnt turn on debug logging until it had been a while and i thought the buffering thing was about to happen. It did, and I went to upload the logs but got the same invalid URL. Then I tried the SSH method with -A instead f -a and that gave me the same result. I tried with -d and that gave me a valid URL, so maybe i have to pick and chose which logs to upload that way? What would be the best one to post?


#10

Are you also enabling the component specific logging? Because this almost always results in the behavior you describe here.


#11

I’m not sure how you could generate a 10M log in such a short time unless you have a spammy addon or excessive logging

Try checking the log manually and finding out what’s bloating it so much

Sam


#12

Nope, only debug logging. The stats show up in the corner of the screen and I try to repro the buffering issue. Then after getting it to happen, I try to use the MyOSMC log uploader. My addons are transmission and spotify, neither are running at the time.


#13

I suspect your buffering issue is probably related to the drive issues reported in the other thread that you have created.

When you next reproduce this, it would be good to know if you can play a video off the internal storage (doesn’t need to be anything fancy), to rule out issues with Kodi stability


#14

got the buffering issue to happen and tried playing a vid off the internal storage but that also buffered forever. I enabled logging and tried to play a few things then uploaded them so they were small enough to go through. They are here:
http://paste.osmc.tv/usuvebahex
Thanks again for your time, guys!!


#15

Hi

I’m looking into this. It looks like I can source the Colbert file as a test.

Is this occurring always with Live TV? Does manually setting 60Hz as the framerate and disabling Adjust Refresh Rate solve the issue? This is just for a test.

We also have some Live TV improvements, but it depends if you feel brave enough to try them.

Sam


#16

In my settings the frame rate is already 60 and auto-adjust is turned off. I’ve experienced the issue with video files being read from the external HD, and when it occurred last I also tried to play a test video that i had copied to the internal storage, which also failed in the same manner. It’s like the vero just suddenly gets to a state where it simply will not play any video at all until it is rebooted, then it works again, for a while.


#17

I have been experiencing a similar issue over the past few weeks. I try to play a video and, although the green play symbol appears, nothing happens. Only a reboot solves it. It is intermittent but happens more than 50% of the time.

I have changed nothing (except to install the March update). My videos are served from a Synology NAS.


#18

exact same issue on PI3 when switching channel on TVheadend client.

  • the issue appear randomly
    -I need to manualy restaty the PI.

It is working perfectly since 2 years, I am only having this problem since a month or so.


#19

I’ve had a similar issue, created a thread about it, but nothing was fixed unfortunately.


#20

We are introducing some video playback improvements in a couple of days. I’ll then revisit individual clips for people.