First Vero 4K+ impressions

#1

Hi,

Trying out my newly received Vero 4K+, to replace my Odroid C2 (using eMMC Flash storage) because I mainly wanted to get proper HDR support.

I am streaming from my Synology NAS via SMB. Unfortunately the Vero 4K+ seems to struggle already with the “jellyfish-110-mbps-hd-hevc.mkv” from http://jell.yfish.us/ , while my old Odroid C2 can easily stream the “jellyfish-400-mbps-4k-uhd-hevc-10bit.mkv”, using exactly the same connection (cables, switches, …).

Yes, I know NFS would probably be more efficient, and real video files almost never reach such high bitrate, but still - it’s a bit dissapointing.

Another thing I noticed is that the included remote control is a bit slow to browse through the menu’s. When I use a USB keyboard, or my old IR remote, it’s much faster. Pity, because I like not having to point in the right direction.

Apart from this, it seems to be a very nice device. Good work.

#2

Eduarxox,

thx for your feedback.

Regarding the JellyFish demos, have also a look here: Lost 2160p on vero after update

For me the statement regarding the remote control is more astonishing: The shipped OSMC remote controls are RF devices, so you don’t have to point in any specific direction. Also from my experience the reaction time for the RF remotes is much faster than any IR device.
Could you try a re-pairing of the OSMC with the RF receiver which is described here: Pairing the Original Black OSMC RF Remote Control with a Pi/Vero2/4k/4k+

#3

Thanks for your feedback.

The remote speed will be improved in the next update as we have re-worked the remote subsystem significantly.

You should be able to play the Jellyfish file just fine with a good connection.
Are you using an fstab based mount?

Sam

1 Like
#4

I know, that is why I said that I like not having to point at the receiver, but I still ended up using my old IR remote.

I tried pairing again, but the blue light is steady on instead of blinking, after pressing both buttons long time. It is blinking 3 times however, when re-inserting the USB dongle. So I guess it re-paired. Unfortunately still slow. I use the default Kodi skin, and the main menu on the left is lagging behind when I quickly press the cursor up or down several times.

The “Lost 2160p on vero after update” is not applicable for me, because I can still watch 2160p, just not when the bitrates are very high (stuttering).

#5

No, I used the standard “Windows Network (SMB)” in Kodi’s “Add network location” (just like on my Odroid C2). I can try fstab though.

#6

CoreELEC uses LibreELEC as a base and may have a newer version of Samba which is more performant.

We are tracking Debian Buster aggressively and will update Samba soon enough; but for now, use an fstab mount if you can.

The video engine in Vero 4K / 4K + will yield better result than that of the C2 as it’s a newer architecture.

Sam

#7

I’ve just been testing the jellyfish demo files on my vero4k+. Accessing them over gigabit ethernet using systemd samba automounts.

I only had issues with the 300mbps and 400mbps uhd hdr files. For those, a few frames were skipped by kodi. I had the PlayerDebug information on-screen, and could see my vq figure stayed right up at 99-100% when the frames were being skipped, so this didnt seem to be an issue with throughput.

All the ‘real-world’ uhd rips i have play fine, so im not concerned by this; so long as it handles the 140mbps jellyfish clip, then this is a good indication that real-world clips play fine.

#8

I tried with fstab now, instead of Kodi’s “add network location”, and that is a spectacular improvement, thanks!

It’s still struggeling with 300 and 400 Mbps HVEC, and also 250 Mbps H.264, but at least they are playable now. I’m surprised that @jahutchi still seems to have better performance though (especially because my C2 plays even the 400 Mbps without any dropped frames, via the same NAS)

#9

You don’t say what OS you are using on the C2. Maybe there’s something we could look into.

#10

LibreELEC

#11

I’d be more concerned as to whether the C2 and Vero are running the same version of Kodi.

#12

This is mainly academic as all my real-world 4k content plays fine. But here are the numbers of skipped frames i get when playing the jellyfish high bitrate clips over my samba systemd automounts:

jellyfish-400-mbps-4k-uhd-hevc-10bit.mkv: 7
jellyfish-300-mbps-4k-uhd-hevc-10bit.mkv: 4
jellyfish-250-mbps-4k-uhd-hevc-10bit.mkv: 0
jellyfish-250-mbps-4k-uhd-h264.mkv: 40 (intetesting!)
jellyfish-200-mbps-4k-uhd-hevc-10bit.mkv: 0
jellyfish-200-mbps-4k-uhd-h264.mkv: 49 (intetesting!)
jellyfish-140-mbps-4k-uhd-hevc-10bit.mkv: 0
jellyfish-140-mbps-4k-uhd-h264.mkv: 0
jellyfish-110-mbps-hd-hevc.mkv: 0

Had previously only tested the 10bit clips which as shown above only skip frames for the 300 and 400mbps variations.

These tests were performed on kodi leia (latest stable april release).

With the playerdebug info on-screen it looked like my vq% stayed at 99-100 even on those with frame skips.

#13

Odroid C2:
Kodi 18.2
LibreELEC 9.0.2

Vero 4K+:
Kodi 18.2 RC1
OSMC 2019-04-21

#14

I can play the higher bitrate content here (tested with USB storage).

#15

Can you also test via the network?

#16

Later – yes.

#17

Tested with NFS here without issue (using fstab based mount).

#18

Worryingly, I copied the jellyfish sample files to the vero 4k’s local storage and get pretty much the same numbers of skipped frames as i reported above :frowning:

#19

h264 will always be worse than h265. Not sure why.

#20

Sure…just a little perplexed as to how sam can play them all back without issue