Frequent random freezing


I have Raspberry Pi B+ with OSMC (latest version: October 2015.10-1). I have USB HD attached. After September update OSMC frequently and randomly freezes. It happens while playing movie/video and it starts with sound muting and in few seconds it freezes. I can’t connect to it over SSH, but I can ping it. All I can do is unplug power cable and restart it.

I tough it was because I have Deluged torrent service running on it, but it also happens when I stop the service. Here is log paste with debug mode on:

Please help me.


since i have seen a lot of instability with usb hard disks directly connected on the rpi i would suggest 1st thing to buy a self powered usb hub (one with its own power brick) and attach the hard disk on it.

If this is out of topic i am really sorry.

I have IcyBox USB docking station ( It has it’s own power supply.

Anyone? Please.

Are you overclocking?
Is your power supply up to scratch?

No, I’m not overclocking, I have default CPU settings. Power supply for Pi and HD are both original.

Pi doesn’t come with a power supply unless some retailer bundles it. Please give us the specs on yours.

If it’s the type that uses a micro usb cable, try switching that out.

Here is the foto of power supply specs. I don’t think it’s power supply cause it was working normal for year and a half.

I’m having exactly the same issue. Worked well for past an year and with an update it just started randomly freezing.

Also can’t access through ssh. Sometimes it happen while in idle, sometimes during playback, the sound mutes and after a few seconds the whole system freezes.

My hdd is also independently powered and has always worked so i think this is a software issue introduced.

I’ll try to move to an old version to see it that sorts it out

What overclock profile are you using ?

Medium I think. Nevertheless, it has been configured for about 1 year and I have never touched any of the settings again.

Yesterday I did a backup of my .kodi folder, installed the August version and re-applied my settings, so far no freezes.

Will keep reporting for the next few days.

I’m using default profile, I never change it. Two days ago I did a clean install of osmc and so far I had two freezes. It doesn’t look good.

Nevertheless, the first port of call when having issues with freezing should always be to drop back to normal overclock and see if the problem goes away.

Just because it has worked for the last year does not mean that the power adaptor could not have degraded over that time (including the connectors) or that a USB device you are using now draws more power than ones that you were using previously etc…

Even changes in software can lead to the CPU running in Turbo mode more often (The Pi CPU is dynamically clocked based on demand) which puts more demand on the power adaptor and can lead to freezing if power is marginal.

So this could be because of Deluge torrent running in the background? When I enable debugging I can see that CPU0 is most o the time 100% and CPU.KODI is between 20 and 40%? Cause I just added new torrents and I got 3 freezes in 1 hour. I will stop deluge and see what happens.

Hi Guys,

I’m Having the same problem with the last update.
When playing video the sound suddenly stops and then the pi freezes.
before i updated it never froze.
also when navigating troug the menu’s it freezes and first the sound disappears.
first i tought that some codec was missing.
sometimes it plays for a few hours correct.
i can always acces trough ssh when it freezes doh so no error there for me.
but it realt started directly after the update.
i have nothing externally connected exept my remote.

My deluge sees a lot of use and this hasn’t ever been an issue for me. You might want to ssh into your osmc and run top. That may help you figure out what’s putting such a load on your cpu.

If you can still log in with ssh then enable debug mode in Kodi, use it normally until it freezes, then through SSH capture all logs:

grab-logs -A

Please post the resulting URL. After you have done this, try restarting Kodi from ssh to see if it recovers without needing a full reboot:

sudo systemctl restart mediacenter

Well I didn’t have this kind of problems till September update. Yesterday I replaced Deluge with Transmission and load was a bit smaller but I just got first freeze. I will try Qbittorrent to see if there is any difference, but I think torrent process is not the problem.

Here is my latest (debug) log:

Have you tried running the system without any torrent client running in the background ?

Unfortunately your log was taken after a reboot so the system journal from the session where it “froze” is lost. If possible please try to log in with SSH and capture the logs before rebooting.

Hm, when system freezes I can’t connect to via SSH.