HDMI-CEC stopped working after May update on LG and Samsung TVs

We recently upgraded to the May upgrade of OSMC (06 June 2017) on Pi 3 and 2+ and we experience severe issues with HDMI-CEC. All OSMC units have stopped communicating with 2 out of 4 LG TV sets using HDMI-CEC and one out-of-the-box Samsung UE65KS8000L! In other words, we can see the Kodi desktop on the TVs HDMI input, however we can no longer control it via the TV remote.

We tried several HDMI inputs on the TV sets, we turned Simplelink/Anytime (depending on the model) on and off, we reset the TV and the OSMC unit in different orders… to no avail. We cannot control the OSMC unit using the TV remote and HDMI-CEC as before.

We noticed on OSMC's May update is here - OSMC that changes were made to the CEC on all platforms within this version. Can anyone point out a potential fix on this issue? It is driving us mad as it happened all of a sudden!

Last but not least, has anyone succeeded in controlling Kodi/OSMC using a KS8000 Samsung TV series?


Have you tired turning the TVs off at the Mains for 10 minutes? After powering the tv, power or restart pi.

Also have you tried changing the Input away from pi, then back. Does cec work then?

I’m assuming you have upgraded from the April release, is this correct? Also are you running the latest may release, 2017.05-2?

If all else fails logs will help.

Thanks Tom.

Hi Tom,

Thanks for the quick reply. Unfortunately I’ve already tried your suggestions to no effect.

Next stop… the logs!

As promised, here are the logs…

The kodi.log -> http://paste.osmc.io/raw/qohusizaza

… and the output of the cec-client command -> http://paste.osmc.io/raw/weyeselife

It seems like Kodi disconects the external CEC device (TV) and any commands received from it are discarded…


Your first post mentioned issues on 2 lgs and a samsung, which one is the log for?

Thanks Tom.


The one indicated @ the first post, Samsung UE65KS8000L. I haven’t obtained logs from the LGs yet.


DEBUG: [ 1219] not sending command 'set osd name': destination device 'TV' marked as not present

Doesn’t look like libcec is recognizing The Samsung, have you tried a different HDMI Cable?

Thanks Tom.

Hi Tom,

Yes, 3 different cables :frowning:

As promised, here follows the log from an LG 55UC970V :


… and the corresponding cec-client debug log:


The line above does not appear in these logs, however any contol through CEC remote is not feasible.


Anyone with an idea on this CEC malfunction as it deems all TV sets kodi-unusable?

This is a horrible generalization. There are no indications that it affects all TV’s.

The problem is upstream with pulse-eight’s libcec. OSMC can only wait for them to resolve.

@ActionA : I am not making a generalization… I have mentioned two specific TV sets, both latest models from LG & Samsung, which experience CEC issues with Kodi. Hence, the “all TV sets” refer to the ones I mentioned. We own two earlier Samsung and LG models where Kodi can be controlled through CEC.

Therefore, as I understand from the second line of your answer, the issue is with the library implementation. Can this get upgraded individually from the rest of OSMC?

@mx5gr has cec worked for you before the May update?

Yes, it was working on the LG model I mentioned. The Samsung one was not present back then.

I created the latest stable 4.0.2 of this library, libcec, for you.Âą

I guess you have a raspberry pi 2 or 3? Then try those 4 commands, after login via ssh:

Just Raspberry pi 2 & 3:
cd /tmp/
wget http://pingumale.bplaced.net/rbp2-libcec_4.0.2-osmc.deb
sudo dpkg -i rbp2-libcec_4.0.2-osmc.deb

(*For Raspberry PI 1 replace rbp2-libcec_4.0.2-osmc.deb by rbp1-libcec_4.0.2-osmc.deb in step 2&3.)

Please report: does it fix your problem? If yes, please provide a log, so I can compare it with your broken log.

[ÂąJust as a notice - for developers - to reproduce: checkout current osmc from github, cd to osmc/libcec-osmc, replace commit in build.sh with 5250931, remove patch all-005, make.]

Two is anecdotal evidence. Particularly when compared with the number of users that OSMC has.

You told us to add all-005 in the May update, so that’s what we did. I don’t have many TVs to test CEC on but did publish some test builds before the update and results were positive.

Have you found that this patch shouldn’t be included?
If so, then PR changes accordingly

Why this revision? The revision we use shouldn’t be causing any problems. The problem is if you revert to this version, you will break things for other users. There seem to be fewer users affected by the current libCEC release. I’d look in to things if there were complete debug logs – so far we have a debug log in this thread but component based logging is needed.



No, with all-005 everything is fine. But it fixes a bug that was introduced later than 250931, the version I compiled here.

So, all-005 is only applicable for d1a708b and newer, but 5250931 was before.

For OSMC: don’t change anything! I fully agree that for the most users the current solution (latest libcec + all-005) is working and therefore the best we can do. Libreelec users also confirmed that this patch fixes d1a708b.
The idea behind the .deb for mx5gr is, to check if there is an additional(unrelated to all-005) bug introduced in the march libcec commtis. To verify if it makes sense to take a closer look at those commits, or if it is a general bug… To compare it, we have two builds where the bug (that one which all-005 fixes, introduced in d1a708b) is not there: your latest official OSMC build and all versions before d1a708b. I chose a bit random 5250931, because it was before the bug and that version which bumpes libcec to version 4.0.2.

So, this is just a build for mx5gr, to locate the bug. No general solution, and not recommended if cec is working for someone…
Btw: I added the reproduce notice just because you asked for it a month ago, when I created some testbuilds to locate the all-005 bug…

@pingumale Thank you for your response and custom build!

I tested the deb file you sent and I have to report that… it works on the LG (I cannot test it today @ the Samsung)!

Of course, the LG remote keys that are functional with Kodi functions are much less than those on Samsung (almost all Kodi functions are mapped), however basic functions such as the cursor keys, OK, play, pause are operational.

Kodi log: http://paste.osmc.io/raw/icidalipuw

CEC-client dump: http://paste.osmc.io/raw/uwewuqevep

You still need to upload proper debug logs with component logging if you want this resolved in OSMC.

@sam_nazarko the logs uploaded above are with “enable debug logging” enabled within Kodi. Is there another level of debugging that I should enable?

The logs included within the previous posts had the same level of debugging enabled

Yes, enable component logging for CEC.