HDR video too dark on a HDR TV

I got a vero4k, connected to LG oled55c7 (b7) 4k hdr TV. Originally I played movies with an internal plex client on the tv. The colours and dynamic range of HDR video on that TV is stunning, especially with the technicolour image setting.

However, after setting up the vero4k, I can’t get the same video quality. The image is dim, and appears to have somewhat less colours, or range of colours. The video is recognized as HDR by the TV though.
Also, this occurs ONLY when playing 4k HDR. All other videos seems to be working.

Troubleshooting:

  1. First I thought it was the 8bit/10bit issue, so I added the 10bit444 command in rc.local, that solved some ugly gradiants at least.
  2. Switching the supplied HDMI with another fixed some stability problems, at least when running 4:4:4 4k HDR through the amplifier.
  3. Toggling the HDR option in OSMC settings didn’t do anything that I noticed. Nor did the adjust-refreshrate.
  4. Copying the technicolour image settings from when running internal plex HDR video, to HDMI3/vero4k HDR input did not do anything (this is a function in the tv). Also, I made sure that HDR videos were playing while checking the settings.
  5. Using another image profile on the TV, I managed to get a brighter image, but I noticed clipping, and the colours became worse.
  6. EDIT: I also have connected the vero4k both directly to the TV, and through a Marantz receiver/AVR. As long as I did not use the supplied HDMI cable, there was no change(see p2 above). The video processing on the AVR has been turned off anyway.

Does anyone have any idea?
I have read something online about 0-255 brightness range, could that be configured wrong? I got a year of debian experience, and some years of electronics education, but I’m lost when it comes to video signal protocols…

I should mention that I noticed the “debug information” (when running a video) is displayed a bit outside the TV frame. It’s the same for the side-bar menu that you can get in the main menu by pressing “left” on the controller. Could that indicate anything unusual?

It indicates that you need to change the aspect/overscan settings on the TV.

Have you activated deep colour for the hdmi port the vero is connected to?

Wierd. Changing aspect on the TV does nothing. Changing UI from 1080p to 2160p fixed the side-menu. However, the debug text during playback is still outside the tv frame. And yes, the tv reports 4k hdr.
I’ll see into overscan options, but I thought that was from earlier days and crt tv’s?

Unfortunately not.

If you set 444,10 manually, do not enable HDR autoswitching.

That’s more of an RGB thing, so things are a bit different here.

Can you try a photo of what you see vs what you want to see?

Some debug logs will also help me see if things are set correctly on your side.

As you’re using Plex, can you make sure there is no transcoding or anything that may be interfering with the stream?

Sam

I have the same issue but on LG B7 with Denon x1400h. The HDR images are way too dark.

I have tested all cables and they can all go 18GBs .

Will take some pics for you to see tomorrow.

Can someone help me with how to create a log for Sam? Thanks

Can we confirm that we’re using proper HDR rips and not some heavily compressed MKVs?

You can get more information about logs here.

What setting have you used?

I have the same TV as you and 4K HDR seems normal to me but I have nothing to compare the Vero to other than the TV’s internal apps. Watching Planet Earth 2 on the Vero does look as good as watching the Grand Tour via the Amazon app at least.

For overscan, go into picture settings on the TV, click on aspect ratio (it should say 16:9) and make sure that “Just Scan” is set to ON.

2 Likes

Hi again all,

Al lot of good suggestions and questions here. Thanks!
I’ll try to go through all in an orderly fashion.

Aspect/Overscan:
Okay, using 2160p fixed it. While using 1080o, changing aspect ratio did nothing (i tried all available). Enabling overscan (LG: just scan: on) also fixed it. Nice!

Deep colour is enabled on the correct hdmi port.

osmc HDR autoswitching is off. (444,10 is manually set in rc.local)

Photo and logs are coming asap.

Regarding proper HDR rips. I don’t know how to define a proper HDR rip. But all HDR rips are looking good on the internal TV plex player (xplay for LG tv’s), and are sourced from Bluerays (not ripped by me), in sizes from 5 to 30GB. Plex transcoding is disabled, or at least not used. I believe my i5-lowpower cpu would explode trying to transcode a 4k HDR.

Regarding Plex, I don’t use plex for the vero 4k. I use samba shares from a windows computer, and fstab mounted in vero. Using 5GHz wifi.

Also,I have tried changing cabling and reinstalling OSMC on the vero4k. No change.

To be honest, I’m suspecting the TV settings. I’ll probably try a factory reset of the TV after taking photos and logs.

I uploaded the logs here (in order to remove the smb password from them):
http://axefjord.duckdns.org/vero4k-log.txt

Attached is two photos taken with a fullframe dslr, identical exposure/iso/whitebalance, and converted from raw to jpg i lightroom.

And lastly,

A TV factory reset did nothing, the problem remains. The only changes after resetting was enabling deep colour (in order for the video to be shown). Other than that. I checked that both tv image settings was “standard”.

i have managed to plug my PC my AVR (same and cable port as the vero before) and the video was as bright as playing the file using the TV’s internal player.

So i have to assume there is something not quite right with my vero. I will try to get some logs out later today

Can you upload a debug log and mediainfo sample? Depending on the source of the material we might not be detecting it as HDR properly

Does your TV show HDR when you press play?

Hi Sam,

First, I’m impressed by the time and effort you put into each case. I’m really appreciating that.

Secondly, you probably got that right.
While all my HDR non-demo videos (movies/series) does not work, I downloaded the LG new york hdr-demo (.ts format) from http://4kmedia.org/lg-new-york-hdr-uhd-4k-demo/ , and that worked!

Installing and using “mediainfo” on the vero4k gives an informative output of the LG demo, while my planet earth 2 mkv did not give any information at all (nor anything on mad max or a couple of other movies).

Installing and using MediaInfo on windows did give information on planet earth 2.

See mediainfo:
http://axefjord.duckdns.org/planetEarth2_windows.txt
http://axefjord.duckdns.org/LG.txt

And yes, the TV has always shown the HDR sticker on every HDR video, regardless if the problem is there or not.

I use LG OLED 65 B7V, and the LG got its own settings for each mode (HDR, Dolby Vision and SDR). You need to punch up the strength of the OLED to HDR or Dolby Vision. I have a bunch of remux UHD Blu-rays, and they all look good.

Have not read the entire thread, but do you have something in between your Vero 4K and OLED TV? I know some receivers/surround processors strip the meta-data for HDR. But on the other side, if you get HDR working on some of your test-files, then this is not the issue.

HI,

i also can confirm that on my LG OLED 55C7 4K HDR via Vero 4K ist too dim compared to other 4k hdr Players like apple tv or the internal lg Player app.
10 bit is set via rc.local .

THX Very much

NIP

Hi Sam,

If mediainfo is used in order to recognize HDR videos, then I might have made a breakthrough.
Using the mediainfo command on the vero 4k gives no output on any files on my mounted samba share. Neither HDR or any other. However, after copying the files to the vero4k local storage, mediainfo gives a valid output.

I’ll try other forms of sharing the files, to see if that fixes the problem, but I’m travelling for a week, so we’ll have to see when I get the time again.

Tor.Gunnar:
Thanks, I have set the display settings during actual playback of HDR content. Is that what you indicated? Also, while debugging, I have connected the vero directly to the TV.

Setting the display settings during playback of HDR is the correct approach. I have tried viewing the same file from both Vero 4K and my oppo 203. They look the same (slightly better quality on the Oppo 203, but no difference in brightness).

Are you sure you have enabled the 10bit 4:4:4 output; setting it in rc.local did not actually set 10bit 4:4:4 on my system. I had to connect via SSH and enable it manually. No sure why, but this could be related?

On my system i have this signal path: Vero 4K => Marantz AV8802a => LG OLED 65 B7V.

The beauty of this setup is that I can check the video signal in Marantz AV8802a received from Vero 4K, that it is actually 4:4:4, and 10 bit. Pre firmware upgrading my Marantz AV8802a; I did not get HDR from Vero4K, or dolby vision from Apple TV 4K.