Headless Pi boot failure

The latest update to OSMC on Rpi (20210808) has caused a number of complaints here, like “My Pi no longer boots unless connected to a TV/monitor via HDMI.” I’ve used a headless, no-video OSMC/Pi 3B for years as an AirPlay receiver, and I can confirm that the update was negative in this respect. Analysis elsewhere on the forum is correct: without a connected HDMI the Pi does not find a display device and won’t start the desktop nor any applications that depend on it. This also affects sshd, which will authenticate incoming clients (as seen in the verbose output) but never offer a usable terminal session. The fix often suggested (hdmi_force_hotplug=1) does not cure the condition for me, whether it’s put in config.txt, config-user.txt, or both… it seems to have no effect. I also tried various hdmi_group/_mode pairs, following advice about forcing a mode change, but no luck. Has anyone brought their headless Pi3B alive after this update (the dual-video Pi4 might be a different case)? If not, how many releases must I drop back to restore the old behavior? Thanks!

This is a known issue with the upstream Raspberry Pi kernel and it looks like this is still open.
We will wait for a fix from upstream.

You could try disable_fw_kms_setup=0 in config.txt

There was a workaround to this provided yesterday (17 Aug):

BTW, it worked for me. (I noticed the reference to DRM in the workaround.)

Can you provide a link to this?

Certainly.

See drm/vc4: Initialization

1 Like

@fzinken’s suggestion works and is simpler. We tested it this morning.

2 Likes

I can confirm that this setting allows the Pi to boot with no monitor/TV attached. I had previously included the setting (hdmi_force_hotplug=1) in my testing and it was left in place.

With the Pi booted and the osmc webserver started, I notice that my previous choices for audio have changed. I used to have a few ALSA entries (gone now).

My USB DAC is listed, and when I choose it as the audio output device and reboot, I see the DAC sync with the Pi (on the DAC’s display). Good. I can choose the DAC as an AirPlay target on my phone. Good. But when I play music to it, there’s no audio output. This might be a new thread topic as the Pi does boot headless, but I thought I’d mention it

Some more insight in what @dillthedog wrote and links to helper scripts from libreelec can be found in the KODi forum Start Kodi without TV on

Works for me, as well. Cheers.