Help with .mkv files

New 4k + box, installed no problems, setup Synology NAS, no problems, watched all movie file types, no problems, then all of a sudden I cant watch .mkv files (HD). They just won’t play any more. Tried 720k HD .MP4 files, they play ok.
The box did do an auto update yesterday, but the files still played last night, unless the box did an update without me being there in the early hours?

Any ideas chaps ?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Wow ! that was hard, but got it eventually
Link to logs

Also, is there a soft reboot option as i cant find this anywhere ?
It might help you find the problem if I tell you the Video file is “Longmire”. the file name is .265 but it is not in that format.


These are not full debug logs, please follow the instructions provided by ooZee.

Thanks Tom.

I DID follow exactly what I was asked to do, and this is the result.
So ill try again, and upload another log file.


Ok any particular reason logs are not being uploaded to ?

Thanks Tom.

Log files


Still not full logs, any reason you are not using osmc’s log uploader?

Thanks Tom.

Yup, it doesnt supply a url for viewing

It will if you reboot twice before attempting to create logs, just as the instructions provide.

When viewing logs in Grind > FTG Maintenance, I get 2 different screens, and I cannot choose which, its luck

Yup rebooted twice before activating fault

WTF is grind or FTG Mainenance? They have absolutely nothing to do with the provided instructions?

Grind is the automatic installation on boot, this is how I received the box

I didnt receive this box direct from osmc, but from CPC.


I suggest doing a factory reset:

If you rather not do that:

If you remove the add-ons and repositories listed here:

Is the problem still reproducible?

Also for further reading:

Thanks Tom.

I would prefer to do a factory reset, obviously thats why i cant do what you want me to do, because I am not seeing what you expect me to see.
Also, I need stuff to be as it should before I start spending time setting it all up.
Thanks for your help guys, Ill do just that !

1 Like

How do you create a USB stick bootable image if you only have a linux pc ?

Transfer the image ( with dd onto the USB stick