Help with OSMC update after upgrade


After upgrading OSMC to the latest release last night, I’m having trouble checking for new updates with the message that I have Insufficient Space and to try again later. I’d appreciate any help figuring this out.

My logs are here and details are below:


I hadn’t done an update since November 2020, as the automatic update had stopped working for some reason I never investigated. After running into a strange Kodi issue (more on that later), I finally decided to do an update last night. After researching the issue, trying the HotFix (first via UI and then command-line) and then doing a command line upgrade (via “apt-get dist-upgrade”), I was finally able to upgrade successfully.

I then started an Update via the My OSMC Check for Update UI and after making sure the update had started to download packages successfully, I went to sleep. When I woke up, the UI was unresponsive, but I was able to ssh in without problem. So I did a reboot and then tried to do another update via My OSMC just to make sure the previous update had completed successfully.

I received a message (upper right corner) that it was downloading 46 packages, for a total of 0.0 Kb, and then after a couple of seconds, I got the “Insufficient Space - Try again later” message. Every attempt results in the same message. I’ve tried running “apt-get dist-upgrade” since and it always runs cleanly with 0 upgraded and 0 not upgraded.

That’s it for the OSMC-specific stuff. I’ll mention a couple of Kodi issues just in case they provide further clues to this Update issue:

  1. I can’t seem to download new skins. Going to “Settings → Add-ons → Install from repository → All repositories → Look and feel” shows only “Image collections” while going to “Settings → Interface → Skin → Skin” only shows the 3 default skins along with a Cancel button, i.e. no More button is displayed.

  2. Here is the Kodi issue that precipitated the upgrade in the first place and still persists after the upgrade: Whenever I try to play a video, it takes about 50 seconds after I click Play for the video to actually start playing. And that happens every time. Even playing videos from a Playlist takes 50 seconds for each new video after the previous one in the Playlist ends.

Please let me know if anyone has any suggestions or additional questions.

Thanks in advance.

I had a similar thing happening. You can read about it at Extremely slow network

@BGIYYZ Thanks a lot for sharing that pointer about the delayed playback start.

The idea of something waiting to time out had occurred to me, and this seems to confirm it. I’ll go ahead and try the settings trick, and if it works, I’ll revert and then proceed to uninstall my plugins one by one until the delay goes away. This will take a while to go through, but I’d like to pinpoint the guilty plugin. I’ll update this thread with my findings.

Meanwhile, if anyone else has any ideas as to why I can’t seem to update OSMC, or why I can’t find any new skins in the repo, I’m all ears.

1 Like

Logs don’t seem to be in debug mode so difficult to diagnose.

However, you have a lot of error messages regarding accessing different repositories.

Suggest temporarily trying a clean default profile as describe here - Extremely slow network - #30 by darwindesign

The repository seems to be temporarily unavailable - see Repository down?

The OSMC APT repository and Kodi repository are separate and the issue with the Kodi repository which was fixed earlier wouldn’t have affected OSMC updates



Thanks to both djbloc and sam_nazarko for your helpful replies. I’ll take points in turn.

This is spot on. I can indeed confirm that the Kodi repository is working fine for me now. I have been able to get my skin back. So that issue is solved. However I’m still unable to get Update from My OSMC to work.

Yes. @BGIYYZ had suggested the same. And I can confirm that my videos start playing immediately with a clean profile. So thank you both.

I still want to try to pinpoint the culprit plugin. But that will be a long, tedious exercise. I’ll update this thread again when I get to the end of it.

As far as the OSMC Update issue – I always get the Insufficient Space error – is there anything I could do to provide additional debugging information?

Looking at the Logging System Settings, everything is check-enabled. However, I don’t have Verbose turned on for any of the items under “Specify component-specific logging…”

Are there particular items on that list which I should make Verbose to help shed additional light on the OSMC Update failures?

Thanks again all for your help.

Something is off with your system, how did you create the SD Card? I doubt that you have used the OSMC Installer. You ran out of space on the boot partition.

/dev/mmcblk0p6   79M   52M   28M  65% /boot

To be honest, I don’t remember. I bought and installed this Pi 3 over 7 years ago, and I’m sure I would have followed whatever was the recommended practice at the time, as this was my very first experience with the platform. I then invested a lot of time into getting it configured just right for my needs, which is why I’ve never upgraded the device itself.

I had wondered about that, but thought that 28M/35% free sounded sufficient for updates. Also, as I mentioned above, I had just successfully upgraded from a Nov 2020 to a July 2023 distribution, and then apparently updated it, before the next update started complaining about space.

Also, running “apt-get dist-upgrade” at the command line seems to run fine, and outputs:

Reading package lists… Done

Building dependency tree… Done

Reading state information… Done

Calculating upgrade… Done

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

So I’m not clear why the My OSMC Update is complaining about space.

In any case, are there any recommendations on how I could free up space in the boot partition?

Thanks for the reply.

Well if update via command line is working then continue with that.
OSMC Update is complaining as the 28M would not be enough to install the new kernel while keeping the existing one. The standard boot partition of OSMC has a size of 316M

/dev/mmcblk0p1  316M   62M  254M  20% /boot

You hardly can free any space with the current structure of OSMC

Yikes. That’s way bigger than my 79M partition. Maybe the kernel has put on some weight over the last 7 years. I can certainly relate.

From reading around, it appears that the My OSMC Update is recommended because it’s supposed to grab additional Debian packages. If I managed to live for almost 3 years without updated versions of those packages, I suppose I can continue to live without them.

In any case, I think I’m going to treat myself to one of those cool-sounding Vero V’s when they become available to the uninitiated. I should be able to limp along until then. That should also give me enough time to track down all the OS configs I made to my current Pi to turn it into a media and file server.

Thanks again for all the feedback. I’ll update this thread with the identity of the guilty addon once I narrow it down.

Is also doing apt-get dist-upgrade so if that is how you update and it doesn’t report errors (assuming you run apt update before) you are fine.

I’m hoping for end of next week. Depends on how quick the website can be brought up.

If you sign up to the Newsletter you’ll be the first to know :slight_smile:

Cool. I’m all set then. Thanks again.

Just did. :wink:

Good luck with the launch.

1 Like

Just out of interest, what was your skin of choice? Mine was Arctic Zephyr, though it seems it was some other add on that was causing the delay problems

Eminence. I have a plasma screen, so I want the lowest contrast possible with minimal extraneous lettering.

Anyway, Eminence is the only addon I’ve provably ruled out as a suspect, given that I kept experiencing the delay even before I was able to download skins from the repository.

I wanted to update this thread to say that I have not made any fundamental progress on the mystery of the delayed video playback.

I did rule out any of the addons that were generating error messages by first disabling and then uninstalling them. The delayed start remained unchanged.

I’ve since cleared all other error messages at the time of playback, except for one set of messages that make no sense to me.

But first I wanted to address this:

It turns out that long ago, I had modified advancedsettings.xml to turn off Debug mode. And that setting can’t be overridden from the UI.

Having turned Debug mode back on, I can now post a partial debug log from around the time of the event:

I press the Select button to play the FOOBAR.mkv file at the 14:36:01.335 mark and nothing of note seems to happen until the error messages at the 14:36:50.266 mark, after which the file is opened and played.

However, I have no idea why GetDirectory would fail persistently for /home/osmc/.kodi/temp when that is the precise directory where the log file is successfully being written. As far as I can tell, directory ownership and permissions are as expected:

drwxr-xr-x 10 osmc osmc 36864 Aug 24 16:18 /home/osmc/.kodi/temp

So barring any further suggestions, I’m perfectly happy to turn the page on this. I’m up and running in a new environment to which I’ve copied my old settings. I just need to figure out how to get my old library in there and I’ll be all set.

Thanks again for all the help. I wish I could have helped clear up this particular mystery.

I really don’t know but we have seen where some backups or other things get stuck there and it produces some unexpected behavior. You could try just deleting the entire .kodi/temp folder and restarting Kodi and see if that makes a difference.

When those two time jumps happen the only thing in the log is CEC communication. I would try deleting your CEC settings and retest…

systemctl stop mediacenter
rm ~/.kodi/userdata/peripheral_data/cec_CEC_Adapter.xml
systemctl start mediacenter

Winner, winner, chicken dinner!

I moved aside the old temp folder, created an empty new one, fired up mediacenter and BAM, all videos play instantly!

I can’t believe how many times I looked at that error message and dismissed it out of hand. Just sheer arrogance on my part.

Thanks so much, @darwindesign, for wading through the posts to come up with your bull’s eye suggestion. And thanks to everyone else who helped me piece this whole thing together.

I’ll try to update @BGIYYZ’s old thread with a pointer to @darwindesign’s post.

1 Like

So you still have the old temp folder? Any idea what exactly in there is causing the issue?

You suspected it. I give you the accused:

-rw-r–r-- 1 osmc osmc 182331504 Jan 14 2023 OSMCBACKUP_2023_01_14_03_15_23.tar.gz
-rw-r–r-- 1 osmc osmc 941217457 Apr 28 00:39 OSMCBACKUP_2023_04_28_00_28_05.tar.gz

If the older (and smaller) backup is in .temp by itself, then videos take about 11 seconds to start playing.

If the newer (and larger) backup is in .temp by itself, then videos take about 50 seconds to start playing.

If both files are present, then videos take about 50 seconds.

From that, I conclude that the most recent backup file is inspected before every video starts playing. Which is… interesting.

I gather that backup files aren’t meant to be left in .temp, so these presumably got left behind when a couple of backup attempts failed for whatever reason.

1 Like