[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


#1232

Here is what I used to get Raspberry pi3 Bluetooth to work on PS3 controller this lets you function Kodi and Retropie !
https://www.piborg.org/rpi-ps3-help


#1233

Nice


#1234

Hi Guys,

quick questions, my PI2 really struggles with FBA and some CPS-1 and CPS-2 games, is that normal?
Some of those games work fine with Mame but still rejected with PiFBA, and I didn’t get the reason.

Was I wrong thinking the PI2 can emulate all the bitmap arcade games without issues?

Thanks,

D.


#1235

@Danielsan2015 Have you tried the same on Recalbox or Retropie? If there is a problem probably here you will also have the same


#1236

No I didn’t, I just use “Retrosmc” available following the guide on top of this topic.


#1237

You can try different fba versions.
See if one works better than the other.

Also you can try to update the pifba package from retropie setup script.


#1238

Hi All,

I updated the emulator and used a different set of roms (however all the previous I tried were processed by crlmame and the right dat file). I am pretty sure most of the roms I tested went from different sources so I was wondering if the limits are inside the Pi2 and my OSMC setup.

I will try with other roms if I find something already tested for a Pi and for the latest release of FBA, thanks!


#1239

So where is this option to uninstall described in the instructions?


#1240

Please give me a link to the instructions you are reading.


#1241

First post on this thread. Says to use the script to uninstall, but the script does not seem to contain an option to uninstall. I see however that if I first select install, and then let it work for a while, a new menu will appear with an option to then uninstall. Maybe this is what the instructions in the first post of this thread is referring to.


#1242

This is just for users upgrading from a VERY old version.
If you want to update and you don’t have the uninstall option in the menu, just run the installation again.

To remove RetroPie, you can use the option in the menu you described.


#1243

I was coming from a very old version. But it seems part of my problem was an sd-card that suddenly went read-only and a bit corrupt (no pun intended). Complete reinstall under way.


#1244

This makes me sad. After clean reinstall, retropie does not work. The menu item does not appear after installing it from the script, and the manually added shortcut to start it just gives me a black screen, and then goes back to osmc. Found out you have to enable the addon in kodi for it to show up. Think I see a retropie or emulationstation splash for a split second when I try to start it, and then it goes black and back to osmc.

I see that more people had their sd cards die(?) doing this. Strange indeed.


#1245

Uhm. I don’t think sdcards die because of retropie…

If you installed to the faulty card again, chances are high that it will not work again.
The card might just be bad.

Is there something of interest in the emulationstation logfile?

Also, try to start emulationstation from commandline after quitting kodi. Should be more verbose.


#1246

Discarded the bad card. Can’t write to it any more. Worked fine before the install and seems broken after. Just a coincidence I suppose. Did an uninstall from retropie-installer and doing a new install now. Looked like emualationstation was not installed properly.


#1247

As said, ditch that card. I think it is faulty.
There was no output when starting es from ssh?


#1248

The install will not finish. Either stops somewhere after starting the installation or now it stopped after selecting install in the first script. Just hangs at random places it seems. Perhaps this card is bad as well. Osmc works fine tho.


#1249

Maybe. Where does it hang exactly? At what screen?
Is your internet connection ok?


#1250

It seems there’s no binary image for emulationstation and it will run out of memory during the compilation for ES. To workaround this, you can do sudo MAKEFLAGS=-j1 ./retropie_setup.sh which will keep it to 1 thread and eventually complete.

I’ve been having to do this for the past couple months…


#1251

I stop mediacenter in the installscript to prevent out of memory during compilation.
That worked until now. Maybe something on your system needs more ram than usual?
Or do you use a pi1?