[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


#1252

I’ve tried shutting down mediacenter but it still runs oom… I do have a few other things on there that perhaps fill up the rest of the ram. Using a pi3. EDIT: Oh I see that you explicitly shutdown mediacenter in the script… I also have nzbdrone running and a VPN server, so perhaps this pushes it over the edge.


#1253
sudo touch /enable_swap
sudo reboot


#1254

I’ve had the same problem as @comat0se some time ago: when I tried to install RetrOSMC on a system with couple of non-standard options (LAMP, VNC server, VPN Server) it ran out of memory. When I wiped the card, installed OSMC and then the RetrOSMC - it went ok.


#1255

Probably I (we) should mount some swapfile before compilation just to be safe.


#1256

yea I can confirm simply enabling swap will make the script complete…


#1257

Hey lads, I’ve spent countless times re formatting my micro sd card and I still can’t get the binary install option when I click install. It just goes straight into the install which takes a fair while - it doesn’t give me the option to choose the type of installation though!

Nothing shows up and I’m completely stumped on what to do.


#1258

It should be “Basic installation” now.
If the RetroPie Setup menu never shows up, there could be a connectionproblem to github.
Can you ping the git repository of retropie via https?


#1259

Thanks for all input. Finally have some free time and a couple of new sdcards, so will have another go at this now. I think the oom-issue was what was happening to me earlier, but I did notice the screen said shutting down media center, before the installer got going. Didn’t seem to help though.


#1260

Shut down other stuff running in the background or use a swapfile.


#1261

Worked fine this time, just using the install-script as is.


#1262

Actually the problem was with the roms.


#1263

Havent gotten around to actually playing anything before now. And a new problem shows up. Controller only works in emulationstation menu. Dead in games. Did not happen on my earlier working install.


#1264

What emulators? What controller?


#1265

Default ones for nes snes gba genesis 32x etc. Wireless 360 controller. Fixed it though. Had to do the bindings in the retroarch gui menu. Pretty sure I only had to configure the controller in emulation station before. The one that autolaunches on first startup. Or am I only dreaming this? Getting old, so could be.


#1266

It should be this way, but not sure if this works for all gamepads.

Edit: worked for my generic usb gamepads.


#1267

Hi.
Please, could you give me a hand?
i install retropie trough the script install-retrosmc.sh and all it’s working except that i cant start emulstation (or retropie) trough the addon, because, dosent appear… i search the add on in programs addon and nothing (of course i install the addon…). Im starting retropie trough a ssh console… but, i prefer a addon.
Can you give me a hand?
(i dont speak english)
Thanks


#1268

As posted numerous times now:
You have to activate the addon in the addon settings in kodi after installing it.
Kodi deactivates addons from unknown sources by default since version 17.


#1269

When I select splash screens in retropie menu, the screen goes black for a few seconds and then just returns to retropie menu. Any other way to set splash screen?


#1270

A splash screen will not work of course.
OSMC doesn’t use the programs to display a splash screen on boot.


#1271

I thought you could replace the emulation station white splash with something else. No? I have it disabled now in es_settings.cfg, so I just get a couple of seconds of black screen, but it’s not possible to replace it?