[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


As far as I know the splash screen is coded in. Anyway. This would be the wrong place to ask this. Did you try on the retropie forums or just google?


Have been googling but can only find decriptions of how to change it thru the menu which does not work in retrosmc. Was hoping it was just a file, and perhaps a path set in a config file or something. Asking here since the response time is record low, and already have a registered user :slight_smile: Thanks for feedback.


I have been trying to install, but the script gets to where it starts building objects for emulationstation and always stops at “GuiMenu”. I have tried doing a clean install of both OSMC and Retro, but it just always stops running. I have left it there for hours and it doesn’t make progress. I have plenty of memory on my card. After I force quit and try to run through the addon I just get a black screen and it goes back to OSMC.


What system are you on? On a Pi1 this could take a while and you could run out of memory without swap. But it should not just hang, instead it should quit with an error. So unfortunately I have no clue what the problem could be.


How do I mount a usb stick please and add roms, tried following the help but struggling.


I’m on a raspberry pi 3.


You cannot zransfer roms like in retropie itself unfortunately. You have to copy them from an usbstick to the /home/osmc/RetroPie/roms/systemname
Best way to do that would be via ssh. A plugged in usb stick should be mounted automatically in /media


so is there no way to mount a usb drive with the roms on?


It is automounted to /media when inserted.


Have added Roms to it but retropie doesn’t see them.


More info!
How should anyone figure out anything from this sentence…

What roms? What emulator? Where exactly did you put them? What format are they in? Did they work before on a retropie install? What error do you get when trying to launch them?
They do not show up in emulationstation at all?


Added a folder called retropie on the usb stick but it doesn’t create the emulation folder inside.


Do you even read what I post?
This does not work on osmc.

You have to manually copy the roms to the roms folder in your home directory.


So my home directory cannot be usb stick?


You could create a symbolic link from /home/osmc/RetroPie/roms


Fantastic thank you so much!


No. It cannot and also would not be on a retropie install as it copies the roms to the home folder in the background.

As fzinken said, you could solve this with a symbolic link. But be sure to copy the original folder to the usb stick completely first. Then add roms.


I have the same issue as Joshua on a raspberry 3 with a fresh osmc install.
It stops at “Building CXX object es-app/CMakeFiles/emulationstation.dir/src/guis/GuiMenu.cpp.o”.
RAM is almost full at 703MB and i got high load above 5 but low cpu useage.


it seems, indeed, that it ran out of memory. i was able to install after i set “gpu_mem_1024=64” in /boot/config.txt


You could also add sone swap before installation.

Edit: Don’t forget so set back the memsplit to the appropriate value after installation.