[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


I am unable to install retropie. error below:

I cant seem to get past emulationstation as it’s the only thing that isn’t installed.

I followed the simple guide here:

unsure what to do any help would be appreciated!


If you read a few posts back, you see that emulationstation needs to be built while installing retropie.
It could be that you run out of memory or something.
Try to install it from retropie-setup.sh script and report if there are any errors while building.


I am having trouble figuring out how to load ROMs onto Retrosmc. I managed to get Retrosmc itself installed after some difficulty (had memory issues while installing but figured out a fix thanks to this thread) but now can’t get the games where they need to be. I saw a post advising this:

“Copy roms to /home/osmc/RetroPie/roms/systemname/ to make the emulatormenues appear.”

But being new to this game, I don’t actually know how to copy files from my desktop to this directory. Does anyone have any step-by-step advice for accomplishing this? Thanks so much. I should mention I am using a terminal in mac to SSH my way around the osmc.


Here is some help if you are new to the linux command line:


Use cp to copy files to their destination:

cp /media/yourusbstick/yourfile.yourextension /home/osmc/RetroPie/roms/yoursystemname/

Edit: You can also use scp if you are connected via ssh.


It seems a lot of people are still running out of memory during the emulationstation compile. While the swapfile worked for me initially, it no longer works.

Using this still works:
sudo MAKEFLAGS=-j1 ./retropie_setup.sh


Yes, that should work. But compilation will take a lot longer pn pi2/3.


I’m having the same issue on a Pi3.
Already tried shutting down the media center service before instaliing but no luck.
What else can I try?


after killing many services before installation I was getting stuck at 86%.
Tried also messing around with the boot/config.txt, and got stuck at 93%
Finally after adding 1 GB swap file I got it through the EmulationStation Compilation.


You just need to enable the official OSMC swap file.


You should detect if our swap file is active and if not, print a warning about enabling it and then suggest a reboot.



How do you enable it, been hunting on google and can’t find anything on it


Search this thread for swap, and you’ll find it.


You are right. The script should handle that but as you might have noticed, I virtually have no time for computerstuff atm :frowning:

Will have a look at this when time permits…


Can you just link the post number or something to help us to find the solution because with saying that you’re not helping


Well a quick search showed me this which I assume is the official way


thanks it’s not so hard to help people with a simple quote and not reply like ooZee


Not hard but still a bit unnecessary for something you could have done yourself


I know @fzinken already replied, but I don’t want to look like somebody who’s “not helping”:
reply number 1253



i agree that but the onZee’s post is unnecessary. He wasted time for saying that and could have given the post number directly


Whose time did I waste? Yours, by pointing You to the solution? Or mine?


you waste more mine than yours that’s sure.

After all thanks fzinken and ooZee my installation is not freezing anymore


@juanpedro learn to search cant expect answers to be handed out to you, your not entitled to anything.

Its opensource.

Think @ooZee acted apporiate as a former moderator myself.