[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


Sorry for trying to help. I think the discussion should end here.


OK, I’m trying to install Retrosmc on my Pi3, but I’m getting problems compiling emulationstation.

From the outset, I was getting this error:
Could not successfully build emulationstation - EmulationStation - Frontend used by RetroPie for launching emulators (/home/osmc/RetroPie-Setup/tmp/build/emulationstation/emulationstation not found).

I was getting this at around the 14% mark, and googling suggested I was running out of RAM. I use pi-hole on the same box, so I changed the /boot/config.txt so the GPU only got 32MB, rebooted, then I ran:sudo systemctl stop mediacenter and sudo service dnsmasq stop and got about 766MB free memory according to free -m.

Emulationstation compiling is now getting to 83% before giving me similar errors.

I’ve pasted my log into Pastebin, in case someone who knows what they’re doing can provide ideas on how to fix this.

Everything else seems to be installed (using the retrosmc script, I can see all the other packages listed as “installed”), it’s just emulationstation that won’t install.

Is there a way to install it from binaries, just using apt-get or something?


You cannot install es from binaries as osmc userland is incompatible with raspbian in some cases.
Use a swapfile while installing.
Instructions are some posts back in this thread.


Sorry, you’re right. For some reason I didn’t see the many answers, probably due to the way discourse renders the posts bit by bit (this thread has over 1300 posts).

For anyone else, before you run the installer, run:


I’ve got trouble compiling emulationstation :
[100%] Building CXX object es-app/CMakeFiles/emulationstation.dir/src/views/ViewController.cpp.o c++: internal compiler error: Killed (program cc1plus) Please submit a full bug report, with preprocessed source if appropriate. See <file:///usr/share/doc/gcc-4.9/README.Bugs> for instructions. es-app/CMakeFiles/emulationstation.dir/build.make:905: recipe for target 'es-app/CMakeFiles/emulationstation.dir/src/views/ViewController.cpp.o' failed make[2]: *** [es-app/CMakeFiles/emulationstation.dir/src/views/ViewController.cpp.o] Error 4 make[2]: *** Waiting for unfinished jobs.... CMakeFiles/Makefile2:246: recipe for target 'es-app/CMakeFiles/emulationstation.dir/all' failed make[1]: *** [es-app/CMakeFiles/emulationstation.dir/all] Error 2 Makefile:137: recipe for target 'all' failed make: *** [all] Error 2 Removing additional swap /home/osmc/RetroPie-Setup Could not successfully build emulationstation - EmulationStation - Frontend used by RetroPie for launching emulators (/home/osmc/RetroPie-Setup/tmp/build/emulationstation/emulationstation not found).

I’ve added swap as mentionned previously and stop kodi


Are you building on a pi 1?
Are you really sure you stopped kodi and other applications running in the background and activated swap?


Not enough memory


finally it works don’t know what went wrong firt time, thanks for the answers


Got the same issue … added swap and stopped the service mediacenter.
Totally out of memory atm :cry:


Managed to get around the issue by killing cc1plus process and let him finish.
After that I build only ES from source, that worked :slight_smile:


Sorry if it has been answered but I cannot find the retropie launcher in program addons in kodi after I have installed retosmc and the launcher addon. I can run emulationstation so I know everything installed. From the installer, I selected Install Launcher Addon. It completes this task (“Addon installed”). I have rebooted each time I changed the skin but still no shortcut in kodi. I have tried with Amber and Confluence with no luck.

In my /RetroPie/scripts folder, I see are retropie.sh, retropie_watchdog.sh, retrosmc-config.cfg. I don’t see a video.sh file.

Thanks in advance for your help.


Addons are now disabled by default. You need to go to Settings to enable the addon.


Thanks, that worked.

Now I need to go back and figure out how to exit from ES back to Kodi.


Just quit es and kodi will load back up automatically.


Long time no post. After fiddling around with some (S)NES games and Retrosmc beautifully working with a wireless Xbox 360 controller, I decided to try some PSX and N64 games from teenage days. Now I’m out of space on the 8 GB SD card. Easy: just use the 6 TB HDD that’s connected to the Pi2 via SATA-USB adaptor to store all roms.
In this post mcobit describes how to create a symbolic link in ~/RetroPie that points to a folder on a HDD. Because it’s been quite a while since this was posted, I just wanted to make sure the method is still valid. Just these four commands and that’s it?
Anything else to consider when Retrosmc has been in use for quite some time, written this, configured that? Maybe a fresh start and install everything onto the HDD? Rerun the setup script?

Not Retrosmc-related, rather RetroPie-related: Does anyone know how to switch between PSX BIOSes conveniently? Turns out you can’t just have three BIOSes (European, a Japanese, North-American) lying around in the BIOS folder and the emulator choosing which one to use for a certain rom. Mix of roms from Germany/Europe and North America for nostalgia or censorship reasons.



I can’t see why it wouldn’t still be working, and if for some strange reason it doesn’t work; you can revert by reversing the instructions. But I don’t think you will have any issues.

Thanks Tom.


Thanks for the reply, Tom! I went with the safe solution and did a backup of the complete SD card before trying, but it wasn’t even necessary.
Long story short: It works! :slight_smile:

The commands from mcobit’s linked post above contained the unlinking of a symbolic link that was present in earlier installations of Retrosmc. Current builds don’t use it anymore. So it’s just

ln -s /media/yourHDDlabel/roms /home/osmc/RetroPie/roms

As for the BIOSes: My bad. I supposed one needed BIOSes from different regions to play European, North-American and Japanese games, but it’s not even necessary. The SCPH1001.BIN is fine.

Happy gaming, everyone! I’m already exicted about Kodi 18 and its inclusion of RetroPlayer. :slight_smile:


I have a question about the current mame emulator… how it’s works on a Pi2 ? I read some info about libretro/mame2016 (based on romset 0.179… i have a most recent but i thinks it’s work also) and it’s said need much hardware capable. This someone can post some feedback ?

Another question it’s… i have a homemade ARCADE JOYSTICK whit 10 buttons… you thinks i can use it (i use it on windows whitout any problems… it’s a usb generic joystick) ?


The arcade stick should work if it is a generic usb hid device.

Newer MAME versions need much more power to emulate games fluently.
On newest MAME you might only be able to play very basic games.
MAME 0.106 was the last version that had the old video core that is very performant on arm devices (advmame 0.106).
You can use newer builds but they will be a lot slower.


How do I uninstall this?

The launcher doesn’t show up, and I lost my ability to get to the console.