[HowTo] RetroPie and OSMC: Retrosmc - Retrogaming on OSMC


#1354

Google is your friend: https://pi-diaries.blogspot.de/2016/05/retrosmc-with-attract-mode.html?m=1


#1355

Hi @mcobit

Seeing as i don’t use retrosmc much anymore i would like to free up some space by completely unistalling it, and wait instead for retroplayer in Leia.

Would it affect the system by unistalling or it better to just keep it installed. Getting error launching in latest stretch update anyways.

I am on an old version as i havent updated it in few years.

Thanks for any info


#1356

Same here. Does anyone know how far Leia is from reaching OSMC? If it’s a couple of months, I’ll try reinstalling.


#1357

Also there is someone on github who found a solution with the older libs from jessie.
I will see if I can patch it up when I have access to a pi again.


#1358

Found and tried it. It works! :smiley: Shoutout to danyeaw’s workaround on GitHub

wget http://ftp.us.debian.org/debian/pool/main/i/icu/libicu52_52.1-8+deb8u6_armhf.deb http://ftp.us.debian.org/debian/pool/main/b/boost1.55/libboost-thread1.55.0_1.55.0+dfsg-3_armhf.deb http://ftp.us.debian.org/debian/pool/main/b/boost1.55/libboost-chrono1.55.0_1.55.0+dfsg-3_armhf.deb http://ftp.us.debian.org/debian/pool/main/b/boost1.55/libboost-locale1.55.0_1.55.0+dfsg-3_armhf.deb http://ftp.us.debian.org/debian/pool/main/b/boost1.55/libboost-system1.55.0_1.55.0+dfsg-3_armhf.deb
sudo dpkg -i lib*armhf.deb
cd /usr/lib/arm-linux-gnueabihf
sudo ln -s libboost_date_time.so.1.62.0 libboost_date_time.so.1.55.0

#1359

Hey guys, I recently got Retrosmc setup on my pie. However, my TV is a constant pain. OSMC has the option to manually adjust the image so I am basically using a custom resolution that fixes my old crap TVs annoying overscan which for some reason does not seem to be able to turn of anywhere in the TV settings…

Anyway, the correction does ofc not carry over into emulation station or any of the games for that matter. Anyone know how I can fix this? the /boot/config.cfg affects the booting OS OSMC right? Or does it? Anyway this is mine:

gpu_mem_1024=256
hdmi_ignore_cec_init=1
disable_overscan=1
start_x=1
disable_splash=1
gpu_mem_256=128
sdtv_aspect=1
gpu_mem_512=256
dtparam=audio=on
#overscan_scale=1

I honestly don’t know what overscan_scale did so I commented it out… Did not change anything I think… Also looked in opt/retropie/emulators/mame4all/mame.cfg but changing stuff there did not seem to help, neither did changing in opt/retropie/emulators/retroarch/retroarch.cfg… Any ideas?


#1360

@exobuzz
As the move to debian stretch broke RetroPie as libs are missing, would it be ok to have an exception in the installer script, that detects osmc and lets it run it anyway? There is a workaround we can implement in the retrosmc script that will make it start again.

Edit: Is there some timeframe for stretch support for Retropie already? In this case ot might be easier to just wait for now.


#1361

@RJ45 I did the same, and it’s not working, I get the error message:
/opt/retropie/supplementary/emulationstation/emulationstation: error while loadi ng shared libraries: libboost_filesystem.so.1.55.0: cannot open shared object fi le: No such file or directory
@mcobit Is there a way to fix, an existing repropie installation?


#1362

@NRgia Did you install it step by step like described in the first post in this thread?

Did you get this the error

error while loading shared libraries: libboost_date_time.so.1.55.0

when launching RetrOSMC after OSMC’s Januar update to Debian Stretch?

Did you complete the workaround using the four commands I listed in the post above?

IIRC you can try running the setup again.


#1363

Hi, I’m getting the same error as @NRgia it was a working retropie installation until the update. I was getting libboost_date_time.so.1.55.0 but the worked around seems to have fixed that one.

Any clues?


#1364

@RJ45 It was working before Debian Stretch update. I did exactly as you instructed, if I run the setup again it will say (I don’t want to uninstall):

fatal: destination path ‘RetroPie-Setup’ already exists and is not an empty dire ctory.
Sorry - Raspbian/Debian Stretch (and newer) is not yet supported on the RPI

Distributor ID: Debian
Description: Debian GNU/Linux 9.3 (stretch)
Release: 9.3
Codename: stretch

The returned error I receive before and after I apply the fix is the same:
error while loadi ng shared libraries: libboost_filesystem.so.1.55.0: cannot open shared object fi le: No such file or directory

I did not saw other errors


#1365

Hi,

I would check the symlink is correct:

cd /usr/lib/arm-linux-gnueabihf

and provide the output of:

readlink libboost_date_time.so.1.55.0

Thanks Tom.


#1366

I think that it is correct

osmc:/usr/lib/arm-linux-gnueabihf$ readlink libboost_date_time.so.1.55.0
libboost_date_time.so.1.62.0

thanks


#1367

Hi,

Sorry misread the earlier posts, try:

wget ftp://ftp.us.debian.org/debian/pool/main/b/boost1.55/libboost-filesystem1.55.0_1.55.0+dfsg-3_armhf.deb

sudo dpkg -i libboost-filesystem1.55.0_1.55.0+dfsg-3_armhf.deb

And try retropie again.

@NRgia This may help you aswell.

Thanks Tom.


#1368

Installed the package and everything is working now.

Thank you so much for your help.

That’s why open source rocks


#1369

I have had to recently rebuild my Pi as it went belly up. I am trying to run the Retrosmc script with the latest OSMC build but getting the error:

“fatal: destination path ‘RetroPie-Setup’ already exists and is not an empty dire ctory.
Sorry - Raspbian/Debian Stretch (and newer) is not yet supported on the RPI”

I have tried to run “sudo dpkg -i libboost-filesystem1.55.0_1.55.0+dfsg-3_armhf.deb” after downloading the package but getting the following error:

osmc@OSMC:~$ sudo dpkg -i libboost-filesystem1.55.0_1.55.0+dfsg-3_armhf.deb
(Reading database … 29820 files and directories currently installed.)
Preparing to unpack libboost-filesystem1.55.0_1.55.0+dfsg-3_armhf.deb …
Unpacking libboost-filesystem1.55.0:armhf (1.55.0+dfsg-3) over (1.55.0+dfsg-3) …
dpkg: dependency problems prevent configuration of libboost-filesystem1.55.0:armhf:
libboost-filesystem1.55.0:armhf depends on libboost-system1.55.0; however:
Package libboost-system1.55.0 is not installed.

dpkg: error processing package libboost-filesystem1.55.0:armhf (–install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libboost-filesystem1.55.0:armhf

Can anyone help please? Will this only work if I install on an older version of OSMC first then run the above after I update?


#1370

Hi,

libboost-system1.55.0 is provided with the fix posted by rj45:

Thanks Tom


#1371

@Tom_Doyle Thank you for the support, that fixed the issue.


#1372

Just tried a fresh install on my new RPi3 with the January image of OSMC (2017.12-1) – no luck. :confused:

Sorry - Raspbian/Debian Stretch (and newer) is not yet supported on the RPI

Looks like you have to install one of the OSMC versions before the Stretch update, then install RetroPie, then patch OSMC, and then finally apply the workaround from above. I’ll give it another try tomorrow.


#1373

Just do like Claudio suggested, it works :slight_smile: