Is advancedsettings.xml supported in Alpha 2?


I just moved from Raspbmc to OSMC Alpha 2. Very happy with it and can’t wait to get the OSMC skin.

I’m wondering if advancedsettings.xml is already supported at such early stage? I’ve some TV Show episodes with odd season and episode naming, therefore I created on Raspbmc some Regexp which worked fine.

On OSMC I copied from Raspbmc the advancedsettings.xml file to ~/.kodi/userdata and updated my library but the episodes with odd naming don’t show up.

Now I’m just wondering if I should start renaming all files or to be patient and wait until it’s supported by OSMC.

Many thanks in advance!

Advancedsettings.xml is a Kodi-feature, so it shouldn’t matter if OSMC is still in an early stage.
Maybe try deleting your library and start over?

Seems to me there is no standard advancedsettings.xml file in /home/osmc/.kodi/userdata

It is not there by default. You must create it.

You’re right,I always thought it was exist by default,created one of my own now and upload file using FTP client

<advancedsettings> <video> <subsdelayrange>120</subsdelayrange> </video> </advancedsettings>

Thanks for the swift replies. I’ll recreate my entire library overnight and see if it helps.

advancedsettings is in the system directory not /home so that the user can’t lose our sane defaults if they deleted the kodi directory

Hey Sam! I’ve added below (which worked with raspbmc) to /usr/share/kodi/system/advancedsettings.xml and rebooted and updated library but the episodes won’t show up. Is the path to advancedsettings.xml correct?

<tvshowmatching action="prepend">
        <regexp>Season [0-9]+/([0-9]+)-([0-9]+)</regexp>

There should be an advancedsettings there already

I’d recommend editing in your /home/osmc/.kodi/userdata directory so as not to overwrite system defaults


Well, I seem to be a bit lost here.

I have just received my Raspberry PI 2 and is using OSMC for the first time. I have switched the skin so it looks like the Kodi I know and calibrated to screen, but thats about it.

I then want to start getting it to work with my setup, where I’m using a shared database. I have copyed the advancedsettings.xml (and passwords.xml) to /home/osmc/.kodi/userdata, and restarted OSMC (looks like Kodi, but expect it to be OSMC with another skin), but nothing changed - no files, movies, videos etc. from my shared setup.

I then wanted to try to copy the xml files to /usr/share/kodi/userdata, but I have no permission to write to this location. I used the user ‘osmc’ and have tried both with FTP and SFTP.

Could someone please help me getting my setup working on my Raspberry PI 2, so this also uses the shared database and files.

Well, I’m back again. I still can’t get my setup to work as intended.

First of all, it’s very hard for me, to get OSMC to boot up with the advancedsettings fil. I sometimes have to reboot like 6-8 times, before it picks it up.

Further I have a shared sources.xml file, so I can browse the files from all my units. Therefor I have added the following in my advancedsettings fil:


It works on all my other units, but in OSMC I don’t have any folders when I look under ‘Files’ (both under Videos and Music).

How come I have these issues, and what can I do to solve them?

(By the way, I’m running OSMC 0.0.4 (Kernel: Linux 3.18.5-v7+))

Thank you for your reply msieminski. I have tried your suggestion with making the mount, but it didn’t make any difference.
But thanks for trying and other good suggestions are welcome.

And sorry for replying this way. Because I am new, I can only make 3 posts in a threat and a deletion of a post is not completed until 24 hours later. So hope you see my reply.

make sure that this file is available to osmc using mount in shell:

sudo mount.cifs // /mnt -o user=USER,pass=PASSWORD
ls -la /mnt/sources.xml

Once again, thanks for the reply msieminski.

I wrote the result of trying this, in my previous post. This is because I’m limited to only 3 post in each thread at the moment, cause I’m new in this forum.
Now I have deleted another post to make this reply

But in short it didn’t solve anything. But maybe there’s something else I can try.

The status for me is that when starting up OSMC, I have to restart several times (sometimes up to 8 times) before it start’s up with the options in the advancedsettings.xml-file.
Further the sources.xml isn’t loaded, so the sources, which the advancedsettings.xml is based on, aren’t in OSMC. However, I can play the videos which are already in the movies/tv-shows database.

Really hope to get this up running, so I can play movies not added into the database and also be able to add new movies/tv-shows to the database from OSMC.

I fixed that for you, don’t take advantage of it :slight_smile: Sounds like a timing problem where Kodi is launched before the network is up, closing (Exit) Kodi should cause it to relaunch with network access. Soon, hopefully in the upcoming version, there will be an option to wait for network which will fix your problem

1 Like

Thanks for the fix. For sure won’t take advantage of it. Just very happy to get this support.
I have now tried to exit OSMC so it restarts and now the sources are there! So it definitely seems like your right about this startup before the network connection. Maybe this is also why it seems like it’s not starting up with the advancedsettings. I suspect that my issue with the advancedsettings-file is that it is actually loaded, but doesn’t have access to the SQL database yet and therefor don’t show any movies or tv-shows in the library when I start up.
But I will try to test this a bit more.

But thanks ALOT for the help. Really appreciate it.

Thanks for your great tip, this answer should be in the FAQ till the issue is fixed.

Wait for network has been available in the networking GUI for some time now, if that’s what you’re referring to.

You’re replying to a two month old post - a lot has changed since then…

I don’t understand this at all. Is it possible to add the xml or no? Does they’re need to be write privileges? Thanks

This topic is now closed. New replies are no longer allowed.
That xml has been working in every version I’ve tried, and you shouldn’t be using alpha 2