Issues Playing back high bit rate 4k video

I have this issue with playing back certain 4k videos.
One example is footage form my GoPro hero sessions 5. This is an .mp4 H.264 2160p25 video with aac 2.0 audio an the bitrate does get as high as 70-80mbps. When using a wired connection it freezes on the first frame and gets stuck on buffering but does not actually download any cache of the video most of the time and so playback is not possible.

I have just tried via WiFi connected to a BT whole home WiF AP which in turn is wired in with a gigabit connection. The Vero 4k connects at 433Mbps on 5ghz band. When on WiFi despite the higher throughput I get pretty much the same result except if I pause the video it does download the cache and then after a min you can playback the video.

I get the same results when trying to playback my Sony 4k camcorder flies which are .mp4 2160p25 @100mbps

All this is via SMB shares off my windows server. (I did try to setup NFS on the server but I can’t connect to the shares)

My question is would buying a Vero 4k + with its gigabit nic solve the issue? Or is there sometime elese going on.

I can playback these files via the network without buffering /issue on the Kodi app for Windows 10 (hard wired in gigabit)
Many thanks in advanced

There was a fix for GoPro playback here: VideoPlayer: various fixes by FernetMenta · Pull Request #13095 · xbmc/xbmc · GitHub
This is master branch (i.e. Kodi 18/Leia only) - Not in Krypton.

You can try a testing build [TESTING] Kodi 18 (Leia) builds for Vero 2 & 4K

Meant to say local playback from the Vero 4k’s internal storage works fine without buffering.

Hi,

Are you using fstab mounted SMB shares or kodi soft mounts, also logs would be helpful:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks Tom.

I think that the GoPro issues are not bandwidth related. I considered backporting them to Kodi v17, but as Kodi v18 is not far off, it doesn’t make a lot of sense to do this.

If the issue isn’t fixed with Kodi v18, then yes, it likely is a bandwidth limitation. Gigiabit Ethernet would fix this; but Ii also suspect how you’ve mounted your shares will make a difference too

Sam

Thanks for all your replys.
Yes you are proberly right about the Go Pro videos being a separate issue.
I was using SMB mounts via the UI and have just setup a fstab SMB mount but I get the exact same issues.
With regards to the 100mbps 4k file from my camcorder I’m not sure if this is a bandwidth issue network wise as even over WiFi at full speed it buffers and does not play properly. I also have similar issues with a 4k HDR file (LG Demo Chess) which does not peak over 60mbps.

I have uploaded the full logs http://paste.osmc.io/hucodecuvu.xml albeit with my password removed.

I started with C0001.mp4 which is the 100mbps 4k file from my Sony Camcorder.
Then GOPRO0096.MP4 the go pro video.
Lastly LG_chess_HDR.mp4 h.265 encoded. This does play after a few seconds but then has an error about the read rate being too slow.
All played though fstab SMB mount.
Let me know if you need any more. I’m just conscious of if I need to get a 4k+ to fix these issues (except the go pro issue) before the price rises :slight_smile:

To play a 100Mbps file over the 802.11ac WiFi you will need a very good connection. Is it a constant bitrate?

Sam

Hi Sam yes the file from the 4k camcorder is a constant bitrate of 100mbps. It is a Sony FDR-AX33 camcorder.

WiFi wise it is proberly the best it’s going to be it is a BT Whole Home AP which is in the same room about 5m away line of sight to the Vero and the connection speed to the Vero is 433Mbps which I believe is the maximum the Vero 4k can support as the AP does support up to 1200mbps and an iPad in the same room connects at 866mbps. The AP is connected by a wired gigabit connection.

I can try sharing the same files from my PC just to rule out the server being an issue etc.

Give that a go. Obviously the 4K + would do this over Wired, if you can run a cable. But we may be able to get this to work on your 4K.

Sam

Check throughput with iperf3

Hi All,
Just done an ipperf3 between the Vero and the server and the average bandwidth bitrate is 132mbps which should just be enough to play a 100mbps file but only just so I can see where the issues arise.

I will do some more iperf3 testing with other devices in case I have more general network issues.

Try to change the channel to see if you get stable higher figures.

Hi fzinken good point i could try that. In the meantime i have done the following tests:
AC WiFi running at 433mbps connection rate on PC iperf3 to server average bit-rate: 281 mbits/sec
AC WiFi running at 866mbps connection rate on PC iperf3 to server average bit-rate: 436 mbits/sec
Gigabit Wired Lan on PC iperf3 to server average bit-rate: 943 mbits/sec

Copying the camcorder video file from the 4k share to my pc over gigabit lan 896 mbits/sec

This proves that the majority * of the network performance is good and the read/write speeds of the HDD the file resides on.

  • the wifi test i just did was from upstairs connected to a different AP so will now bring the Vero 4k to this room for a fair test.

Ok so with the Vero 4k in the same location as the PC WiFi Usb adaptor (now disconnected) with no other devices connected to this AP i see the follwing:
iperf3 results now slightly higher averaging around 224 mbits/sec.
Despite this the 100mbps 4k video still buffers and even after pausing it plays for a few seconds and then buffers again.
If i play the same files via the Windows 10 Kodi App on the PC over the WiFi with the simular thoughput to the Vero 4K the files play though fine without buffering.

Sam - Have you tested playback of 100mbps ~ 4k files via wired gigabit lan on the new Vero 4K + ? I just want to make sure that if i bought a Vero 4K + it would resolve the issue i can run a network cable to the Vero no problem.
If needed i can provide a sample file from my camcorder for testing?
Many thanks.

FYI here is the media info of the Sony 4k camcorder video:
General
Complete name : \nsm-server\4K\Camcorder\CLIP\C0001.MP4
Format : XAVC
Codec ID : XAVC
File size : 1.09 GiB
Duration : 1mn 34s
Overall bit rate mode : Variable
Overall bit rate : 99.4 Mbps
Encoded date : UTC 2018-07-21 14:54:54
Tagged date : UTC 2018-07-21 14:54:54

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L5.1
Format settings, CABAC : Yes
Format settings, ReFrames : 2 frames
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 1mn 34s
Bit rate mode : Variable
Bit rate : 97.7 Mbps
Maximum bit rate : 100.0 Mbps
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 25.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.471
Stream size : 1.08 GiB (98%)
Encoded date : UTC 2018-07-21 14:54:54
Tagged date : UTC 2018-07-21 14:54:54
Color range : Limited
Color primaries : BT.709
Transfer characteristics : IEC 61966-2-4
Matrix coefficients : BT.709

Audio
ID : 2
Format : PCM
Format settings, Endianness : Big
Format settings, Sign : Signed
Codec ID : twos
Duration : 1mn 34s
Bit rate mode : Constant
Bit rate : 1 536 Kbps
Channel(s) : 2 channels
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Stream size : 17.3 MiB (2%)
Encoded date : UTC 2018-07-21 14:54:54
Tagged date : UTC 2018-07-21 14:54:54

Other
Type : meta
Duration : 1mn 34s

it is actually a variable bit rate but does max out at 100 mbps.

Sure — feel free to provide a sample and I can check this for you. I can play up to 600Mbps material (which is not practical) on the new device before hitting bottlenecks with RAM speed.

The problem with WiFi is iperf can look healthy overall but very small drops will cause problems. A copy and paste of the complete test might show us if this is happening

Sam

Thanks Sam I don’t have the full reports anymore sorry but the speed during the test never dropped much below the average maybe ~15mbps difference.

Do you have a place I can upload the file it is 1.09GB in size?

Our limit is currently 512MB if you have something comparative that is causing problems for you.

I am looking at expanding this in the future

Sam

Hi Sam yes I have a clip that is 386MB how do i go about uploading it ? i did try via the upload on this post but it does not accept the format and im guessing that is for pictures only.

You can upload it here: https://collab.osmc.tv/s/ZLN6PWnbGo5kMFT.

Sam