Jerky playback and no sound on some videos

So, received my Vero 2 yesterday. And like others said, great performance (coming from Pi1)
Though there is a couple of strange issues for me.

  1. There seems to be a lot of buffering, and quite a bit choppy playback when skipping through video (h264, 1080p). I didn’t have that at all on the Pi.

  2. Some videos don’t play the sound at all. Seems to be AC-3 only. Though not all.

I’m streaming from a Synology NAS via NFS. There’s not so much of an issue when playing from a USB drive.
The videos with no sound are the same though.

My logs

The issue is only with playback as the UI in general is mindblowingly fast and way beyond what I’m used to.

Update: So, I tried running the ‘no-audio’ files on my Pi1, also with february update, so should be the same version as Vero 2, and there’s is no issue whatsoever.
Also the buffering issue that’s on the Vero 2, is nonexistent on the Pi1 (using the same cable btw).
That means the problem must be somewhere in the Vero hardware, right?

Could someone please respond to this?

In the hope of a reply soon from the team, I can only continue to report what I find.

After more testing, I can conclude that as far as I know all of my h264.mkv videos are audio/video out of sync after skipping at least once through them. It’s only slightly, but definitely noticeable. Again, no such problems on the Pi.

An update was released in the early hours this morning, can you update and then retest to see if you still have any of these problems ?

I have moved your thread into the Vero 2 section where it should be so that it doesn’t get lost amongst non-Vero 2 posts.

@DBMandrake Thanks for your reply.
I have installed the latest update, and the good news is that the buffering now seems to be gone.

Bad news is, that the no-audio problems persists. And that skipping through some videos, makes the video stop entirely, and return to title screen.

Also the audio/video sync is still off. Though I think I fixed it by delaying the audio by 200 ms.
When pausing and again unpausing the audio starts playing a little later, and not because of the delayed offset.

Skipping through videos (10 minutes or more) sometimes causes massive sync issues, like 5-10 seconds out of sync. This be helped by pausing, and looks like it’s making the video ‘catch up’ to audio.

Thanks for moving the topic to the correct section. I thought I placed it right initially though, when I gave it the Vero 2 ‘sticker’?

Fresh logs

Tried this?

Edit: Just realized you are on Vero2, not sure if this will be useful…

No joy. Tried to disable it, reboot, then re-enable, reboot and play. No difference. Thanks for the suggestion anyway.
Maybe the problem is the amcodec???

@TL81, we’re having what might be a similar issue, but in our case I believe I’ve tracked down the lack of audio to the problem with the video playback - it appears as though we’re getting no sound because the “Vero 2” is desperately trying to sync. it with video which is playing back badly (jerkily, even when visually it appears relatively smooth).

For example, I’ve stuck “Frozen 3D” on in the background as a test - currently about 44 minutes in and have only had a few seconds of sound (from the bl**dy ice miners singing at the start … :slightly_smiling:).

Obviously it’s just a guess that your problem might be related, but it may be worth considering …

If you’re interested, my post on our problem is here (consistently interrupted playback) - hopefully it might be of some help, though of course YMMV …

Cheers,

Tris.

@THEM Thank you for your reply.
Our issues do sound similar. But why would there only be problems on video with AC3 sound? And why only on certain videos with AC3, and not others?

@TL81, very good questions, and without more specific details as to either I can’t provide you with a definitive answer.

I can, however, speculate, for what that’s worth:

If I, and possibly you, are losing sound because the “Vero 2” is trying to sync. it, then what would actually trigger it will be the total composite processing path involved in handling a particular video, rather than necessarily specifically the fact that it’s AC3 sound (or any other single pointer).

E.g. …
Take a cartoon. Nice and simple video processing; no high level of detail, large blocks of essentially the same colour (therefore easy to encode) with relatively small changes between frames. That sort of video you could probably decode on just about anything without breaking a sweat. Add an AC3 soundtrack and still, not an issue.
Now take something ridiculously detailed, like a modern digitally filmed and downmixed title. That’s going to be a right beggar to process.
If the problem is because of the sound sync. trying to keep up, that AC3 cartoon will play fine. The modern title won’t. Now downmix the audio on the latter to basic stereo PCM and see what happens - vastly simpler to keep everything in sync. Similarly, the AC3 cartoon would be playing fine because overall it would be relatively straightforward to keep everything in sync.

Maybe …

That is a horrendous oversimplification, as you’re obviously aware, especially when you consider hardware acceleration and everything else that can get involved in the process. However, it’s one which seems broadly to fit both your, and our, issues and, in the absence of any more specific diagnostic detail, is potentially plausible.

Now, even if I am right (and I’d remind you that’s pure speculation), that doesn’t immediately help as I have no solution, just an unproven hypothesis. What I’m hoping is that it might make one of the developers think “OK, just hang on a minute, I wonder whether …?” and therefore possibly points someone in the right direction.

Assuming that is the right direction, that is! :slightly_smiling:

This is a bit of a long shot but we have a newer kernel that changes the way frame rate syncing is done, it is possible that this might help. You can install it as a test by doing the following:

sudo apt-get update
sudo apt-get install vero2-image-3.10.94-28-osmc --reinstall
reboot

After a reboot you can check you’re on the right version with:

cat /proc/version

(It should be -28-osmc. The current released kernel is -27-osmc)

Please let us know if this helps with stutter and no audio. You can revert to the previous version with:

sudo apt-get install vero2-image-3.10.94-27-osmc --reinstall

If this doesn’t help please provide a mediainfo of a file that exhibits the problem.

1 Like

Please see the mediainfo section in How to submit a useful support request - General - OSMC

Thanks for the suggestion. No change though.

Here are a couple of files that have the problem

http://paste.osmc.io/upidiqejoy.md

http://paste.osmc.io/ocilinofed.rib

http://paste.osmc.io/datenowivo.rib

And here are some that don’t

http://paste.osmc.io/iyarulobax.rib

http://paste.osmc.io/efovaduqos.vhdl

http://paste.osmc.io/zitihubeki.vhdl

One of the files that won’t play sound is actually a cartoon/animation. So I don’t know.
Could be like you said, a lot more to the story though.

1 Like

Me neither - it obviously is a little more complicated than that …
Oh well, it was just a theory …
However:

I know that was directed at @TL81, and I don’t want to hijack this thread. However I thought you might find it useful to know that I just tried that test kernel and played part of “Frozen” (3D) - before (GA kernel), basically no sound (and jerky video); after (test kernel), jerky video but with much more sound. I.e., plays for about a second; pauses for about 1/4 second; rinse and repeat but most times when it’s playing we do get sound.
So in our case, it made a … well, let’s just say “difference” :slightly_smiling:

So after today’s update (2016.02-4) things pretty much look the same. I even think buffering has gotten a little worse. Meanwhile things are smooth on the Pi, so I’ll keep on using that for my daily media consumption.

Are you using Kodi’s built in NFS client ? EG in the Video source you have nfs://something ? If so, there has been quite a lot of discussion about this in another thread. There seems to be an issue with libNFS in Kodi, although quite why it seems to be more noticable on the Vero 2 at the moment we’re not sure.

It’s very likely that if you switch to a Kernel NFS mount your buffering problem will be solved. There are various tutorials out there so it’s not too difficult, so here’s a brief explanation of what to do.

First create a directory under /mnt to mount your remote nfs file system. I call mine Mac-Mini:

sudo mkdir /mnt/Mac-Mini

Now add a new entry for it in /etc/fstab. Here is an example to get you started: (leave the existing line in place and add this as a new line, all as one line)

192.168.0.10:/Users/admin/Movies /mnt/Mac-Mini nfs noatime,noauto,x-systemd.automount,nfsvers=3,nolock,nofail,local_lock=all,soft,retrans=2,tcp 0 0

Replace the IP address with the IP address of your NFS server (if it has a static IP) or it’s hostname, and the path immediately after that with your NFS export path. The second path is to the mount point you just created.

Once you have saved that try mounting it, replace the path with the correct one for your system:

sudo mount /mnt/Mac-Mini

(The mount options I gave will also cause it to auto mount on boot)

If you look in that folder you should now see files on your NFS server. You now need to change your video sources. Unless you use path substitution in advancedsettings.xml you will need to remove your existing TV Shows and Movies sources and re-add them. This time instead of choosing NFS browse to “Root Filesystem” then mnt then whatever you called yours instead of Mac-Mini, then to your Movie or TV Shows folder and add the source as before.

Give that a try and see if it helps. While performance of the built in NFS client in Kodi doesn’t seem to be nearly as good as it should be for reasons we haven’t worked out yet, a Kernel NFS mount will always be faster than Kodi’s built in NFS client even if this issue wasn’t there, so if you are trying to squeeze every last drop of streaming performance out you are best to stay with the Kernel mount if it helps for you.

1 Like

Forgive me. But I am not experienced with the commandline at all. How do I add a new entry into the fstab file?

Edit: I tried to do it with Filezilla. But it seems I don’t have the necessary permissions. I can read all files fine, but I don’t have write permission.

The easiest is to login with ssh and then edit the file with sudo nano /etc/fstab, but be careful only to add your entry and not change any other entry.

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Thank you for your advice. It really helps a lot.
As far as I can see, having tested for a couple of minutes, it does indeed seem like the buffering has gone. Will watch a full length movie later, to confirm.
Will this issue be addressed in future updates, so one doesn’t have to make these changes manually?

For me, there are only two problems left, keeping the Vero 2 from being the perfect media center. The failure to play some videos with AC-3 sound, and the (approx. 200 ms) audio/video sync issue.
Still I’m happy it looks like we’re getting there.

It would be good if we could find out more about the file you are having issues playing. Please see the mediainfo section in How to submit a useful support request - General - OSMC