Keyboard layout corresponding to set Region

Hi guys, just got my new Vero, i love it!

Still just discovering all the features and reading a lot in the forum.

I am wondering about my QWERTZ bluetooth keyboard (Rii mini i8+) which is not working correctly with language set to German and region to my country Austria. It still is acting like a US keyboard.

I have found out there is a way using console commands and then it should maybe work. Have to give it a try. Unfortunately I’m not even knowing how to enter console LOL. And there are so many different commands people were suggesting in different threads, none of which was ever marked as SOLUTION…

Is it planned or possible to let OSMC’s set Region/Language actually change the hardware keyboard layout to the matching region? Would be incredibly convenient …

Anyway… Nonetheless a splendid piece of tech!

Yes it is planned but with no ETA yet. Meanwhile, you will have to do some work with the commandline.

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

You will have type the following commands:

sudo apt-get update
sudo apt-get install console-data
sudo loadkeys de-latin1

Your keyboard should now be working correctly.

To load the QWERTZ layout when vero starts you have to put a command into a file called rc.local. Start by typing

sudo nano /etc/rc.local

You will now be editing the file. You should see this on your screen:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.


exit 0

Use the cursor keys to go to the line just above where it says exit 0 and enter this line:

loadkeys de-latin1

Type ctrl-X and then Y to save your changes.

3 Likes

Thanks a lot…

If that worked for you, please mark it as the solution to help others who may have the same issue.

Thanks, had the exact same problem (which is now solved).

Best, M

Hello Guys

I have same love for my VERO 4K :wink: and same problem with my french AZERTY Rii mini i8+.
I precise that my VERO 4K is setting with language set to French and region Switzerland.

So please what’s the correction should I do ?

Thank you a lot

Same problem - same solution!!
Look again at the earlier posts, and follow the remedial action listed there.
If that doesn’t work, then we’ll need as mush detail as you can provide on what you did, and what happened as a result.
Derek

So you confirm that is the same code :“loadkeys de-latin1” for my french AZERTY keyboard ?
Because in Deutchland they have QWERTZ keyboard and not AZERTY

Hi,

I think loadkeys fr will do the required. You can test it it before adding it to rc.local.

sudo loadkeys fr A reboot will clear it if its incorrect.

Thanks Tom.

Ok Tom

I will try.

Thank you for your help

Hi
I try to follow your process but nothing works.
I can read at the end : cannot open file fr-latin9, or file fr1-latin1 or file fr, regarding I tryed to write…

Please help…

I can send you a picture of my screen if you need…

Did you install console-data?

Sorry but i’m really newbie with linux… I did not install nothing…

I just follow instructions from this post.

So go through this thread again and follow @grahamh solution.

Yes
I exactly did that

I make a picture of my screen
Could I send to you ? May it be more simple for you to understand where I am in OSMC and what I did?

Hi,

Please confirm you have completed the following:

sudo apt-get update
sudo apt-get install console-data
sudo loadkeys fr

Thanks Tom.

1 Like

Yes
I confirm
I go to send you picture of my screen