Mouse Input too sensitive

I have changed to the confluence skin to get round this problem, but note that skin changing is virtually impossible unless you use the keyboard arrows rather than the mouse to navigate through the menus.


As EMJB says Confluence works fine with a mouse so this is a problem with the design of the OSMC skin, probably with the algorithm that is used to scroll menus.

However I have since discovered the joys of CEC and found that my Panasonic remote control drives OSMC very effectively with no configuration changes. I have started playing with some key function mapping but already have much more than the mouse gave me. Will try again when a new version of the skin is released.

The more I explore the OSMC/Kodi combination the more I appreciate I have still to discover.

Keep up the great work Teams Kodi & OSMC.

Pretty much the same experience for me but also with a huge mouse cursor seen on the old tube TV I’m using. Maybe Confluence should be the default skin at install?

Other than the above OSMC looks good. Looking forward to future builds.

Oh, ye of so little faith…

1 Like

The skin doesn’t support mouse or touchscreen control. Kodi is a media center not a media player.

In XBMC/Kodi the primary environment was designed for the living room (10-foot interface) and controlling it only with a remote control. While XBMC/Kodi does support mouse, keyboard, and even touch controls, the main method of controlling XBMC/Kodi is designed around is the typical remote.

Hi, I too have a big problem with this. Are you saying that OSMC out of the box will not support a mouse ?

Another user with mouse preference who is affected by this issue in RC version.

Is there some setting to define in config which controls mouse movment sensitivity?


It is a problem that the skinners are aware of, and it will be fixed for the next release.

We understood that this is an issue with skin and it’s great that it will be addressed in the future, but I’m asking what can I do now to make Pi with OSMC usable :smile:

Use another skin.

1 Like

Use a remote or a keyboard? Adapt and overcome…

No mouse support in the OSMC skin.

There are two really simple solutions:

If your TV supports CEC then its remote should just work via the HDMI cable, nothing to configure. You can then have endless fun playing with keymaps.

Alternatively if you have an Android phone or tablet on the same LAN as OSMC then install Yatse which should give you lots of remote control functionality.

Since I switched to using my Panasonic remote I have given up any desire to use a mouse on OSMC generally although I can still see that it could sometimes be useful, particularly for things like on-screen keyboards.


Your suggestions are reasonable except that when trying to instal the RC I could not complete the set up of wifi without a mouse since the keyboard was also not reacting properly. I have yatse on an android but without wifi it becomes a none starter. I also had the problem that although my sony bravia is supposed to support cec - it does not as it’s any early version.

Therefore events dictate that a properly configured mouse and keyboard are essential items. I am sure that this will get fixed eventually.

Use a network cable, set everything up, remove network cable.

That is what I did but the keyboard would not complete the wifi set up (would not click on my ssid) and I needed to use the mouse to point at my ssid before it would complete. To get to the wifi set up I needed to use the keyboard as the mouse was totally uncontrollable. See if you can scroll back on languages in the initial set up. I too had to switch to confluence as soon as I could.

Winning combination there.

Did you try configuring WiFi as a preseed option?


Hi Sam sorry for the delay in reply - been away. Yes I did initially set up the install with the wifi as a preseed option but it was not recognised during the instal. I had to switch to wired to complete the process. Thereafter the wobbly mouse and dodgy keyboard made it difficult to instal the wifi as the keyboard would not complete the password option once the ssid was scanned. Had to mouse onto it to get the password option.

However once past this glitch the RC has been working perfectly with the wifi. I am highly impressed with the product that you and your team are putting together and I am sure that the small failings will get resolved over time.

Keep up the good work.

I’ve just updated one of my Raspbmc install to OSMC having tried to install an earlier version a few months ago and not having much success. I assumed that they were early releases and not properly working. I’ve installed RC3, 3 times to try and get it to work - as I couldn’t seem to get it working and assumed it was a bad install. I then found this thread that says that a mouse is not supported. This needs to be put in the FAQ as I naturally assumed that because it worked well in Raspbmc that it would have at least the same functionality in OSMC. That would have saved me having to try installing 3 times before I searched on here to eventually find that it was a mouse problem - and not an install or display problem which was my initial thoughts that I went searching through the forum for a solution.

The real problem is that with the default OSMC skin, is that you can scroll up with the mouse but not down. This makes it impossible to get to the Settings option on the main menu to change the skin to Confluence as it is just off the bottom of the screen. As you can’t see it and you can’t scroll down to see it, you don’t even realise it is there so you try looking on other screens for Settings!!

So some suggestions:

  • put a note in the FAQ so people are aware of the issue
  • move Settings up on the main menu so someone with just a mouse can at least change the skin to Confluence - or reduce the font so that all the options are on a single screen.

I’ve now started to play and now managed to get my Android remote working, so will start looking around the functionality - performance is impressive!