New Vero V don't boot properly


I just received my new Vero V. I scrupulously followed the instructions in the Quick Start Guide.
At first it seems to boot normally. The OSMC symbol appears, then a black screen and then the blue sad smiley. After that it keep to alternate between a black screen and the sad smiley.
I tried to reinstall OSMC via these instructions :

The installation seemed to work fine, according to the log on the USB, but the Vero still doesn’t run, exactly the same way.
I can access a command line, holding the home and OK buttons of the remote, during the sad smiley-black screen loop, so I could extract logs there :
I have a Vero 4 which works fine on this TV.


Can you try on a different TV to the Grundig as a quick test?
I think I can see the issue


A log from 4K/4K+ so we can see which resolution is being picked there would be useful as well.

1 Like

It works on my pc screen iiyama (resolution 1920*1080)
The resolution of the Grundig is max 1280x720.
With the Vero 4K+ :
Is this a limitation of the Vero V ?

No - we will be able to get this solved for you. The fact you know how to use SSH is excellent and means we will be able to fix it fast for you.

Can you please upload logs from the Vero 4K + so I can see how your TV is being handled there.

We will then be able to work out how to resolve it for Vero V and send you a test build.

Thanks for your cooperation. I am sure this will help other users too.

For a quick fix, please try
touch ~/.kodi/userdata/vesa_cap
and reboot.

We should have a fix for this. I’ll make this available for testing shortly.



Hopefully the issue is now addressed

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Run the following command to add the staging repository:
    echo 'deb bullseye-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list
  3. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  4. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you remove /etc/apt/sources.list.d/osmc-devel.list after updating.

This will deactivate the staging repository. You can do so with the following command:
sudo rm /etc/apt/sources.list.d/osmc-devel.list.

Please note that we will automatically disable this update channel after 14 days on your device in case you forget to do so to ensure that your system reverts to the stable update channel.

Hi Sam,

I used your update and the Vero works fine now, thanks a lot !

I have the same problem. The Vero V finally arrived after 4 weeks. The Vero V tries to boot but the sad smiley appears and it doesn’t go any further. What can I do?

I think the Vero V boots itself without having to install any software. It just doesn’t boot! Why is this so complicated?

Sorry to hear this. You should be able to reinstall the software to solve this issue.

See Reinstalling OSMC - Vero V - OSMC

I am not sure if this is the same issue you are experiencing but the latest version of OSMC fixes the sad face the original user experienced.

Alternatively I can give you instructions on how to SSH and update the device.

As you can imagine the bug (if it’s the same as the one reported by the user above) was discovered rather late after we had prepackaged a large number of units to deal with the launch.

I can only apologise about such a significant delay. Please PM me your order number so I can investigate this further and improve this.

OSMC is reinstalled and it booted. Unfortunately I can’t get the remote control to pair. I press the ok button and the house button. But nothing happened. The battery contact protection has been removed.

Running now! The battery supplied was completely empty!

I am glad things are now running as expected


A question. For films I am offered the Scraper TV Movie Database Pyton. Vero 4K+ also had the TV Movie Database add-on. Why is the bel Vero V no longer available? And for series I can only select the TMDb TV Shows scraper. TV Movie Database Python is not offered to me. Is that correct? With Vero VK+ I was also able to scrape series via The Movie Database.

Did you mean TVDB? On a clean install you only have the default (and team Kodi prefered) scrapers installed. The have gone through a few revisions, the naming is confusing, but what you have is the current TMDB scrapers that one should be using if you want to scrape from that site. If you wanted to use TVDB or IMDB scrapers then you have to install them from Kodi’s repository and you will find them under the information providers section.

TVDB is not present in Kodi’s repository!

Also a new problem. If you play films in 3840x2160p, only a small window is displayed at the top left and not the full screen.

Are you sure your going to install from repository and not the my add-ons section? I just took a look and it is showing up for me.

Sorry about that. The following gives instructions on how to fix it…

Sorry. I meant IMDB. I can’t find the scraper in the Kodi Kodi repository to install. Or does it call itself something else now? And I can’t find TMDB scraper either, only TMDB Python. TMDB Python doesn’t allow for series scraping. With the Vero 4K+ I was able to scraping series with TMDB. I can’t find this addon anymore!

The hotfix seems to be working. The image is now full size. Thanks for that!

And another problem. No matter which weather addon I install. The “Weather” section always shows me 0 degrees and not the correct temperature.