No audio device present but hdmi video snd_bcm2835


running RPI3 and osmc version:

osmc@osmcNEU:~$ grep Kodi .kodi/temp/kodi.log | head -3
2021-11-16 17:52:33.866 T:404      INFO <general>: Starting Kodi (19.1). Platform: Linux ARM (Thumb) 32-bit
2021-11-16 17:52:33.866 T:404      INFO <general>: Using Release Kodi x32
2021-11-16 17:52:33.866 T:404      INFO <general>: Kodi compiled 2021-09-14 by GCC 8.3.0 for Linux ARM (Thumb) 32-bit version 5.10.22 (330262)

Strangwise hdmi audio is not working.

In config.txt I added some hdmi settings - should be like hdmi save - without success.


in dmesg it looks like hdmi is enabled

osmc@osmcNEU:~$ journalctl | grep snd_bcm2835
Feb 14 11:11:58 osmcNEU kernel: Kernel command line: coherent_pool=1M 8250.nr_uarts=0 snd_bcm2835.enable_compat_alsa=0 snd_bcm2835.enable_hdmi=1  vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  root=/dev/mmcblk0p2 rootfstype=ext4 rootwait quiet osmcdev=rbp2

2021-11-16 15:06:58.091 T:1913     INFO <general>: CAESinkALSA - Unable to open device "default" for playback
2021-11-16 15:06:58.104 T:1913     INFO <general>: No Devices found - retry: 4

anyone experienced similar topics?

Thanks a lot

Yes. @nimbleguardian did. but he got no video and neither did I. Did you get a picture?

I found just reverting the kernel fixes it.

sudo apt-get install rbp2-image-5.10.32-2-osmc --reinstall


ok thanks, will check that.

It used to work before I did some updates…
but was not using it for awhile

It seems you are on the staging repo (buster-devel) which is still in testing.

ok, let me check the repo,
still not working after

sudo apt-get install rbp2-image-5.10.32-2-osmc --reinstall


deb buster main

deb buster-devel main

so will delete the buster-devel.

Will check

still note working

how to downgrade to 18.8?

which sources to be used?

You did reboot, yes?

You cannot downgrade from Kodi v19 to Kodi v18.x.
If you took a backup, you could reinstall an older version and update.

ok thanks,

will check

is this only entry correct for osmc in sources?
deb buster main

running 19.1.0-17

still no audio device present

is there a way to get hdmi audio in kodi 19.x?
or should I use kodi 18 fresh install?

did several reboots

Please post some logs so we can check package versions.


thanks for checking

What’s the output of

aplay -l
aplay -L

You may have to

sudo apt-get update && sudo apt-get install alsa-utils

to get aplay.

Had to install alsa

resultaplay: device_list:272: no soundcards found... osmc@osmcNEU:~$ aplay -L null Discard all samples (playback) or generate zero samples (capture)
Video is working, stange

So sound is totally borked. I can only suggest backup and reinstall.

ok thanks, will do that.

No need to reinstall, your problem comes from here


The fkms seems not to provide any audio device.

You could try to add dtoverlay=audio=on

You could try to add `dtoverlay=audio=on

thanks, did not try that ,
but this did the trick.


Thanks a lot for your help…!!!


did use fkms because of: