No connetion to the network server

After updating to Kodi 18.9, I can not find my distributed folders in my home network (SMB)
When I want to add a new source, I see nothing.
When I click on a distributed folder, it will say “Operation not permitted” and then “Could not connect `to the network server”.
Can I go back so I get a working version or is there an easy way to fix the problem?

What server are you using for the SMB?
Most people who had this issue were able to fix it with changing SMB protocol versions.
While the source of the issue is not fully clear to me.
Check out this three threads:

Could there be something with the password in Vero?
When I try to log in with PuTTY I get “Access denied”

Normally not. Did you ever changed it? Otherwise it would be user osmc and password osmc!
If that is not working and you never changed it something might be more seriously wrong

I used the default password and then it worked.

If I want to extract “SMB component logging” which command do I use then?

And if the password has expired, is it on my computer or in kodi ?
How to change it?

sorry, I’m not that good at this :slight_smile:

I can access kodi from my computer but when I want to add a path from kodi via SMB I do not see the network.
The working group is the same as I had before the update

Yes, that would be on the computer.
Is it a windows 10 machine or what?

Can either go via Gui - MyOSMC -> Log Uploader, or alternative if you logged in via SSH use grab-logs -A

Yes is a Win 10 machine.

Here is the log:

Thanks, but in that log you didn’t enable the debug logging nor the SMB component specific logging (see explanation below).

But first you can try in Settings → Services → SMB Client, To disable legacy Security and put min protocol to 3

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for SMB components

  • enable event logging and notification event logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshots:

The problem:
When I log in to my home network with kodi, I can not see the distributed folders.
It’s a Windows 10 network that I run with SMB.
This worked before the last update.

I enabled logging and then tried to open a shared folder.
Then “Operation not permitted” and “could not connect to network server” appear.

Here is the log file:

Seems you didn’t disabled “legacy security” try that first.
Also not sure, you configured as winsserver is that your windows machine>

Seems you didn’t disabled “legacy security” try that first.
I couldn´t change it, it´s gray marked

Also not sure, you configured as winsserver is that your windows machine>
It´s my router

Yeah seems we grey it out when SMB3 is selected. Guys it doesn’t make a difference. But maybe shortly set both Protocol to SMB1 then you should be able to disable that setting then set again to SMB3.

Generally do you know the user/password you used to access your Win10 from Kodi or did you use Guest Account?

Would either leave it empty or choose your Windows IP.

If I use SMB1 it´s working

You mean the connection to server is working?

Yes, and when I put SMB3 I have no connection.

Can I have SMB1 ?

Yes you can use SMB1, but be aware:

  1. It is less secure and less performant than SMB3
  2. Actually Win10 has started to disable SMB1 since 12 month therefore I am suprized that worked for you. (Win10 will keep it active currently when you use it within the last 3 months but that might change with future updates)

Ok then I know.
I use SMB1 for so long and I will try to fix it later.

Many thanks for your commitment and help :slight_smile:

Was you issue that existing sources and scraped content could not be accessed using SMBv3 or only browsing the network was no longer working. If the only thing that stopped working was browsing then that is expected behavior.

A method to allow for easy addition of multiple sources from the same machine is to go to
Settings > Media > Library > (Manage Sources) Videos > Add videos > Browse > Add Network Location >
In that screen you would manually enter the computer name or IP address of the computer your connecting to and your credentials. Once you have done that when you go to add a source instead of going to Browse > Windows network (SMB) you will go to Browse > [what you put in the name field] and you should be able to see and browse the shares on that source without issue.