Still (SMB) network share problems after oct/nov updates

Hello All,

My network shares are still not accessible after the october and november updates.
To be sure I did a fresh install (june image) on my Vero4k+.
Only thing I’ve changed in the fresh install is de min and max SMB client to v3.
After setting up the network share, with IP address as a server and a username + password the share works just fine

The logfile:

After this I did the OSMC update to the november build (Kodi 18.9) and changed nothing to the settings.
When opening my network share I get the message “ operation not permitted”

The logfile:

I’ve also checked the above with a fresh october image and it shows the same error message.

So this leads me to believe something is wrong in the october and november updates?
Any ideas anyone?

But last time you wrote it worked after you changed to use IP address?

Yes it worked for a couple of weeks and then it suddenly stopped working. Could be that another update was installed. So to be sure there was nothing else involved I did a fresh installation of the june/october/nov builds.

If you want to investigate this you would need to enable “Component Specific logs” for SMB.
Maybe we can see something from there.

Alternative is to ignore the Kodi SMB implementation and go for Kernel mounts (fstab or autofs).

here the link for the specific SMB component logging

SPNEGO login failed: The user account password has expired.

1 Like

That was the problem! Didn’t know this password could expire.
I’ve set it to " never expire" and this solved the problem.
This was probably also the fix in the earlier problem I’ve had.

Thanks for the help!