No March update available?

Hi, I have Nov 2021 2021.11-2 version.

I’ve tried the manual update and it doesn’t offer a new version, what can I do to fix this?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Here you go…


Not seeing anything obvious, can you please provide the output of the manual update?

Thanks Tom.

1 Like

Ah, missed this before. My Vero is connected fine, I stream wirelessly from a NAS. Tried another SSID, same issue.

Video of it here

Can I update manually by command line?


sudo apt-get update && sudo apt-get dist-upgrade


This is the output I get


Either used the hotfix or try the other 2 solutions mentioned.

Thanks Tom.

1 Like

This one worked

1 Like