No Network access to files

I haven’t use my device for a while, & when using, it’s not “finding” my music?

I’ve got a Win 10 PC, Vero connected via wired ethernet, & I can access the device via browser or Ios App. All my folders are set as network-shared,but if I go into Add Files, then specify location using Device-name (ie Acer-MB), I get an error “Invalid Syntax”.
If I use IP address, either with or without username & password, it just shows a message saying timeout, & no network connection?
I’ve tried changing Max SMB to v1, then back to v3, but nothing seems to work? I have SMB v1 enabled in Windows features settings.
This is the guide I was following:
Any help would be most appreciated…

Go to Settings > Media > Videos > Add videos > Browse > Add Network Location >

Make sure the protocol is set to SMB and in the “Server Name” field click on it and manually type in the computers device name or IP address, your credentials, and then click OK. Don’t type in any additional network path at this point. Now instead of going to Browse > Windows network (SMB) you will go to Browse > [the location you added] and you should be able to see and browse the shares on your computer.

thanks for the reply. I did a full, fresh install, & re-added files using similar method above. Not sure if it was coincidental (or not), but I switched off SMB V1 on Windows Features on my PC.
All was working fine, then overnight “something” changed, & all file-access was timing-out. The only event was that PC goes into sleep mode after inactivity.
I re-booted PC, & Vero was fine after that, all network files were accessible, so guessing something to do with network / PC?
I’ll try disabling sleep mode on desktop today, see whether that makes things more stable…

Kodi tends to try to access a network file and if it fails it refuses to bother trying again for that same file until it has played some other file. The default delay IIRC is rather short and if your network share is slow to respond this would be expected behavior. You could try changing settings>system>power saving> for both time to wait and potentially the try to wakeup option.

Generally speaking it tends to be problematic to allow network resources to go into sleep mode. I played with it in the past and came to the conclusion that it wasn’t worth the headaches. I’ll let my drives spin down, but I don’t let the computer itself go to sleep or suspend.

1 Like

thanks, is this the option:

Maximum wait time for network

If so, what would you suggest is a sensible value?

Yes. The option means what it says in that it is the amount of time it waits for a response before timing out and assuming the file is not available. Likely you want to set it whatever its longest value is in your situation. If the file is available immediately a longer wait time shouldn’t impact how long it takes to open.

ok, great. Do you know what the format of the value is, ie is it # seconds?

It would be seconds. I don’t have a definitive solution for you here. I’m suggesting you just play with the wait time and wakeup options in Kodi and see if you find something that works for your particular setup. There really isn’t any risk of breaking anything here so you should feel free to muck about all you want.

1 Like

ok, worked fine for a few days, but when I rebooted my PC, Vero couldn’t get a network connection (wired) for file access. I tried a Vero reboot, then disable/enable the ethernet, still no joy.
I then switched to wireless, which works ok, but is slow for the large libraries.

Any ideas as to why wired will not re-establish after a PC reboot?


The Vero was connecting to your PC via ethernet and then you rebooted you PC and then lost connection, but then unplugged (?) your ethernet cable on your Vero and connected via WiFi and you could then establish a connection to your PC again? That sounds like there is a missing piece of information. If your PC wasn’t running a static IP and it changed with the reboot, or you were using a hostname and it wasn’t resolving I could see a reason for the Vero to have issues, but I’d expect the same issues with wireless as wired. If you switch back to ethernet can you successfully ping the PC from the Vero (ssh into the Vero and run ping -c 10 but using the IP address of your PC of course)

Hi - I didn’t disconnect cables, just “switched off” the ethernet adapter option in the Vero menu, then enabled wireless. This meant the IP would remain unchanged.

I have since tested, then did the opposite, ie switch off wireless, then re-enable wired adapter, & it has re-established connection, & all works ok.

I’m just confused why I need to go through this routine, I would have thought even a reboot of the Vero after a PC outage would have been sufficient to re-establish network connection?

The IP address will change if you do this and you are using DHCP.

The MAC for WiFi and Ethernet are different

Sorry, what I meant was that the IP for the ethernet connection remained unchanged, even if I disable then re-enable the adapter via menu option.
I realise that Wi-Fi & ethernet will have different IP’s.

Don’t disable the ethernet with the button in My OSMC, I think that currently causes issues. I was referring to the IP address of your PC possibly changing during the reboot so the existing connection with the Vero’s ethernet may have no longer been resolving to the correct address. By switching to the wired network perhaps it kicked off a refresh. If you’ve not set your IP address for the PC your sharing files from as static I’d encourage you to do so. Additionally I’d note that it is preferable to set an IP as static in your router/DHCP server to avoid conflicts, or at least make sure that your DHCP server is handing out addresses in a limited range and any manually set addresses on client devices are set unique and outside of that address space.

IP of the PC is static, so I know that both IP on PC & vero are unchanged when reboots take place. I had the PC off overnight, powered it on this morning, & Vero cannot access shared drives (via wired).
Again, tried Vero reboot, router re-boot, still no joy?

Log might give some clues


I’ve just enabled wireless, & it works fine, but slow. If I switch off wireless, wired shows connected (in My OSMC), but any access to files gives a timeout / couldn’t connect to network error?

Just can’t identify why sometimes it works, other times it won’t?

edit: just uploaded log:

For some reason Kodi’s internal DNS resolver isn’t working. No clue why. I’d rebuild your library with your sources changed to the PC’s IP address or do a path substitution to get the same end result. For path substitution you would use something like…


But using the PC’s actual IP address where I typed in Further instructions can be found in the following howto…

ok, have created a alt path to one of my sources using IP instead of DNS ,switched from wireless back to ethernet, & that seems to work ok.

Strange thing is, even access to the original sources (still using DNS) now work…

Still baffled :slight_smile:

1 Like

sorry, meant to ask, can you point me to a guide which would assist in how I’d make changes such as the advancedsettings file please?

I’ve installed PuttY & can connect to me box, but after that I’m a bit stumped!