Old Vero 1 remote with Vero 4K

Is it possible to get this to work? Is the IR receiver in the Vero 4K disabled by default? How do I make my old remote work?

Use the newer one if you can. It uses RF and doesn’t rely on IR (line of sight).

Most remotes should work: you can select the OSMC remote under OSMC -> Remotes.

Sam

Well I want to use my Logitech Harmony which is IR (and I used to control my Vero 1). I’m really bummed if the Vero 4K supports IR remotes but not the Vero 1 remote.

I did select OSMC remote under remotes in My OSMC but it didn’t make any difference.

The Vero 4K supports IR remotes.

I think you may want to use a different profile with Harmony. This was actually discussed today: Logitech Harmony support. A couple of users have it running.

I’ll check the Vero 1 remote tomorrow when I get a chance.

Cheers,

Sam

I saw that thread before but most of it is greek to me. I’ll try Windows remote MCE and see if it works. I don’t really understand why the IR is not just backwards compatible OOTB with a Vero 1 remote.

i got it to work but i have selected the samsung tv remote in osmc as i have a samsung.

Than on myharmony config app learn every command like enter, left etc. and lern it from ur tv remote or something else.

This works for me.

But better use a remote from a device that is not running at the same time when using vero 4k otherwhise the original device will also respond to the commands.

We’re aware of a bug that is causing the IR protocol used by the original white OSMC remote to not be decoded properly on the Vero 4k, so at the moment a white OSMC remote won’t work with it, however most other IR remotes will work.

For example I have successfully used my Xbox 360 media remote and also an original white Apple remote with the Vero4k using the built in profiles in My OSMC.

This bug is on our list of things to fix however given that the device ships bundled with an RF remote that does work and is identical in function to the old white remote there are a couple of other higher priority fixes that are being worked on first before we come back to this problem. The white remote not working is nothing deliberate, just an unforeseen bug in the way the IR driver works.

Hi Everybody,

glad to read that this issue is being worked on. I really assumed I could use the old vero 1 remote commands on my Harmony. (Same workaround as described before via having the Logitech Harmony “learn” its commands.)
It took me a while to find this thread and I just want to share that this would be a great thing to have fixed soon.

Thanks for your work!

The easiest solution for now is to use MCE commands instead as those will work out of the box on your Harmony.

Easiest for whom? You guys break something and then won’t fix it!
So it’s easiest for YOU if I add an MCE remote to my harmony and screw around setting that up all because you don’t want to fix something you broke.
You know I sent you money and supported you even before I got my vero 1 and now a vero 4. It’s not like I’m just bludging on you. Is it too much to expect you to fix stuff you break???

Hu? You started off this this:

And you you are complaining about the Vero 1 remote??? Make up your mind!

My harmony is programmed for years with the vero 1 remote.

Make up my mind about what?

I think you misunderstand.
I’m not asking you add another remote to your setup.

I’m suggesting you use an MCE profile on the Harmony. Then the remote will work out of the box with default profiles in My OSMC -> Remotes and you will have more buttons than the original Vero remote had. This is what most people using a Harmony do.

In terms of the remote not working on the Vero 4K. We didn’t break it, we didn’t add support for it. It’s not common for people to use the old Vero 1 remote on a Vero 4K, and we don’t ship this combination of hardware. I will look at adding support shortly however.

The much easier solution in the interim is to program the Harmony as an Xbox Remote or something and select Xbox Remote in My OSMC. This will give you more button controls as well

I have no idea how I can use an MCE profile on my harmony. To me that sounds like I have to ADD an MCE remote to my harmony setup and edit my activity to use that and reset all the buttons for the activity.

Ok so you didn’t break it but it’s a BUG you are aware of that you haven’t fixed. Right?

I’m just amazed you didn’t foresee that people would want to do this or even remotely think this wouldn’t work out of the box when they ‘upgraded’ to a Vero 4…

I added a game console xbox 360 and I can’t get it to work even when I select xbox360 as remote type in remotes section od OSMC. What am I missing?

Does it have to be paired somehow? I also tried MCE keyboard. Nothing works.

I understand your frustration. We are looking in to adding support for RC5 (the protocol the Vero 1 remote used) remotes soon.

Did you try rebooting after setting the remote profile?

Sam

Yeah I just tried a few different ones in OSMC, with and without RC6 support checked but none of them are working with the Microsoft MCE Keyboard remote I last tried. I rebooted OSMC between every change. I tried the XBOX360 and also the MCE remote in OSMC. Nothing works.

RC6/MCE remotes will work – check battery and use a camera without IR filter (usually front facing) to check a signal is being sent

Sam

That’s why I asked if I was missing anything else. Clearly some people have it working. I don’t. Which remote should I select in OSMC configuration? Should I disable or enable RC6? I checked that the remote has it’s buttons configured for the MCE keyboard and I can see it is transmitting when I press a button.