OSMC Alpha 2

Originally published at: http://osmc.tv/2014/12/osmc-alpha-2/
Hi everyone, I hope you’re having a wonderful Christmas. As you may have heard, Kodi 14.0 is now final and has been released. This has been made available as an update to Raspbmc users while I work on getting OSMC in to a more usable form. I’m trying to get through our alpha phase quickly…

Any easy way to upgrade to Alpha 2 from Alpha 1?

I tried Sudo apt-get dist -upgrade and no upgrade found and hasn’t done anything. Still only have exit option

Seems like playback of video from within RAR files is broken. Sometimes nothing happens and sometimes audio is playing with the spinning squares animation in the background on the GUI. Access to the files is via SMB share on a NAS on wired network.

EDIT: Found the answer. “Support browsing into archives” is not enabled by default. Maybe it should be? Especially for the upcoming Vero?

Not at this time. I’d advise you don’t customise Alpha builds too much as they are just here for testing now and are not suitable for use in the long term.

If you’ve tried to run

apt-get dist-upgrade
on an Alpha 2 build, the reason this hasn’t done anything is because the packages are already up to date (built last night).

I don’t plan to enable this by default. Decompressing archives on the fly while playing content is quite taxing on the CPU and for the minimal storage saving I’d recommend just storing them as single video files.

If I do this on an Alpha1, I get lots of updates available.
Will this get me to Alpha2 level?

[edit]
Hm, this doesn’t seem to be going very well…

No. As I explained at http://osmc.tv in the announcement, apt-get dist-upgrade on Alpha 1 will not work. You need to install fresh. The packages are broken in Alpha 1 which prevents properly upgrading them. You can remove the post&pre rules in dpkg, but there’s no guarantee this will work as expected.

I can understand the thinking behind this. However, the reason many have RAR-packed files is that they come like that on certain places on the net. These archives does not have any compression at all, so there is very little stress on the CPU on these. The reason I suggested that I think it would eliminate a few support questions from users since XBMC had this on by default before. I also thought the behavior when the option was turned off was a bit odd too. That the videofiles audio started playing in the background and sometimes weird sounding audio. Instead maybe a popup that browsing inside archives is disabled and can be enabled in the settings. I realise that this is a thing that should be addressed to the Kodi developers, but just my two cents. Looking forward to the final release on my pre-ordered Vero and R-pi. :smile:

There is no installer for Fedora 21. Tried Fedora 20 packages, but there are some dependencies unmet (libjpeg, libpng and more). Would be nice if there was some other way to use the installer.

PS. The Google and Facebook login to this discussion system don’t work.

Running super :smile: … but what is the command to restart kodi from the command line?
The same for hyperion, i tried ‘initctl restart hyperion’, but that doesn’t seem to work anymore.

We can enable it by default in OSMC and I’ll pilot that.

OBS is still not offering Fedora 21 yet so I can’t provide binaries for that yet I’m afraid. Stay tuned.

Can you explain what happens? I haven’t tried Google yet but Facebook should not be giving any issues. What happens on login?

We use systemd now, so initctl (Upstart) is deprecated. Hyperion is not shipping yet as this is an Alpha build! We plan to ship Hyperion in our app store.

I just found here http://osmc.tv/help/wiki/init-kodi/ that it should be ‘systemctl start mediacenter’ instead of kodi or xbmc, now to find out what the command is for hyperion :smile:

[edit]found it ‘systemctl restart hyperion’!

Oups, must have missed (or already forgot :-D) that.
Are you planning on implementing this?
For now, can I just copy over the .kodi-folder to a fresh install to recover my Kodi-settings?

Might work… Lot of things changing from build to build so, no guarantees…

Yes, copying over .kodi will work.

In the future: we will ship an update addon that will be an interface to apt-get. apt-get dist-upgrade will work, but we recommend you stick with our UI addon when it does ship which handles things a bit more nicely.

Anyone got AirPlay working with iOS 8 / OSX10.10 btw?
Tested with a few streams and YouTube as well, but couldn’t see my RPi in the list … :fearful:

Hi

Don’t have an iOS device here, but heard there are some issues with the native YouTube app and you should do it through Safari instead. Does that help at all?

Make sure you’re on Alpha 2: Alpha 1 had a broken AirPlay implementation

Sam

The only way I got it sort of working … it took quite some effort … was to play through Instatube
But that was possible before Kodi as well, Yosemite and iOS8 native atleast won’t show the RPi as an option :frowning:
Ooh and I’m on Alpha 2 of course :wink:

Facebook login gives this:

App Not Setup: The developers of this app have not set up this app properly for Facebook Login.

Google login:

Error: redirect_uri_mismatch

Application: Discourse Forum

The redirect URI in the request: http://discourse.osmc.tv/auth/google_oauth2/callback did not match a registered redirect URI.

This runs great on rpi b+ much quicker than raspbmc nice work seems quite stable so far had no issues.

The manual ip address configuration seems to be broken when using the windows installer. I am using a wired connection. Couldnt try the linux one as no support for fedora 21.

Also when I set dns via connmanctl 127.0.0.1 remains in resolv.conf is this expected behaviour? I can resolve names so it does work just seemed odd to me.

Any info on getting chromium going on osmc or having it built and put in to the repos as I would quite like it so I can get netflixbmc and youtube going.

Will there be an upgrade to final stable from alpha 2?

Cheers

Chris